Составьте диалог пользователя с компьютером на произвольную тему?

Информатика | 10 - 11 классы

Составьте диалог пользователя с компьютером на произвольную тему.

Например, машина задает два вопроса “Как тебя зовут?

” и “Сколько тебе лет?

” ; после введения имени (Антон) и числа (15) выводит на экран “Да.

Через 50 лет тебе уже будет 65 лет, а звать тебя будут не Антон, а дед Антон”.

Ответить на вопрос
Ответы (1)
Анико7 10 июл. 2020 г., 07:49:58

Program R ;

uses crt ;

Var a, c, d, l, k : String[50] ; b : integer ;

Begin

Writeln('Привет!

') ;

Writeln('Давай познакомимся!

Как тебя зовут?

') ;

Readln(a) ;

Writeln('Очень приятно, ', a, '!

', 'А меня зовут Евгений.

') ;

Writeln('Сколько тебе лет?

') ;

Readln(b) ;

if (a = 'Антон' and b = 15) then

Writeln('Да.

Через 50 лет тебе уже будет 65 лет, а звать тебя будут не Антон, а дед Антон') ;

Writeln('Мне тоже, ' b, '!

') ;

Writeln('Какую музыку ты любишь слушать?

') ;

Readln(c) ;

Writeln('Ничего себе!

Да у нас похожие вкусы!

Ведь я тоже люблю слушать ', c) ;

Writeln('Какое время года ты любишь?

') ;

Readln(d) ;

Writeln('Я тоже обожаю ', d) ;

Writeln('Какой твой любимый цвет?

') ;

Readln(l) ;

Writeln('Мне кажется, мы во многом похожи.

Это и мой любимый цвет.

') ;

Writeln('Кто ты по знаку зодиака?

') ;

Readln(k) ;

Writeln('Надо же!

Я тоже ', k, '.

') ;

Writeln('Было очень приятно познакомиться и поговорить, ' a, '!

Пока!

') ;

End.

Александра2044 23 мая 2020 г., 14:04:26 | 1 - 4 классы

Если Володины марки сложить с Алешиными и из общего количества убрать 12 марок, то получится количество марок у Антона?

Если Володины марки сложить с Алешиными и из общего количества убрать 12 марок, то получится количество марок у Антона.

У Володи на 22 марки меньше, чем у Антона.

Сосчитай, сколько марок у Володи и сколько у Алеши, если у Антона 43 марки?

Glavagosydarstva 26 дек. 2020 г., 19:31:39 | 5 - 9 классы

Составить программу, которая по введенному возрасту пользователя сообщает, к какой возрастной группе он относится : До 13 лет – детство ; От 14 до 24 лет – молодость ; От 25 до 59 лет – зрелость ; От ?

Составить программу, которая по введенному возрасту пользователя сообщает, к какой возрастной группе он относится : До 13 лет – детство ; От 14 до 24 лет – молодость ; От 25 до 59 лет – зрелость ; От 60 лет – старость.

Ксения550 19 мар. 2020 г., 23:43:22 | 5 - 9 классы

Составьте программу , которая возводит в квадрат введенное целое число, если оно отрицательное , и выводит на экран результат?

Составьте программу , которая возводит в квадрат введенное целое число, если оно отрицательное , и выводит на экран результат.

Unnamed11 24 окт. 2020 г., 00:36:03 | 5 - 9 классы

ПОМОГИТЕЕЕ?

ПОМОГИТЕЕЕ!

59 пунктов и лучшее решение будет, если будут пояснения

№11.

В зависимости от введённого пользователем возраста (от 1 до 99 лет)

вывести сообщение о том.

Сколько пользователю лет.

Предусмотреть

ситуацию, что может быть :

«Тебе 7 лет».

«Тебе 2 года».

«Тебе 23 года».

«Тебе 1 год»

для любого числа.

№12. Пользователь вводит число и месяц не високосного года.

Вывести дату

следующего дня.

Например :

Дано : 1 января.

Вывод : 2 января

Дано : 28 февраля.

Вывод : 1 марта

Дано : 31 декабря.

Вывод : 1 января

№13.

Даны год.

Месяц и число рождения двух человек.

Определить, кто из

них старше.

Примечание ;

Предусмотреть ситуации :

1.

Люди родились в разные года

2.

Люди родились в один год.

Но разные месяцы

3.

Люди родились в один год.

Разные месяцы, но разные дни.

4. Люди родились в один год.

Месяц и день.

ЖЕЛАТЕЛЬНО С ПОЯСНЕНИЯМИ, ЧТО К ЧЕМУ.

Volospolina148 22 апр. 2020 г., 04:18:25 | 5 - 9 классы

Создайте приложение «5 лет назад», которое через области ввода запрашивает у пользователя имя и возраст?

Создайте приложение «5 лет назад», которое через области ввода запрашивает у пользователя имя и возраст.

А при нажатии на кнопку в заголовке формы выводит надпись с именем и возрастом, который был 5 лет назад.

Например, ввели имя «Вася», а возраст «17» лет, то приложение должно выдать «Вася, 5 лет назад Вам было 12».

Причем если было введено число меньше 5, то приложение выводит «Вы еще не родились».

Akazama 27 мая 2020 г., 00:30:36 | 5 - 9 классы

Создайте приложение «5 лет назад», которое через области ввода запрашивает у пользователя имя и возраст?

Создайте приложение «5 лет назад», которое через области ввода запрашивает у пользователя имя и возраст.

А при нажатии на кнопку в заголовке формы выводит надпись с именем и возрастом, который был 5 лет назад.

Например, ввели имя «Вася», а возраст «17» лет, то приложение должно выдать «Вася, 5 лет назад Вам было 12».

Причем если было введено число меньше 5, то приложение выводит «Вы еще не родились».

Покер666 16 авг. 2020 г., 15:24:21 | 1 - 4 классы

Инопланетянина с планеты элзика спросили : "сколько тебе лет?

Инопланетянина с планеты элзика спросили : "сколько тебе лет?

"он ответил : "если я проживу ещё половину того, что прожил, мне будет 99лет"сколько лет инопланетянину?

Hkrn 14 июн. 2020 г., 18:31:33 | 5 - 9 классы

Составьте программ, реализующая следующее условие : требуется ввести десять имен пользователей?

Составьте программ, реализующая следующее условие : требуется ввести десять имен пользователей.

Компьютер "знает" имена : Катя, Ваня, Сережа, Антон.

После ввода имен пользователей выводится следующая информация : а) В диалоговую панель : Ввод пользователей завершен б) В диалоговую панель : Количество знакомых имен = в) В диалоговую панель : Количество незнакомых имен = г) В окно браузера отображаются все введенные имена пользователей.

Gorinanastyyya 30 авг. 2020 г., 08:32:29 | 5 - 9 классы

Возраст Бори и его компьютера в сумме составляет 10 лет?

Возраст Бори и его компьютера в сумме составляет 10 лет.

Если Борин компьютер проживет еще 3 года, то по окончании этого срока возраст Бори и его компьютера в сумме составит … Выберите один ответ : 13 лет 7 лет 16 лет 20 лет 10 лет.

RozaAmerkhanova 31 дек. 2020 г., 22:51:53 | 10 - 11 классы

Разработайте программу в паскаль, которая запрашивает у пользователя возраст мужчины и, в зависимости от введенного значения, выводит на экран результат из списка : до 9 лет – дитя ; до 12 лет – отрок?

Разработайте программу в паскаль, которая запрашивает у пользователя возраст мужчины и, в зависимости от введенного значения, выводит на экран результат из списка : до 9 лет – дитя ; до 12 лет – отрок ; до 18 лет – юноша ; до 24 лет – молодой человек ; до 60 лет – мужчина ; старше 60 лет – старик.

Вопрос Составьте диалог пользователя с компьютером на произвольную тему?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.