Паскаль?

Информатика | 10 - 11 классы

Паскаль!

Заполните массив случайными числами и найти минимальный и максимальный элементы массива и их номера.

Пример : Массив : 1 2 3 4 5 Минимальный элемент : A[1] = 1 Максимальный элемент : A[5] = 5.

Ответить на вопрос
Ответы (1)
23046847367646 19 янв. 2020 г., 23:36:08

Const

n = 10 ;

var i, amin, amax, imin, imax : integer ;

a : array[1.

N] of integer ;

begin

for i : = 1 to n do

a[i] : = random(30) ;

writeln('Полученный массив : ') ;

for i : = 1 to n do

write(a[i] : 4) ;

writeln ;

imax : = 1 ;

imin : = 1 ;

amax : = a[1] ;

amin : = a[1] ;

for i : = 1 to n do

if a[i]> ; amax then

beginamax : = a[i] ; imax : = iend else

beginamin : = a[i] ; imin : = i ; end ;

writeln('A[', imin, '] = ', a[imin]) ;

writeln('A[', imax, '] = ', a[imax]) ;

end.

Nura0809 6 июн. 2020 г., 17:08:31 | 10 - 11 классы

Паскаль?

Паскаль!

Заполните массив случайными числами и найти два максимальных элемента массива и их номера.

Пример : Массив : 5 5 3 4 1 Максимальный элемент : A[1] = 5 Второй максимум : A[2] = 5.

FroZen007 14 нояб. 2020 г., 19:08:11 | 10 - 11 классы

Напишите программу пожалуйста в паскалепроизведение элементов массива, расположенных между максимальным и минимальным элементами ?

Напишите программу пожалуйста в паскале

произведение элементов массива, расположенных между максимальным и минимальным элементами ;

Hiperst29 21 янв. 2020 г., 10:28:24 | 5 - 9 классы

Help?

Help!

Задать случайным образом массив.

Найти минимальную сумму трёх подряд идущих элементов массива.

Вывести номер первого элемента из тройки элементов с максимальной суммой.

(Паскаль) Кто может, напишите решение задачи, желательно с комментариями.

Рома127 11 апр. 2020 г., 09:47:12 | 10 - 11 классы

Посчитать сумму элементов массива, заполненного случайными числами, и произведение максимального и минимального элементов?

Посчитать сумму элементов массива, заполненного случайными числами, и произведение максимального и минимального элементов.

Rnastichenko 13 окт. 2020 г., 07:24:06 | 10 - 11 классы

Ввести с клавиатуры массив из 5 элементов, найти в нем максимальный и минимальный элементы и их номера?

Ввести с клавиатуры массив из 5 элементов, найти в нем максимальный и минимальный элементы и их номера.

Planetaokt 15 авг. 2020 г., 04:10:22 | 10 - 11 классы

Ребят нужно на СИ + + и на паскаль?

Ребят нужно на СИ + + и на паскаль!

Заполнить массив случайными числами и найти два максимальных элемента массива и их номера.

Пример : 5 5 3 4 1 Максимальный элемент : А(1) = 5 Второй максимум : А(2) = 5.

SpiderMan1997 3 авг. 2020 г., 10:04:59 | 10 - 11 классы

Написать в программу в паскале (сразу все) - найти максимальный и минимальный элемент в массиве?

Написать в программу в паскале (сразу все) - найти максимальный и минимальный элемент в массиве.

Irapris 13 нояб. 2020 г., 22:46:50 | 5 - 9 классы

Заполнить массив случайными числами?

Заполнить массив случайными числами.

Найти на сколько максимальный элемент массива больше минимального.

Очень надо.

Пожалуйста!

Sskant 23 окт. 2020 г., 08:12:23 | 5 - 9 классы

3) Заполнить массив случайными числами?

3) Заполнить массив случайными числами.

Найти на сколько максимальный элемент массива больше минимального.

Очень надо.

Пожалуйста!

Slideq 30 окт. 2020 г., 04:08:28 | 5 - 9 классы

Найти номера минимального и максимального элементов массива, в Паскале?

Найти номера минимального и максимального элементов массива, в Паскале.

На этой странице находится вопрос Паскаль?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.