Создать программу которую с клавиатуры вводится количество секунд, прошедших с начало суток, определить кол - во полных часов и мин?

Информатика | 5 - 9 классы

Создать программу которую с клавиатуры вводится количество секунд, прошедших с начало суток, определить кол - во полных часов и мин.

Прошедших сначало суток.

Ответить на вопрос
Ответы (2)
KiraLapina 25 дек. 2020 г., 08:01:24

Var s, m, h : integer ;

begin

readln(s) ;

h : = s div 3600 ;

m : = (s - h * 3600) div 60 ;

if m = 60 then

begin ; inc(h) ; m : = 0 ;

end ;

writeln(h, ' : ', m) ;

end.

Masterova201348 25 дек. 2020 г., 08:01:26

В часе 60 минут и 60 * 60 = 3600 секунд.

Следовательнонужно проверятьсколько раз входит в число секунд ваши интервалы :

var sec : integer ;

begin

readln(sec) ;

writeln('proshlo', sec div 3600, ' polnyhchasov ili', sec div 60, ' polyhminut') ;

end.

Zvezdochkina01 20 окт. 2020 г., 16:33:48 | 5 - 9 классы

Написать программу подсчета количества часов, минут и секунд в данном числе суток?

Написать программу подсчета количества часов, минут и секунд в данном числе суток.

Напишите на C + +.

3874618 29 нояб. 2020 г., 13:07:42 | 5 - 9 классы

С начала суток прошло n секунд?

С начала суток прошло n секунд.

Выведите на экран текущее время в формате часы минуты секунды.

Alinochkanekrasova 3 окт. 2020 г., 16:51:03 | 5 - 9 классы

Дано количество секунд сначала суток?

Дано количество секунд сначала суток.

Вычислить текущее время в виде количества часов, минут и секунд.

Valik7777777 11 окт. 2020 г., 14:48:30 | 5 - 9 классы

С начала суток прошло N секунд (N - целое)?

С начала суток прошло N секунд (N - целое).

Найти количество полных минут, прошедших с чала суток.

Yandeks234 4 мая 2020 г., 12:57:11 | 10 - 11 классы

Помогите пожалуйста с Excel Microsoft?

Помогите пожалуйста с Excel Microsoft.

С начала суток прошло n секунд (n – положительное вещественное число).

Средствами Microsoft Excel определить : а) сколько полных часов прошло с начала суток ; б) сколько полных минут прошло с начала очередного часа ; в) сколько полных секунд прошло с начала очередной минуты.

Решение целесообразно оформить следующим образом :

Lstava 29 авг. 2020 г., 16:10:38 | 10 - 11 классы

Написать программу с процедурой подсчет кол - во часов, минут, секунд в данном числе суток входные данные число суток?

Написать программу с процедурой подсчет кол - во часов, минут, секунд в данном числе суток входные данные число суток.

Vadimkostyuk 23 июн. 2020 г., 15:52:32 | 5 - 9 классы

Для заданного количества суток (s) определите количество часов (h), минут (m) и секунд (c)?

Для заданного количества суток (s) определите количество часов (h), минут (m) и секунд (c).

Составьте блок схему и напишите программу на языке Паскаль.

KISYNA 3 сент. 2020 г., 10:30:26 | 5 - 9 классы

Для заданного количества суток (tfh) требуется определить количество часов (h), минут (m) и секунд (с)?

Для заданного количества суток (tfh) требуется определить количество часов (h), минут (m) и секунд (с).

Кристина1309 2 янв. 2020 г., 13:51:03 | 5 - 9 классы

PASCAL ABC?

PASCAL ABC!

Составьте программу подсчета количества часов, минут и секунд в данном количестве суток.

Количество суток вводится с клавиатуры.

Anton12345566 21 апр. 2020 г., 17:31:08 | 5 - 9 классы

Создать программу которая вычисляет количество повторений буквы п в тексте текст вводит пользователь программы с клавиатуры?

Создать программу которая вычисляет количество повторений буквы п в тексте текст вводит пользователь программы с клавиатуры.

На странице вопроса Создать программу которую с клавиатуры вводится количество секунд, прошедших с начало суток, определить кол - во полных часов и мин? из категории Информатика вы найдете ответ для уровня учащихся 5 - 9 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.