1)Опишите на русском языке или одном из языков программирования алгоритм подсчета суммы произведений последовательных пар элементов в целочисленном массиве из 30 элементов?

Информатика | 10 - 11 классы

1)Опишите на русском языке или одном из языков программирования алгоритм подсчета суммы произведений последовательных пар элементов в целочисленном массиве из 30 элементов.

(Это означает, что нужно сосчитать сумму произведений первого и второго, третьего и четвертого, пятого и шестого элементов, и так далее.

) 2)Опишите на русском языке или одном из языков программирования алгоритм поиска номера первого из двух последовательных элементов в целочисленном массиве из 30 элементов, сумма которых максимальна (если таких пар несколько, то можно выбрать любую из них).

Ответить на вопрос
Ответы (1)
Marina5597 15 нояб. 2020 г., 12:59:15

Первый алгоритм :

const n = 30 ;

var a : array[1.

30] of integer ; s : longint ; i : integer ;

begin { формируем массив } Randomize ; Writeln('Элементы массива : ') ; for i : = 1 to n do begin a[i] : = Random(51) - 25 ; Write(a[i] : 4) end ; Writeln ; { собственно, алгоритм } s : = a[1] * a[2] ; i : = 3 ; while i< ; = n - 1 do begin s : = s + a[i] * a[i + 1] ; i : = i + 2 end ; Writeln('Сумма пар произведений равна ', s)

end.

Тестовое решение :

Элементы массива : 1 10 - 9 - 12 - 2 20 21 14 5 19 21 - 14 - 10 - 17 5 - 9 - 8 17 18 11 - 21 - 3 - 15 - 10 - 15 - 16 - 15 2 3 21

Сумма пар произведений равна 846

Второй алгоритм

const n = 30 ;

var a : array[1.

30] of integer ; smax, imax : longint ; i : integer ;

begin { формируем массив } Randomize ; Writeln('Элементы массива : ') ; for i : = 1 to n do begin a[i] : = Random(51) - 25 ; Write(a[i] : 4) end ; Writeln ; { собственно, алгоритм } smax : = a[1] + a[2] ; imax : = 1 ; for i : = 2 to n - 1 do if smax< ; a[i] + a[i + 1] then begin smax : = a[i] + a[i + 1] ; imax : = i end ; Writeln('Номер первого из пары элементов с максимальной суммой : ', imax)

end.

Тестовое решение :

Элементы массива : 23 13 - 11 - 1 - 18 20 - 23 1 - 21 - 10 7 15 - 2 24 - 18 - 22 - 13 12 - 16 22 19 - 14 - 14 - 14 19 15 8 - 15 - 19 - 22

Номер первого из пары элементов с максимальной суммой : 20.

Arrrrt 22 февр. 2020 г., 22:13:18 | 10 - 11 классы

2) Опишите на русском языке или одном из языков программирования алгоритм подсчета максимального количества подряд идущих отрицательных элементов в целочисленном массиве длины 30?

2) Опишите на русском языке или одном из языков программирования алгоритм подсчета максимального количества подряд идущих отрицательных элементов в целочисленном массиве длины 30.

На Паскале АБС.

Maxim12003 28 мая 2020 г., 13:08:15 | 5 - 9 классы

Дан целочисленный массив из 40 элементов?

Дан целочисленный массив из 40 элементов.

Элементы массива могут принимать произвольные значения.

Опишите на русском языке или на одном из языков программирования алгоритм, который находит и выводит номер элемента массива, наименее отличающегося от среднего арифметического всех его элементов.

Но лучше на языке Паскаль.

СеРёЖкА2708 6 янв. 2020 г., 01:30:20 | 10 - 11 классы

В целочисленный числовой массив из тридцати элементов значения вводятся с клавиатуры?

В целочисленный числовой массив из тридцати элементов значения вводятся с клавиатуры.

Составьте программу на одном из языков программирования, которая в данном числовом массиве находит три последовательных элемента, сумма которых максимальна.

Если таких троек несколько, то выбрать тройку с наименьшими порядковыми номерами.

СоняРыбакова 16 апр. 2020 г., 22:47:36 | 10 - 11 классы

Опишите на русском языке или на одном из языков программирования алгоритм определения количества положительных элементов квадратной матрицы, превышающих по величине среднее арифметическое всех элемент?

Опишите на русском языке или на одном из языков программирования алгоритм определения количества положительных элементов квадратной матрицы, превышающих по величине среднее арифметическое всех элементов главной диагонали.

Язык Паскаль.

Dianasmirnova 29 мая 2020 г., 16:47:09 | 10 - 11 классы

2) Дан целочисленный массив из 20 элементов, все элементы которого – целые числа в интервале от - 1000 до 1000?

2) Дан целочисленный массив из 20 элементов, все элементы которого – целые числа в интервале от - 1000 до 1000.

Опишите на русском языке или на одном из языков программирования алгоритм, который находит минимальное значение из всех нечетных элементов массива, которые делятся на 5.

Mmtrr 6 сент. 2020 г., 12:50:34 | 10 - 11 классы

Написать алгоритмы нахождения суммы, произведения всех элементов массива и поиска максимального элемента массива?

Написать алгоритмы нахождения суммы, произведения всех элементов массива и поиска максимального элемента массива.

Rakhuba1981 29 апр. 2020 г., 00:46:34 | 5 - 9 классы

Дан целочисленный двумерный массив 6x10?

Дан целочисленный двумерный массив 6x10.

Опишите на русском языке и на языке программирования Паскаль алгоритм вычисления произведения минимальных элементов из каждой строки.

Напечатать значение этого произведения.

Предполагается, что в каждой строке минимальный элемент единственный.

4yBAK4 28 окт. 2020 г., 14:55:27 | 5 - 9 классы

Дан целочисленный массив из 10 элементов?

Дан целочисленный массив из 10 элементов.

Элементы массива могут принимать целые значения от 0 до 1000.

Опишите на русском языке или на одном из языков программирования алгоритм, позволяющий найти и вывести номер первого элемента массива, который делится на 3.

Гарантируется, что в исходном массиве есть хотя бы один такой элемент.

Программу я написал, но выводит все значения, а мне нужно первое.

Викуся200 21 июн. 2020 г., 14:13:49 | 10 - 11 классы

В целочисленной последовательности есть нулевые элементы?

В целочисленной последовательности есть нулевые элементы.

Создать массив из номеров этих элементов.

Язык программирования VBA.

Sidorovakatyus 23 нояб. 2020 г., 14:56:40 | 5 - 9 классы

Дан целочисленный массив из 20 элементов?

Дан целочисленный массив из 20 элементов.

Элементы массива могут принимать целые значения от –10 000 до 10 000 включительно.

Опишите на одном из языков программирования алгоритм, позволяющий найти и вывести количество пар элементов массива, в которых сумма элементов делится на 2, но не делится на 4.

В данной задаче под парой подразумеваются два соседних элемента массива.

На странице вопроса 1)Опишите на русском языке или одном из языков программирования алгоритм подсчета суммы произведений последовательных пар элементов в целочисленном массиве из 30 элементов? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.