Исправить ситаксические ошибки в программе которая в тексте меняет слово 77777 на слово 00000 Var s : string ; d, i : integer ; begin s : = '177777277777377777477777 ; d : = length(s) ; for i : = 0 to?

Информатика | 10 - 11 классы

Исправить ситаксические ошибки в программе которая в тексте меняет слово 77777 на слово 00000 Var s : string ; d, i : integer ; begin s : = '177777277777377777477777 ; d : = length(s) ; for i : = 0 to d - 4 begin if copy(s, i, 5) = 00000 then begin delete(s, i, 5) ; end end ; writeln(s) end.

Ответить на вопрос
Ответы (1)
Yurayudin00 21 окт. 2020 г., 05:46:19

Var

s : string ;

d, i : integer ;

begin

s : = '177777277777377777477777' ;

d : = length(s) ;

for i : = 1 to d - 4 do

if copy(s, i, 5) = '77777' then

begin

delete(s, i, 5) ;

insert('00000', s, i) ;

end ;

writeln(s) ;

end.

Komarik21 24 июл. 2020 г., 19:43:53 | 10 - 11 классы

Где ошибка?

Где ошибка?

Const n = 10 ; type TMas = array[1.

N] of integer ; var mas1 : TMas ; procedure ImputMas1(var masTMas : integer) ; var i : integer ; begin for i : = 1 to 10 do begin mas1[i] : = random(n) ; Write(mas1[i] : 3) ; end ; end.

Gribaneva 19 февр. 2020 г., 20:46:42 | 10 - 11 классы

Определите, какое число будет напечатано в результате выполнения следующего алгоритма : var a, b, t, M, R : integer ; Function F(x : integer) : integer ; begin F : = 3 * (x - 8) * (x - 8) end ; begin ?

Определите, какое число будет напечатано в результате выполнения следующего алгоритма : var a, b, t, M, R : integer ; Function F(x : integer) : integer ; begin F : = 3 * (x - 8) * (x - 8) end ; begin a : = - 20 ; b : = 20 ; M : = a ; R : = F(a) ; for t : = a to b do begin if (F(t) < ; R) then begin M : = t ; R : = F(t) end end ; write(M) ; end.

Йчуметнлщдшщгапм5689 22 авг. 2020 г., 00:02:41 | 5 - 9 классы

Найдите значение переменной А после выполнения программы VAR A : INTEGER BEGIN A : = SQRT(16) : END?

Найдите значение переменной А после выполнения программы VAR A : INTEGER BEGIN A : = SQRT(16) : END.

Fendoriys 24 апр. 2020 г., 11:49:56 | 5 - 9 классы

Составить программу для вычисления суммы квадратов чисел от 1 до 15?

Составить программу для вычисления суммы квадратов чисел от 1 до 15.

Функция возведения в квадрат sqr() ; Var , , : ; Begin : = 0 ; For : = to do Begin ; ; End ; Writeln(' = ', ) ; End.

Там, где пробелы, вставить что нужно.

Sonyatoropchina 24 мар. 2020 г., 12:41:52 | 10 - 11 классы

Исправить ошибку Помогите исправить ошибку в программе Вот задание : Разработать программу поиска и печати всех чисел - близнецов, принадлежащих заданному диапазону [N, M ]?

Исправить ошибку Помогите исправить ошибку в программе Вот задание : Разработать программу поиска и печати всех чисел - близнецов, принадлежащих заданному диапазону [N, M ].

Вот программа : program yyy ; function prost(var x : integer) : boolean ; var k, i : integer ; t : boolean ; begin t : = true ; k : = 0 ; for i : = 1 to x do begin if x mod i = 0 then k : = k + 1 ; end ; if k = 2 then t : = true else t : = false ; prost : = t end ; var n, m, i : integer ; begin writeln('1') ; readln(n) ; writeln('2') ; readln(m) ; for i : = n to m - 1 do begin if prost(i) and prost(i + 2) then writeln(i , (i + 2)) ; end ; end.

AvEnTaDoR005 25 сент. 2020 г., 12:43:18 | 5 - 9 классы

Program TELESHOP ; var x : real ; begin writeln ('?

Program TELESHOP ; var x : real ; begin writeln ('.

') ; write ('.

') ; write ('.

') ; readln (x) ; if x< ; = 1 then begin if x = 1 then begin writeln ('.

') ; writeln ('.

') ; end else begin writeln ('.

') ; end ; * else begin writeln ('.

') ; end end.

* - место ошибки.

"встречено 'else', а ожидалось оператор" Вопрос : в чем ошибка?

Spasibo123 5 февр. 2020 г., 18:45:06 | 10 - 11 классы

Что напечатает данная программа : Var x : = Integer Begin x : = 2 WriteLn('x + 1 = ', x) End?

Что напечатает данная программа : Var x : = Integer Begin x : = 2 WriteLn('x + 1 = ', x) End.

Ksusha1037 25 июн. 2020 г., 21:03:03 | 5 - 9 классы

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 ?

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 then begin writeln ('утро') ; readln (d) ; if a = 12 then begin writeln ('день') ; end ; if a = 16 then begin writeln ('вечер') ; / / / if a = 21 then begin writeln ('ночь') ; / / / end ; end ;

Treio 28 авг. 2020 г., 11:10:47 | 10 - 11 классы

Помогите решить, пожалуйста) var a, b, t, M, R : integer ; Function F(x : integer) : integer ; begin F : = 9 * (x + 19) * (x - 19) + 1 ; end ; begin a : = - 20 ; b : = 20 ; M : = a ; R : = F(a) ; for ?

Помогите решить, пожалуйста) var a, b, t, M, R : integer ; Function F(x : integer) : integer ; begin F : = 9 * (x + 19) * (x - 19) + 1 ; end ; begin a : = - 20 ; b : = 20 ; M : = a ; R : = F(a) ; for t : = a to b do begin if (F(t) < ; R ) then begin M : = t ; R : = F(t) end end ; write(M) ; end.

EKATERLINS 24 дек. 2020 г., 05:33:05 | 5 - 9 классы

Определите, какое число будет напечатано в результате выполнения следующего алгоритма : var a, b, t, N, P : integer ; Function F(x : integer) : integer ; begin F : = 16 * (9 - x) * (9 - x) + 127 ; end?

Определите, какое число будет напечатано в результате выполнения следующего алгоритма : var a, b, t, N, P : integer ; Function F(x : integer) : integer ; begin F : = 16 * (9 - x) * (9 - x) + 127 ; end ; BEGIN a : = - 25 ; b : = 25 ; P : = 130 ; N : = 0 ; for t : = a to b do begin if (F(t) > ; P) then begin N : = N + 1 ; end ; end ; write(N) ; END.

Вы зашли на страницу вопроса Исправить ситаксические ошибки в программе которая в тексте меняет слово 77777 на слово 00000 Var s : string ; d, i : integer ; begin s : = '177777277777377777477777 ; d : = length(s) ; for i : = 0 to?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.