Составить программу, в которой получить как можно больше слов, образованных из слова информатика?

Информатика | 5 - 9 классы

Составить программу, в которой получить как можно больше слов, образованных из слова информатика.

Вывести на экран длину исходного слова.

(Программа на языке Паскаль, использовать команды : length, copy, delete, insert, concat.

) Желательно сделать до завтрешнего дня, информатика завтра будет.

Заранее спасибо).

Ответить на вопрос
Ответы (1)
Алишка001 13 июл. 2020 г., 08:41:52

Из слова "информатика" так много всего можно сделать!

Вот небольшая часть :

var s, s1 : string ;

begin

s : = 'информатика' ; / / 1 способ

s1 : = copy(s, 3, 5) ;

writeln(s1, ' - ', length(s1)) ; / / 2 способ

s1 : = s ; delete(s1, 8, 4) ;

delete(s1, 1, 2) ;

writeln(s1, ' - ', length(s1)) ; / / 3

s1 : = s ; delete(s1, 1, 5) ;

delete(s1, 3, 2) ;

insert(copy(s, 5, 1), s1, 3) ;

writeln(s1, ' - ', length(s1)) ; / / 4

s1 : = copy(s, 5, 1) + copy(s, 4, 1) + copy(s, 6, 2) + copy(s, 2, 1) + copy(s, 8, 3) ;

writeln(s1, ' - ', length(s1)) ; / / 5

s1 : = concat(copy(s, 3, 3), copy(s, 8, 1)) ;

writeln(s1, ' - ', length(s1)) ;

end.

Alex201500464749 23 февр. 2020 г., 05:01:17 | 5 - 9 классы

Написать программу которая 20 раз выведет слово информатика на экран?

Написать программу которая 20 раз выведет слово информатика на экран.

Егорталалаев 17 февр. 2020 г., 16:15:16 | 10 - 11 классы

Помогите пожалуйста написать программу в паскале : символы, стоящие на четных местах заменить на * ?

Помогите пожалуйста написать программу в паскале : символы, стоящие на четных местах заменить на * .

Пользоваться можно только : Pos, Insert, Delete, Length, Copy.

Barbanov791 27 сент. 2020 г., 13:54:33 | 5 - 9 классы

Задача в программе Паскаль?

Задача в программе Паскаль.

Составь программу, которая из слова ИНФОРМАТИКА получит слова : ФОРТ, ТИК, ФОРТ.

Rasdi 16 окт. 2020 г., 19:52:29 | 5 - 9 классы

Информатика : 9 класс - срочнооо?

Информатика : 9 класс - срочнооо!

Составить программу, которая выводит на экран таблицу квадратов от 10 до 20.

Igor1122hoholok 17 сент. 2020 г., 06:56:52 | 5 - 9 классы

Информатика?

Информатика!

! СРОЧНО!

ПОМОГИТЕ!

СПАСИТЕ!

СОСТАВИТЬ ПРОГРАММУ ПИСЬМЕННО, ЖЕЛАТЕЛЬНО СДЕЛАТЬ И СФОТКАТЬ!

! СРОЧНО!

Geyrayheard 6 авг. 2020 г., 05:03:52 | 10 - 11 классы

Программа по информатике вывести на экран текст "лесенкой"?

Программа по информатике вывести на экран текст "лесенкой".

Айбек87292 16 янв. 2020 г., 07:24:13 | 5 - 9 классы

Составить алгоритм и программу : вывести на экран числа, кратные 2 ( язык Паскаль)?

Составить алгоритм и программу : вывести на экран числа, кратные 2 ( язык Паскаль).

Msleman1 25 окт. 2020 г., 18:07:19 | 10 - 11 классы

Может ли кто - нибудь помочь с темой Массивы по информатике?

Может ли кто - нибудь помочь с темой Массивы по информатике?

Сформировать и вывести на экран в строчку, через пробел, 25 элементов целого типа от - 100 до 100 на языке паскаль.

Заранее спасибо.

Мубина2005 4 авг. 2020 г., 07:28:30 | 10 - 11 классы

1. чем заканчивается любая программа, записанная на языке Паскаль?

1. чем заканчивается любая программа, записанная на языке Паскаль?

2. с помощью какой команды можно вывести значение переменной G на экран дисплея?

3. с какого слова начинается тело программы, т .

Е. набор команд , которые выполняются при запуски программы?

Kubamurzaev 25 окт. 2020 г., 02:29:50 | 5 - 9 классы

Написать программу на языке Паскаль?

Написать программу на языке Паскаль.

Получить из слова "Каблучок" три любых слова.

На этой странице вы найдете ответ на вопрос Составить программу, в которой получить как можно больше слов, образованных из слова информатика?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.