Может кто нибудь написать небольшую программу по паскалю с массивами?

Информатика | 10 - 11 классы

Может кто нибудь написать небольшую программу по паскалю с массивами.

И описать что выполняет каждая команда ?

Нужно на олимпиаде хоть что нибудь написать .

Ответить на вопрос
Ответы (1)
Лянаlana 17 дек. 2020 г., 14:33:42

Задание одномерного массива :

var ИмяМассива : array [НижняяГраница.

ВерхняяГраница] of ТипЭлементов ;

задание двумерного массива :

var ИмяМассива : array [НижняяГраница1.

ВерхняяГраница1, НижняяГраница2.

ВерхняяГраница2 ] of ТипЭлементов ;

заполение массива :

одномерный массив : for i : = 1 to 5 do readln(a[i]) ; {ввод с клавиатуры}

двумерный массив : for i : = 1 to 3 do for j : = 1 to 2 do readln(a[i, j]) ;

вывод массива на экран :

в столбец : for i : = 1 to 5 do writeln(a[i]) ;

в строку : for i : = 1 to 5 do write(a[i], ' ') ;

матрица двумерного массива :

for i : = 1 to n do

begin

for j : = 1 to m do

write (a[i, j] : 4) ;

writeln ;

end ;

действия с одномерным массивом :

вычисление суммы элементов :

s : = 0 ;

for i : = 1 to n do s : = s + a[i] ;

подсчет элементов, удовлетворяющих условию :

k : = 0 ;

for i : = 1 to n do

if a[i] УсловиеОтбора then k : = k + 1 ;

Artiomkonopli 27 сент. 2020 г., 07:42:34 | 1 - 4 классы

Найти максимальный элемент массива X(10)?

Найти максимальный элемент массива X(10).

Помогите написать программу в паскале пожалуйста.

Rord2014 16 нояб. 2020 г., 12:22:12 | 5 - 9 классы

Написать на Паскале программу нахождения суммы, произведения и среднего значения элементов массива, кол - во элементов ввести в программе?

Написать на Паскале программу нахождения суммы, произведения и среднего значения элементов массива, кол - во элементов ввести в программе.

Tatyana72 5 июн. 2020 г., 01:30:36 | 10 - 11 классы

Нужна программа для Паскаля - Реверс массива?

Нужна программа для Паскаля - Реверс массива.

Simka198 31 мар. 2020 г., 11:05:22 | 5 - 9 классы

Написать в программе паскаль?

Написать в программе паскаль.

In17021989 6 янв. 2020 г., 02:17:01 | 5 - 9 классы

Даны два одномерных массива из целых чисел разной размерности?

Даны два одномерных массива из целых чисел разной размерности.

Найти целую часть среднего арифметического элементов каждого массива и их сумму.

Помогите написать программу в паскале.

Tinlisa 6 окт. 2020 г., 16:01:05 | 5 - 9 классы

Написать в программе паскаль?

Написать в программе паскаль.

Ученик141100 27 апр. 2020 г., 14:31:32 | 5 - 9 классы

Дан массив из 5 элементов, найти среднее арифметическое всех элементов массива?

Дан массив из 5 элементов, найти среднее арифметическое всех элементов массива.

Выполнять на паскале.

Нужно написать программу самым легким способом.

SpiderMan1997 3 авг. 2020 г., 10:04:59 | 10 - 11 классы

Написать в программу в паскале (сразу все) - найти максимальный и минимальный элемент в массиве?

Написать в программу в паскале (сразу все) - найти максимальный и минимальный элемент в массиве.

Vasyapupkin201 2 июл. 2020 г., 19:43:53 | 5 - 9 классы

Написать программу вычисления суммы минимальных элементов каждой строки в массиве (6х10) и вывести эту сумму на экран?

Написать программу вычисления суммы минимальных элементов каждой строки в массиве (6х10) и вывести эту сумму на экран.

Язык Паскаль.

Porabote78 31 дек. 2020 г., 16:32:13 | 5 - 9 классы

Написать программу нахождение максимального и минимального значения массива?

Написать программу нахождение максимального и минимального значения массива.

Программу нужно сделать в Паскаль.

ПРОШУ ПОМОГИТЕ.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Может кто нибудь написать небольшую программу по паскалю с массивами?. По уровню сложности вопрос рассчитан на учащихся 10 - 11 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.