Умоляю , помогите с этими двумя задачами?

Информатика | 10 - 11 классы

Умоляю , помогите с этими двумя задачами.

. Мы такое в школе практикуем , я в этом ничего не понимаю.

Очень надеюсь на вашу помощь!

(Задачи решить в Турбо паскале).

Ответить на вопрос
Ответы (1)
Roma57545 8 янв. 2020 г., 00:28:13

Задание 1.

На самом деле в нем ошибка.

Числ Фибоначчи определены начиная с f0 = 1, а в задании дважды указано f1 = 1.

Uses Crt ;

var k, n, f0, f1, fk : longint ;

begin ClrScr ; f0 : = 1 ; f1 : = 1 ; k : = 2 ; Write('n = ') ; Read(n) ; Write(f0, ' ', f1) ; while k< ; = n do begin fk : = f0 + f1 ; f0 : = f1 ; f1 : = fk ; Inc(k) ; Write(' ', fk) end ; Writeln ; ReadKey

end.

Тестовое решение :

n = 20

1 1 2 3 5 8 13 21 34 55 89 144 233 377 610 987 1597 2584 4181 6765 10946

Задание 2.

Uses Crt ;

var P : real ; M : char ; s : string ;

begin ClrScr ; Write('P = ') ; Readln(P) ; Write('M = ') ; Readln(M) ; Str(P : 0 : 0, s) ; s : = Copy(s, 1, 3) ; if Pos(M, s)> ; 0 then Writeln('Yes') else Writeln('No') ; ReadKey

end.

Тестовое решение :

P = 54231.

70475438

M = 4

Yes.

Рил 17 сент. 2020 г., 02:31:08 | 5 - 9 классы

Паскаль, помогите решить задачу?

Паскаль, помогите решить задачу.

Gizhko1973 20 авг. 2020 г., 00:42:46 | 5 - 9 классы

Помогите решить задачу по информатике (нужно решить эту задачу с помощью структурной программы турбо паскаля)Мальчик купил в магазине "n" порций мороженного по цене 12 рублей?

Помогите решить задачу по информатике (нужно решить эту задачу с помощью структурной программы турбо паскаля)

Мальчик купил в магазине "n" порций мороженного по цене 12 рублей.

И "к" плиток шоколада по цене 38 рублей.

Сколько всего денег он потратил?

Shmakova14 28 мар. 2020 г., 08:15:36 | 5 - 9 классы

Помогите решить задачи по Информатике в Паскале?

Помогите решить задачи по Информатике в Паскале!

Все 3 задачи.

Настя26783 11 сент. 2020 г., 06:23:32 | 10 - 11 классы

Помогите решить задачу в паскаль ?

Помогите решить задачу в паскаль :

Polina21031 3 нояб. 2020 г., 07:55:00 | 5 - 9 классы

Помогите решить задачи, с помощью Паскаля?

Помогите решить задачи, с помощью Паскаля.

YulkaKiridon 20 июл. 2020 г., 00:23:19 | 5 - 9 классы

Помогите написать программу в турбо паскале?

Помогите написать программу в турбо паскале.

Feili 16 сент. 2020 г., 14:52:59 | 10 - 11 классы

Задача : найти самую большую цифру целого числа?

Задача : найти самую большую цифру целого числа.

В турбо паскаль.

Саша20001 19 мая 2020 г., 06:28:23 | 5 - 9 классы

40 баллов ?

40 баллов !

У = а * х решите как это выглядить в турбо паскале срочно!

Tatilna 18 янв. 2020 г., 19:28:45 | 5 - 9 классы

Помогите решить эту задачу, в душе не понимаю что это вообще?

Помогите решить эту задачу, в душе не понимаю что это вообще.

Karpenkojana20 15 мая 2020 г., 09:59:34 | 5 - 9 классы

Решить уравнение в турбо Паскале(написать программу)?

Решить уравнение в турбо Паскале(написать программу).

На этой странице сайта вы найдете ответы на вопрос Умоляю , помогите с этими двумя задачами?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.