Написать программу в паскале, определяющую, попала ли точка в область, отмеченную буквой?

Информатика | 10 - 11 классы

Написать программу в паскале, определяющую, попала ли точка в область, отмеченную буквой.

Ответить на вопрос
Ответы (1)
Parovozovaz 11 окт. 2020 г., 17:05:01

Var x, y : integer ;

begin

readln(x, y) ;

if (x< ; 0) and (y> ; 1) and (sqr(x) + sqr(y)> ; 4) then writeln('A')

else if (x> ; 0) and (y> ; 1) and (sqr(x) + sqr(y)> ; 4) and (y> ; x - 2) then writeln('B')

else if (sqr(x) + sqr(y)< ; 4) and (y> ; 1) then writeln('C')

else if (x< ; - 2) and (sqr(x) + sqr(y)> ; 4) and (y> ; 0) and (y< ; 1) then writeln('D')

else if (sqr(x) + sqr(y)< ; 4) and (x< ; 0) and (y> ; 0) and (y< ; 1) then writeln('E')

else if (sqr(x) + sqr(y)< ; 4) and (x> ; 0) and (y> ; 0) and (y< ; 1) then writeln('F')

else if (sqr(x) + sqr(y)> ; 4) and (y> ; 0) and (y< ; 1) and (x> ; 2) and (y> ; x - 2) then writeln('G')

else if (sqr(x) + sqr(y)> ; 4) and (y> ; 0) and (y< ; 1) and (x> ; 2) and (y< ; x - 2) then writeln('H')

else if (sqr(x) + sqr(y)> ; 4) and (x< ; 0) and (y< ; 0) and (y> ; x - 2) then writeln('I')

else if (sqr(x) + sqr(y)< ; 4) and (x< ; 0) and (y< ; 0) and (y> ; x - 2) then writeln('J')

else if (sqr(x) + sqr(y)< ; 4) and (x> ; 0) and (y< ; 0) and (y> ; x - 2) then writeln('K')

else if (sqr(x) + sqr(y)< ; 4) and (x> ; 0) and (y< ; 0) and (y< ; x - 2) then writeln('L')

else if (sqr(x) + sqr(y)> ; 4) and (x> ; 0) and (y< ; 0) and (y< ; x - 2) then writeln('M')

else if (sqr(x) + sqr(y)< ; 4) and (x< ; 0) and (y< ; 0) and (y< ; x - 2) then writeln('N')

else if (y> ; 1) and (y< ; x - 2) then writeln ('O')

else writeln('Точка не лежит ни в одной из областей') ;

end.

Яна89011 31 окт. 2020 г., 17:17:10 | 5 - 9 классы

Написать программу в паскале определяющую и выводящую наибольшее из трех чисел?

Написать программу в паскале определяющую и выводящую наибольшее из трех чисел.

Кирилл99деревянко 26 нояб. 2020 г., 02:36:14 | 10 - 11 классы

Помогите програмку сделать Надо написать программу которая определяет принадлежность точки с координатами x, y в заштрихованной области?

Помогите програмку сделать Надо написать программу которая определяет принадлежность точки с координатами x, y в заштрихованной области.

Альмир1111 7 дек. 2020 г., 07:10:42 | 10 - 11 классы

Написать программу в ПАСКАЛЕ : в тексте, состоящем из латинских букв и заканчивающеемся точкой, посчитайте количество гласных букв?

Написать программу в ПАСКАЛЕ : в тексте, состоящем из латинских букв и заканчивающеемся точкой, посчитайте количество гласных букв.

Topa1984 11 июл. 2020 г., 09:22:59 | 5 - 9 классы

Напишите два варианта программы(2 не обязательно), которая вводит координаты на плоскости и определяет, попала ли эта точка в заштрихованную область?

Напишите два варианта программы(2 не обязательно), которая вводит координаты на плоскости и определяет, попала ли эта точка в заштрихованную область.

Russkiy1413 31 мая 2020 г., 10:31:35 | 10 - 11 классы

Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область?

Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область.

В ПАСКАЛЕ!

СашкаEvseeva2002 4 дек. 2020 г., 00:27:58 | 10 - 11 классы

Написать программу в Паскале?

Написать программу в Паскале.

Задание под буквой Б.

Магира 14 янв. 2020 г., 17:46:04 | 10 - 11 классы

С клавиатуры вводятся два числа X и Y ?

С клавиатуры вводятся два числа X и Y .

Написать программу, определяющую, попала ли точка с координатами (Х, Y) внутрь заштрихованной области (СМ.

Рисунок).

ВИКАКАКТУС 9 окт. 2020 г., 07:53:08 | 5 - 9 классы

Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область?

Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область.

Язык Python.

Ромзес11 18 мар. 2020 г., 05:19:20 | 5 - 9 классы

Помогите написать программу на языке Паскаля?

Помогите написать программу на языке Паскаля.

Напишите программу, определяющую, лежит ли точка А (ха, уа) на окружности х2 + у2 = r2, на ней или под ней.

Sjava2 28 нояб. 2020 г., 13:59:27 | 10 - 11 классы

Написать программу, которая определяет , что введено с клавиатуры( русская прописная или строчня буква , английская прописная или строчная буква , цифра или символ)Написать программу , которая определ?

Написать программу, которая определяет , что введено с клавиатуры( русская прописная или строчня буква , английская прописная или строчная буква , цифра или символ)

Написать программу , которая определяет , к какой четверти координатной плоскости принадлежит точка.

Координаты точки вводятся с клавиатуры .

Написать все эти 2 программы в Pascal ) Помогите срочно пожалуйста ).

На этой странице находится вопрос Написать программу в паскале, определяющую, попала ли точка в область, отмеченную буквой?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.