Написать программу на языке паскаль при помощи подпрограммы функции которая вычисляет минимальное из чисел a b c d?

Информатика | 10 - 11 классы

Написать программу на языке паскаль при помощи подпрограммы функции которая вычисляет минимальное из чисел a b c d.

Ответить на вопрос
Ответы (1)
Svetaua 31 авг. 2020 г., 17:33:41

PascalABC.

NET

type mass = array [1.

4] of integer ;

var a : mass ;

i : integer ;

function min(c : mass) : integer ;

var

i, minim : integer ;

begin

minim : = c[1] ;

for i : = 2 to 4 do if c[i] < ; minim then minim : = c[i] ;

result : = minim ;

end ;

begin

for i : = 1 to 4 do readln (a[i]) ;

writeln ('min = ', min(a)) ;

end.

Как параметр я использовал массив из четырех элементов.

Можно использовать просто переменные и через IF все прописать.

Veelok 4 окт. 2020 г., 07:16:37 | 5 - 9 классы

Написать программу, вычисляющую произведение чисел, кратных пяти?

Написать программу, вычисляющую произведение чисел, кратных пяти.

Язык прораммирования : Паскаль.

Ленуська132 3 окт. 2020 г., 06:34:07 | 5 - 9 классы

Составить программу вычисляющее наибольшее из 3 заданных чисел(паскаль)?

Составить программу вычисляющее наибольшее из 3 заданных чисел(паскаль).

Vitya777888 23 апр. 2020 г., 07:50:29 | 5 - 9 классы

Как написать программу в паскале которая будит вычислять оценку за четверть \в паскале если можете распишете все решение?

Как написать программу в паскале которая будит вычислять оценку за четверть \

в паскале если можете распишете все решение.

MsKotopes 13 янв. 2020 г., 02:15:56 | 5 - 9 классы

Написать программу вычисляющую квадраты введены с клавиатуры чисел, пока не выйдет ноль?

Написать программу вычисляющую квадраты введены с клавиатуры чисел, пока не выйдет ноль!

Пожалуйста (паскаль).

Katya2402 26 апр. 2020 г., 05:20:34 | 5 - 9 классы

Помогите в Паскале пожалуйста?

Помогите в Паскале пожалуйста.

Написать программу, вычисляющую сумму наибольшего и наименьшего чисел из 15 введенных вами.

Венера1999 28 авг. 2020 г., 08:49:28 | 10 - 11 классы

Написать программу на паскале которая вычисляет дискриминант квадратного уравнения?

Написать программу на паскале которая вычисляет дискриминант квадратного уравнения.

Galinababenko 9 окт. 2020 г., 06:25:18 | 10 - 11 классы

Написать программу на паскале?

Написать программу на паскале.

Создать двухмерный массив из целых чисел, в котором поменять местами максимальный и минимальный элементы.

Помогите пж.

Милашка2011 8 июн. 2020 г., 12:58:50 | 5 - 9 классы

Напишите программу, которая вычисляет сумму всех двузначных чисел, на ПАСКАЛЬ?

Напишите программу, которая вычисляет сумму всех двузначных чисел, на ПАСКАЛЬ.

Ирина90973 28 февр. 2020 г., 15:55:58 | 10 - 11 классы

Написать программу которая содержит подпрограмму - функцию которая вычисляет кол - во положительных элементов одномерного массива 10 компонентов вещественного типа?

Написать программу которая содержит подпрограмму - функцию которая вычисляет кол - во положительных элементов одномерного массива 10 компонентов вещественного типа.

(РЕШИТЬ НА БАЗЕ PASCAL 7.

0).

Beautiful0bitch 24 нояб. 2020 г., 02:17:18 | 10 - 11 классы

Цикл со счетчиком, паскаль?

Цикл со счетчиком, паскаль.

Написать программу, вычисляющую сумму наибольшего и наименьшего чисел из 15 введенных вами.

Перед вами страница с вопросом Написать программу на языке паскаль при помощи подпрограммы функции которая вычисляет минимальное из чисел a b c d?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.