В заданном массиве вещественных чисел определить количество элементов меньших среднего арифметического значения?

Информатика | 10 - 11 классы

В заданном массиве вещественных чисел определить количество элементов меньших среднего арифметического значения.

Ответить на вопрос
Ответы (1)
SvetlanaVic 31 авг. 2020 г., 16:30:26

CONST N = 5 ;

var

x : real ;

i : integer ;

ar : array[1.

N] of real ;

begin

for i : = 1 to N do begin

readln(ar[i]) ;

x : = x + ar[i] ;

end ;

x : = x / i ;

for i : = 1 to N doif (ar[i] < ; x) then write(ar[i], ' ') ;

end.

Abdusalamova99 8 апр. 2020 г., 20:11:35 | 10 - 11 классы

Составить программу на языке Паскаль : 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0?

Составить программу на языке Паскаль : 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0.

2)В массиве М из 10 целых чисел найти количество элементов равных 3.

3)В массиве из 8 целых найти номер массива с наибольшим значением.

4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента.

5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

Ariname 14 мая 2020 г., 07:02:43 | 5 - 9 классы

1. Дан массив целых чисел, найти среднее арифметическое всех элементов массива?

1. Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел, найти количество отрицательных элементов массива.

3. Дан массив целых чисел, найти количество чётных чисел в массиве.

Sofia20077115 19 апр. 2020 г., 14:45:18 | 5 - 9 классы

Для массива из 10 целых чисел?

Для массива из 10 целых чисел.

Найти сумму всех элементов, среднее арифметическое, наибольшее и наименьшее значение.

Vanilka14 28 янв. 2020 г., 08:07:27 | 5 - 9 классы

ПОМОГИТЕ?

ПОМОГИТЕ!

Удалить элемент линейного массива вещественных чисел, которые меньше среднего арифметического элемента массива.

Если таких элементов несколько , удалить последний из найденных.

Помогите решить в паскале.

(вычислить средн.

Ариф.

Номер э - та, .

).

Rfnzhgjht 8 дек. 2020 г., 06:17:27 | 5 - 9 классы

Задан массив из 10 вещественных чисел?

Задан массив из 10 вещественных чисел.

Поменять значениями второй и третий элемент массива.

Ovsyanikovanas 28 мар. 2020 г., 18:53:34 | 5 - 9 классы

Дан одномерный массив чисел?

Дан одномерный массив чисел.

Определить среднее арифметическое элементов массива.

Kostiaboik200 28 нояб. 2020 г., 11:45:33 | 5 - 9 классы

Помогите написать проги 1?

Помогите написать проги 1.

Замените все элементы массива целых чисел С(n) на противоположные по знаку 2.

Найти произведение элементов массива целых чисел А(n), меньших 3 3.

В линейный массив вещественных чисел на К - тое место вставить элемент, равный среднему арифметическому элементов массива.

Romchik13 3 сент. 2020 г., 17:31:37 | 10 - 11 классы

Дан одномерный массив вещественных чисел найти средняя арифметическая положительных элементов?

Дан одномерный массив вещественных чисел найти средняя арифметическая положительных элементов.

Flover11 18 дек. 2020 г., 00:43:03 | 10 - 11 классы

Дан массив целых чисел, определить сколько среди его элементов больших, чем среднее арифметическое всех элементов массива?

Дан массив целых чисел, определить сколько среди его элементов больших, чем среднее арифметическое всех элементов массива.

С + + или С.

213rfe 2 сент. 2020 г., 15:06:18 | 5 - 9 классы

Решить в с + +задан массив Z(n) целых чисел?

Решить в с + +

задан массив Z(n) целых чисел.

Найти максимальный элемент массива и если это простое число - удалить все элементы равные максимальному значению.

Определить среднее арифметическое положительных элементов массива после удаления.

Упорядочить массив по убыванию модулей.

Если вам необходимо получить ответ на вопрос В заданном массиве вещественных чисел определить количество элементов меньших среднего арифметического значения?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.