Сделать задание в Паскале?

Информатика | 5 - 9 классы

Сделать задание в Паскале!

И в Блок - Схеме!

Буду очень благодарен тем кто поможет)

Или хотя бы в Паскале сделать программу).

Ответить на вопрос
Ответы (1)
Aislu12 12 янв. 2020 г., 13:57:42

Const n = 15 ;

var x : array[1.

N] of integer ; y : array[1.

(n div 2) + 1] of integer ; i, k, maxmod, xi : integer ; p : longint ;

begin Randomize ; Writeln('Элементы массива') ; p : = 1 ; maxmod : = - 1 ; { меньше меньшего возможного } for i : = 1 to n do begin x[i] : = Random(51) - 25 ; { [ - 25.

25] } Write(x[i] : 4) ; if maxmod< ; abs(x[i]) then begin maxmod : = abs(x[i]) ; xi : = x[i] end ; if (i mod 2 < ; > ; 0) and (x[i]< ; 0) then p : = p * x[i] end ; Writeln ; Writeln('Значение максимального по модулю элемента : ', xi) ; Writeln('Произведение отрицательных нечетных элементов : ', p) ; { удаляем элементы с нечетным номером } k : = 1 ; while (2 * k - 1)< ; = n do begin y[k] : = x[2 * k - 1] ; Inc(k) end ; Writeln('Результирующий массив') ; for i : = 1 to k - 1 do Write(y[i] : 4) ; Writeln

end.

Тестовое решение :

Элементы массива - 7 4 14 10 5 9 - 21 - 17 0 1 - 20 13 - 11 - 17 12

Значение максимального по модулю элемента : - 21

Произведение отрицательных нечетных элементов : 32340

Результирующий массив - 7 14 5 - 21 0 - 20 - 11 12.

Ksyenia1 3 мая 2020 г., 13:35:45 | 10 - 11 классы

Написать блок схему и написать ее в программе паскаль S = a + b?

Написать блок схему и написать ее в программе паскаль S = a + b.

TumblrBoy 24 февр. 2020 г., 11:49:48 | 10 - 11 классы

Составить блок - схему алгоритма и программу на алгоритмическом языке?

Составить блок - схему алгоритма и программу на алгоритмическом языке.

Язык Паскаль ( любой ).

Asidakova 10 янв. 2020 г., 10:46:58 | 10 - 11 классы

Помогите пожалуйста срочно В паскале сделать программу 3 задание?

Помогите пожалуйста срочно В паскале сделать программу 3 задание.

Toonye 2 окт. 2020 г., 00:18:53 | 5 - 9 классы

Сделать программу в Паскале калькулятор?

Сделать программу в Паскале калькулятор?

Svetlankasvetl 7 мар. 2020 г., 13:53:23 | 10 - 11 классы

Ребят мне надо написать программу в Паскаль, кто поможет буду благодарен ?

Ребят мне надо написать программу в Паскаль, кто поможет буду благодарен !

Пасека1 24 нояб. 2020 г., 06:40:01 | 10 - 11 классы

Помогите , пожалуйста , составить программу в Паскале + блок - схема?

Помогите , пожалуйста , составить программу в Паскале + блок - схема.

ЭльвинаDji 31 дек. 2020 г., 20:42:04 | 5 - 9 классы

Сделайте программу паскаль?

Сделайте программу паскаль.

Xoma14 13 окт. 2020 г., 02:20:09 | 10 - 11 классы

Вычислите |x| + x ^ 5, если x = −2?

Вычислите |x| + x ^ 5, если x = −2.

, СОСТАВЬТЕ ПРОГРАММУ В ПАСКАЛЕ С БЛОК - СХЕМОЙ ОЧЕНЬ НАДО.

Crazy9 29 сент. 2020 г., 10:42:10 | 5 - 9 классы

Задачка по информатике по блок - схеме?

Задачка по информатике по блок - схеме.

Можно код на паскале или хотя бы скажите ответ.

Nonella12 22 дек. 2020 г., 23:34:24 | 10 - 11 классы

Запишите на языке Паскаль в виде участка программы следующую блок - схему ?

Запишите на языке Паскаль в виде участка программы следующую блок - схему :

Вы зашли на страницу вопроса Сделать задание в Паскале?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.