Определить максимальный и минимальный элементы среди положительных нечётных элементов целочисленного массива Х?

Информатика | 10 - 11 классы

Определить максимальный и минимальный элементы среди положительных нечётных элементов целочисленного массива Х.

Удалить из массива все нулевые элементы.

Пожалуйста, очень надо, нет времени писать прогу.

Даю 20 баллов!

Ответить на вопрос
Ответы (1)
Lolik8 25 июл. 2020 г., 00:10:22

Type array100 = array[1.

100]of integer ;

var x : array100 ; i, n, j, t, min, max : integer ;

procedure show(x : array100 ; n : integer) ;

var i : integer ;

begin writeln() ; writeln('Вывод массива[', n, '] : ') ; for i : = 1 to n do write(x[i], ' ') ; writeln() ;

end ;

begin n : = 20 ; max : = - 200 ; min : = 200 ; for i : = 1 to n do begin x[i] : = random(2 * n) - n ; end ; show(x, n) ; for i : = 1 to n do begin if (x[i] > ; 0) and (x[i] mod 2 = 1) then begin if x[i] > ; max then max : = x[i] ; if x[i] < ; min then min : = x[i] ; end ; end ; writeln('Max = ', max, ' Min = ', min) ; i : = 1 ; while i < ; = n do begin if x[i] = 0 then begin for j : = i + 1 to n do x[j - 1] : = x[j] ; n : = n - 1 ; end else i : = i + 1 ; end ; show(x, n) ;

end.

Een929 11 июн. 2020 г., 12:23:29 | 10 - 11 классы

Паскаль?

Паскаль.

Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и четные, и нечетные элементы).

Irochka28 16 июн. 2020 г., 08:02:04 | 10 - 11 классы

Расположить элементы целочисленного массива по убыванию?

Расположить элементы целочисленного массива по убыванию.

Найти минимальный элемент.

4158714 10 авг. 2020 г., 21:24:05 | 10 - 11 классы

PASCAL ABC1?

PASCAL ABC

1.

Из целочисленного массива А(n, m) сформировать массив В(n), в котором элемент b[i] равен 1, если среди элементов i - ой строки есть минимальный элемент массива А(n, m) или 0, если минимального элемента в строке нет.

2. В целочисленном массиве А(n, m) для каждой строки найдите среднее арифметическое положительных чётных элементов.

Чем проще, тем лучше!

Спасибо!

Fiksator3780 11 дек. 2020 г., 11:00:21 | 10 - 11 классы

Составьте программу, выполняющую поиск минимального нечетного элемента в заданном целочисленном массиве из 50 элементов?

Составьте программу, выполняющую поиск минимального нечетного элемента в заданном целочисленном массиве из 50 элементов.

Известно, что в массиве есть хотя бы один нечетный элемент.

Настя631прдлвптррии 2 июн. 2020 г., 15:30:58 | 5 - 9 классы

1) Удвоить все элементы массива?

1) Удвоить все элементы массива.

2)Найти сумму элементов двух массивов одинаковой размерности.

4) Найти Минимальные элементы массива и его индекс.

5) Найти максимальные элементы среди положительных элементов массива 6) Найти максимальные элементы среди отрицательных элементов массива 7) Определить количество максимальных элементов массива P.

S Ребят, все в паскале.

Заранее спасибо = *.

Настя122004 1 мар. 2020 г., 21:25:50 | 5 - 9 классы

Напишите пожалуйста программу, которая находит максимальный и минимальный из элементов массива с четными положительными значениями?

Напишите пожалуйста программу, которая находит максимальный и минимальный из элементов массива с четными положительными значениями.

Если в массиве нет элементов с четными положительными значениями, нужно вывести сообщение об этом.

С объяснением!

Olgapirog163 19 мар. 2020 г., 06:29:50 | 10 - 11 классы

Помогите пожалуйста : записать чётные положительные элементы целочисленных массивов X и Y в массив Z?

Помогите пожалуйста : записать чётные положительные элементы целочисленных массивов X и Y в массив Z.

Поменять минимальный и максимальный элементы массива Z.

Вывести элементы массива Z в четверичной системе счисления .

Coolalena200 17 окт. 2020 г., 17:57:45 | 10 - 11 классы

Помогите решить задачи в Pascal 1?

Помогите решить задачи в Pascal 1.

Поменять местами максимальный и минимальный элемент массива.

2. Вывести четные числа среди положительных элементов 3.

Напечатать сумму и номера положительных элементов после первого нулевого элемента.

Милена10111 29 окт. 2020 г., 16:17:47 | 5 - 9 классы

Удалить из массива максимальный и минимальный элементы помогите, пожалуйста )?

Удалить из массива максимальный и минимальный элементы помогите, пожалуйста ).

666Виктория666 8 сент. 2020 г., 14:33:42 | 10 - 11 классы

В целочисленных массива X(N) найти номера и значение, максимального четного и минимально нечетного элементов массива?

В целочисленных массива X(N) найти номера и значение, максимального четного и минимально нечетного элементов массива.

На языке СИ .

На этой странице сайта, в категории Информатика размещен ответ на вопрос Определить максимальный и минимальный элементы среди положительных нечётных элементов целочисленного массива Х?. По уровню сложности вопрос рассчитан на учащихся 10 - 11 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.