ПОМОГИТЕ, ПОЖАЛУЙСТА?

Информатика | 10 - 11 классы

ПОМОГИТЕ, ПОЖАЛУЙСТА.

Напишите программу, которая получает день и номер месяца, а выводит количество дней, оставшихся до Нового Года.

Считайте, что год невисокосный (365 дней).

Учтите, что слово «дней» может иметь также формы «день» и «дня».

Ответить на вопрос
Ответы (1)
Msrvolokitina2 3 дек. 2020 г., 19:25:16

Var

День, Месяц : byte ;

Begin

Write('№ дня = ') ; ReadLn(День) ;

Var C : = 365 - День ;

Write('№ месяца = ') ; ReadLn(Месяц) ;

Case Месяц of

2 : C : = C - 31 ;

3 : C : = C - 59 ;

4 : C : = C - 90 ;

5 : C : = C - 120 ;

6 : C : = C - 151 ;

7 : C : = C - 181 ;

8 : C : = C - 212 ;

9 : C : = C - 243 ;

10 : C : = C - 273 ;

11 : C : = C - 304 ;

12 : C : = C - 334

End ;

if (C mod 100> ; 10)and(C mod 100< ; 20) then Write('До нового года осталось ', C, ' дней')

else

Case C mod 10 of

1 : Write('До нового года остался ', C, ' день') ;

2.

4 : Write('До нового года осталось ', C, ' дня') ;

0, 5.

9 : Write('До нового года осталось ', C, ' дней')

End

End.

1999101615 28 июл. 2020 г., 20:28:56 | 10 - 11 классы

Составить программу, которая по заданным году и номеру месяца m определяет количество дней в этом месяце?

Составить программу, которая по заданным году и номеру месяца m определяет количество дней в этом месяце?

В паскале.

ТанТан 22 июл. 2020 г., 05:59:26 | 10 - 11 классы

Напишите программу, которая вводит с клавиатуры номер месяца и определяет, сколько дней в этом месяце?

Напишите программу, которая вводит с клавиатуры номер месяца и определяет, сколько дней в этом месяце.

При вводе неверного номера месяца должно быть выведено сообщение об ошибке.

Считается, что год невисокосный.

Входные данные Входная строка содержит единственное целое число – номер месяца (возможно, неправильный).

Выходные данные Выходная строка должна содержать одно целое число – количество дней в этом месяце или 0, если был введён неверный номер месяца.

Для ABCpascal.

Kostya31rus 11 авг. 2020 г., 21:03:28 | 1 - 4 классы

Пожалуйста помогите?

Пожалуйста помогите!

Ввести номер месяца и номер дня вывести число дней оставшихся до нового года (номер месяц.

12 день 25).

Karpenkoy1997 26 мая 2020 г., 03:55:54 | 5 - 9 классы

Написать программу в Паскале Пользователь вводит количество недель, месяцев, лет и получает количество дней за это время?

Написать программу в Паскале Пользователь вводит количество недель, месяцев, лет и получает количество дней за это время.

Считать, что в месяце 30 дней.

ВикторияГорбенко 18 апр. 2020 г., 19:23:02 | 5 - 9 классы

Напишите программу, которая получает день и номер месяца, а выводит количество дней, оставшихся до нового года?

Напишите программу, которая получает день и номер месяца, а выводит количество дней, оставшихся до нового года.

Считайте, что год невисокосный (365 дней).

Учтите что слова "дней" может иметь также формы "день" и " дня ".

Fadeev 15 мар. 2020 г., 12:24:30 | 5 - 9 классы

Написать программу, которая бы по введенному номеру времени года (1 - зима, 2 - весна, 3 - лето, 4 - осень) выдавала соответствующие этому времени года месяцы, количество дней в каждом из месяцев?

Написать программу, которая бы по введенному номеру времени года (1 - зима, 2 - весна, 3 - лето, 4 - осень) выдавала соответствующие этому времени года месяцы, количество дней в каждом из месяцев.

Вася162ро 29 июл. 2020 г., 07:11:31 | 5 - 9 классы

Составить программу, которая запрашивает у пользователя год количество дней в текущем месяце и сегодняшнее число?

Составить программу, которая запрашивает у пользователя год количество дней в текущем месяце и сегодняшнее число.

После этого выводит сообщение о том, сколько дней осталось до конца месяца.

Пример работы программы : Сколько дней в текущем месяце?

31 Какое сегодня число?

26 Количество дней до конца текущего месяца : 5.

Konovaljva1999 1 сент. 2020 г., 03:04:55 | 10 - 11 классы

Паскаль?

Паскаль.

Написать программу которая после введения месяца, выводит на экран количество дней этого месяца.

Anel9913 30 мая 2020 г., 12:09:13 | 5 - 9 классы

Помогите пожалуйста?

Помогите пожалуйста!

Напишите программу : По заданному номеру месяца выводилось его название и указано количество дней в месяце.

Nikki09 15 мая 2020 г., 14:49:26 | 5 - 9 классы

Напишите программу, которая вводит с клавиатуры номер месяца и определяет, сколько дней в этом месяце?

Напишите программу, которая вводит с клавиатуры номер месяца и определяет, сколько дней в этом месяце.

При вводе неверного номера месяца должно быть выведено сообщение об ошибке.

Считается, что год невисокосный.

Входные данные Входная строка содержит единственное целое число – номер месяца (возможно, неправильный).

Выходные данные Выходная строка должна содержать одно целое число – количество дней в этом месяце или 0, если был введён неверный номер месяца.

Для PYTHON, не для Pascal.

На этой странице сайта, в категории Информатика размещен ответ на вопрос ПОМОГИТЕ, ПОЖАЛУЙСТА?. По уровню сложности вопрос рассчитан на учащихся 10 - 11 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.