Найти все цифры в записи целого трёхзначного числа?

Информатика | 5 - 9 классы

Найти все цифры в записи целого трёхзначного числа.

Ответить на вопрос
Ответы (1)
Sahko562 3 мар. 2020 г., 12:26:17

Program cifry ;

Var a, x1, x2, x3 : integer ;

Begin Write('введите трехзначное число') ; Readln(a) ; X1 : = a div 100 ; X2 : = (a div 10) mod 10 ; X3 : = a mod 10 ;

Writeln('цифра сотен числа ', а, ' равна ', x1) ;

Writeln('цифра десятков числа ', а, ' равна ', x2) ;

Writeln('цифра единиц числа ', а, ' равна ', x3) ; Readln ;

End.

Froggy 21 июн. 2020 г., 16:45:30 | 10 - 11 классы

Запишите алгоритм, позволяющий определить, есть ли среди цифр заданного целого трёхзначного числа x одинаковые?

Запишите алгоритм, позволяющий определить, есть ли среди цифр заданного целого трёхзначного числа x одинаковые.

Способ записи выберите самостоятельно.

Adelisamolkova 1 февр. 2020 г., 17:37:02 | 10 - 11 классы

В Паскале?

В Паскале!

Ввести целое число и найти сумму его цифр 1) Ввести целое Число - 1234 - Сумма цифр числа равна 10 2) Ввести целое число и определить, верно ли, что в его записи есть 2 одинаковые цифры.

Пример.

Введите целое число - 1234 - НЕТ 1224 - ДА.

Помогите пожалуйста!

))).

Fiber 26 авг. 2020 г., 00:14:51 | 10 - 11 классы

Напечатать в возрастающем порядке все трёхзначные числа, в десятичной записи кот?

Напечатать в возрастающем порядке все трёхзначные числа, в десятичной записи кот.

Нет одинаковых цифр.

AM229 23 окт. 2020 г., 08:40:47 | 10 - 11 классы

. Определите число, полученное выписыванием в обратном порядке цифр заданного целого трёхзначного числа?

. Определите число, полученное выписыванием в обратном порядке цифр заданного целого трёхзначного числа.

НАстик1111 10 нояб. 2020 г., 08:04:40 | 5 - 9 классы

Дано трёхзначное число?

Дано трёхзначное число.

Напишите программу которая определяет есть ли среди цифр заданного целого трёхзначного числа одинаковые.

OAlsonRok 28 июл. 2020 г., 04:23:26 | 5 - 9 классы

Сколько трёхзначных чисел можно записать с помощью цифр 2, 4, 6, и 8 при условий, что в записи числа не должно быть одинаковых цифр?

Сколько трёхзначных чисел можно записать с помощью цифр 2, 4, 6, и 8 при условий, что в записи числа не должно быть одинаковых цифр?

Kovanov2014 27 окт. 2020 г., 02:37:24 | 10 - 11 классы

Дано трёхзначное число?

Дано трёхзначное число.

Найти среди цифр этого числа, максимальное.

Программа в Паскале.

ЕкАтЕрИнА01 22 авг. 2020 г., 08:19:51 | 5 - 9 классы

С клавиатуры вводится любое целое трёхзначное число, найти сумму цифр этого числа?

С клавиатуры вводится любое целое трёхзначное число, найти сумму цифр этого числа.

(Dev C + + ).

MERIVko76 18 мая 2020 г., 19:28:13 | 5 - 9 классы

Составить программу, которая определяет, есть ли среди цифр целого трёхзначного числа одинаковые?

Составить программу, которая определяет, есть ли среди цифр целого трёхзначного числа одинаковые.

Паша66 4 мар. 2020 г., 00:13:51 | 5 - 9 классы

Сколько трёхзначных чисел можно записать с помощью цифр 1, 3, 5 и 7 при условии, что в записи числа не должно быть одинаковых цифр?

Сколько трёхзначных чисел можно записать с помощью цифр 1, 3, 5 и 7 при условии, что в записи числа не должно быть одинаковых цифр?

Вы зашли на страницу вопроса Найти все цифры в записи целого трёхзначного числа?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.