1)Напишите программу, которая считает количество четных цифр введенного числа 2) Напишите программу, которая вводит с клавиатуры натуральное число N и определяет его факториал, т?

Информатика | 10 - 11 классы

1)Напишите программу, которая считает количество четных цифр введенного числа 2) Напишите программу, которая вводит с клавиатуры натуральное число N и определяет его факториал, т.

Е. произведение натуральных чисел от 1 до N : N!

= 1×2×3×.

×N. Что будет, если ввести большое значение N (например, 20)?

3) Напишите программу, которая вводит натуральные числа A и N и вычисляет A ^ N.

Ответить на вопрос
Ответы (1)
Дина9990 22 окт. 2020 г., 21:13:00

1)

var a, b : integer ;

begin readln(a) ; foreach e : char in a.

ToString() do / / Проходит по каждому символу в строке, полученной путём преобразования числа if (Byte.

Parse(e) mod 2 = 0) then inc(b) ; / / Увеличивает значение на 1 writeln(b) ;

end.

= = = = = = = = = = = = = = = = = = = = = = 2 в файле

3)

var a, n : integer ;

begin readln(a, n) ; writeln(power(a, n)) ; / / power возводит число в указанную степень

end.

Koles121 9 февр. 2020 г., 04:04:26 | 5 - 9 классы

Напишите программу, которая после ввода двух натуральных чисел возводит первое число в степень второго?

Напишите программу, которая после ввода двух натуральных чисел возводит первое число в степень второго.

Nastyaepta 10 нояб. 2020 г., 01:33:15 | 10 - 11 классы

Напишите программу, которая вводит натуральное число N и определяет его факториал, то есть произведение натуральных чисел от 1 до N : N ?

Напишите программу, которая вводит натуральное число N и определяет его факториал, то есть произведение натуральных чисел от 1 до N : N !

= 1·2·{.

}· N .

Входные данные Входная строка содержит одно натуральное число N .

Выходные данные Программа должна вывести одно число – факториал введённого числа N .

Izavov88 12 окт. 2020 г., 23:48:38 | 10 - 11 классы

Напишите программу, которая считает количество четных цифр введенного числа?

Напишите программу, которая считает количество четных цифр введенного числа.

Rewmos 1 апр. 2020 г., 02:12:20 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех четных чисел чисел и количество нечетных?

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех четных чисел чисел и количество нечетных.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Elizavetashishe 6 апр. 2020 г., 08:15:42 | 5 - 9 классы

Напишите программу, которая вводит натуральное число N и выводит на экран N псевдослучайных чисел?

Напишите программу, которая вводит натуральное число N и выводит на экран N псевдослучайных чисел.

Wewqeq 19 дек. 2020 г., 18:12:56 | 5 - 9 классы

Написать программу при которой с клавиатуры вводится натуральное число n не при восходящее 1000 и выводится произведение цифр этого числа?

Написать программу при которой с клавиатуры вводится натуральное число n не при восходящее 1000 и выводится произведение цифр этого числа.

K09 26 сент. 2020 г., 08:15:17 | 10 - 11 классы

Напишите программу, которая вводит натуральное число N и выводит первые N четных натуральных чисел?

Напишите программу, которая вводит натуральное число N и выводит первые N четных натуральных чисел.

XDante 23 апр. 2020 г., 21:06:58 | 10 - 11 классы

Напишите программу, которая вводит натуральные числа а иб и выводит сумму квадратов натуральных чисел в диапазоне от а до б?

Напишите программу, которая вводит натуральные числа а иб и выводит сумму квадратов натуральных чисел в диапазоне от а до б.

Pashqa777 17 февр. 2020 г., 07:52:00 | 5 - 9 классы

1) напишите программу которое вводит натуральное число"n" и находит сумму всех натуральных чисел от 1 до n (цикл пока)?

1) напишите программу которое вводит натуральное число"n" и находит сумму всех натуральных чисел от 1 до n (цикл пока).

2)напишите программу которое вводит натуральное число "n" и выводит первые "n" четных натуральных чисел.

3)напишите программу которая вводит натуральные числа "a и b" и выводит квадраты натуральных чисел в диапазоне от "a до b".

Помогите пожалуйста , а то не понимаю))).

Zhansaya20031 11 дек. 2020 г., 19:14:02 | 10 - 11 классы

Напишите программу которая вводит с клавиатуры натуральное число n и определяет его факториал?

Напишите программу которая вводит с клавиатуры натуральное число n и определяет его факториал.

Вопрос 1)Напишите программу, которая считает количество четных цифр введенного числа 2) Напишите программу, которая вводит с клавиатуры натуральное число N и определяет его факториал, т?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.