Написать программу на языке Pascal Палиндромом называется строка, которая одинаково читается как слева направо, так и справа налево?

Информатика | 10 - 11 классы

Написать программу на языке Pascal Палиндромом называется строка, которая одинаково читается как слева направо, так и справа налево.

Рассмотрим все натуральные числа, запись которых в десятичной системе счисления является палиндромом (при этом запись не начинается с нуля).

Например, числа 121 и 1331 являются палиндромами, а число 123 — нет.

По данному числу N найдите N - e в порядке возрастания число - палиндром.

Программа получает на вход одно натуральное число N, не превосходящее 100 000.

Программа должна вывести одно натуральное число — N - е в порядке возрастания число - палиндром.

Пример входных и выходных данных Ввод 20 Вывод 111.

Ответить на вопрос
Ответы (1)
Mgruzevich 24 февр. 2020 г., 17:46:47

Var s : string ; n, m : integer ;

begin readln(n) ; if (n < ; = 9) then write(n) else if (n < ; = 9 + 9) then begin s : = inttostr(n - 9) ; write(s + s) ; end else if (n < ; = 9 + 9 + 90) then begin s : = inttostr(n - 9 - 9 + 10 - 1) ; m : = s.

Length - 1 ; write(s + s[m : 0 : - 1]) ; end else if (n < ; = 9 + 9 + 90 + 90) then begin s : = inttostr(n - 9 - 9 + 90 + 10 - 1) ; write(s + s[ : : - 1]) ; end else if (n < ; = 9 + 9 + 90 + 90 + 900) then begin s : = inttostr(n - 9 - 9 - 90 - 90 + 100 - 1) ; m : = s.

Length - 1 ;

write(s + s[m : 0 : - 1]) ; end else if (n < ; = 9 + 9 + 90 + 90 + 900 + 900) then begin s : = inttostr(n - 9 - 9 - 90 - 90 - 900 + 100 - 1) ; write(s + s[ : : - 1]) ; end else if (n < ; = 9 + 9 + 90 + 90 + 900 + 900 + 9000) then begin s : = inttostr(n - 9 - 9 - 90 - 90 - 900 - 900 + 1000 - 1) ; m : = s.

Length - 1 ; write(s + s[m : 0 : - 1]) ; end else if (n < ; = 9 + 9 + 90 + 90 + 900 + 900 + 9000 + 9000) then begin s : = inttostr(n - 9 - 9 - 90 - 90 - 900 - 900 - 9000 + 1000 - 1 ) ; write(s + s[ : : - 1]) ; end else begin s : = inttostr(n - 9 - 9 - 90 - 90 - 900 - 900 - 9000 - 9000 + 10000 - 1) ; m : = s.

Length - 1 ; write(s + s[m : 0 : - 1]) ; end

end.

Елена2025 4 мар. 2020 г., 13:56:43 | 5 - 9 классы

Число называется палиндромом, если справа налево и слева направо читается одинаково?

Число называется палиндромом, если справа налево и слева направо читается одинаково.

Например, 12321 – палиндром.

Найдите ближайший палиндром, больший числа 13244.

Пример : для числа 12 ближайший палиндром, больший него, это 22.

Elle1995 26 июн. 2020 г., 14:54:04 | 10 - 11 классы

Ребят помогите с задачей в Pacal?

Ребят помогите с задачей в Pacal.

Натуральное число называется палиндромом, если его запись читается одинаково с начала и с конца (например : 1, 22, 393).

Найти все меньшие 100 натуральные числа , которые при возведении в квадрат дают палиндром.

Aselya5 26 мар. 2020 г., 17:30:08 | 5 - 9 классы

Помогите пожалуйста решить задачу в паскале : Составить программу, проверяющую, является ли заданное натуральное число палиндромом, т?

Помогите пожалуйста решить задачу в паскале : Составить программу, проверяющую, является ли заданное натуральное число палиндромом, т.

Е. таким, которое читается одинаково слева направо и справа налево(например : 23132).

Nastyaepta 10 нояб. 2020 г., 01:33:15 | 10 - 11 классы

Напишите программу, которая вводит натуральное число N и определяет его факториал, то есть произведение натуральных чисел от 1 до N : N ?

Напишите программу, которая вводит натуральное число N и определяет его факториал, то есть произведение натуральных чисел от 1 до N : N !

= 1·2·{.

}· N .

Входные данные Входная строка содержит одно натуральное число N .

Выходные данные Программа должна вывести одно число – факториал введённого числа N .

Kraynova009 2 апр. 2020 г., 15:39:02 | 5 - 9 классы

Дано трёхзначное число?

Дано трёхзначное число.

Напишите в паскаль программу, которая определяет : Является ли число "перевёртышем", т.

Е. числом, десятичная запись которого читается одинаково слева направо и справа налево.

Anzhelako 28 дек. 2020 г., 08:06:38 | 5 - 9 классы

Число называется палиндромом, если справа налево и слева направо читается одинаково?

Число называется палиндромом, если справа налево и слева направо читается одинаково.

Например, 12321 – палиндром.

Найдите ближайший палиндром, больший числа 13244.

Пример : для числа 12 ближайший палиндром, больший него, это 22.

Netepluk36 6 мая 2020 г., 13:32:28 | 10 - 11 классы

Напишите программу, которая вводит натуральное число N и выводит на экран чётные положительные степени числа 2, не большие, чем N , в порядке убывания?

Напишите программу, которая вводит натуральное число N и выводит на экран чётные положительные степени числа 2, не большие, чем N , в порядке убывания.

Входные данные : Входная строка содержит одно натуральное число N .

Выходные данные : Программа должна вывести в одну строчку через пробел чётные положительные степени числа 2, не большие, чем N , в порядке убывания.

Если таких нет, программа должна вывести число 0.

Zexxxxxx 19 окт. 2020 г., 15:28:12 | 10 - 11 классы

Палиндромом назовем число, состоящее не менее чем из 2 - х символов или цифр, одинаково читающееся как слева направо, так и наоборот?

Палиндромом назовем число, состоящее не менее чем из 2 - х символов или цифр, одинаково читающееся как слева направо, так и наоборот.

Например, число «1221» является палиндромом, а число «1224» – нет.

Назовем палиндромом - 1016 число, являющееся палиндромом в десятичном и шестнадцатеричном представлении.

Количество палиндромов - 1016 среди первых десяти миллионов натуральных чисел составит….

RogovaЛюба 20 дек. 2020 г., 05:03:32 | 5 - 9 классы

C + + или Паскальрешите пожалуйстааааНатуральное число называется если читается слева направо и справа налево одинаково?

C + + или Паскаль

решите пожалуйстаааа

Натуральное число называется если читается слева направо и справа налево одинаково.

Вам

дано одно натуральное число N, которое состоит из не более чем 106 цифр.

Найдите наименьший

палиндром, который строго больше N.

Формат входного файла

В единственной строке входного файла содержится одно натуральное число N.

N не содержит

лидирующих нулей и состоит из не более чем 106 цифр.

Формат выходного файла

Выведите одно целое число – наименьший палиндром, который строго больше N.

Например 365 - 373.

Anya040904 5 дек. 2020 г., 04:08:00 | 10 - 11 классы

Чебурашка составлял палиндромы из букв Ч и Б?

Чебурашка составлял палиндромы из букв Ч и Б.

Получилось 35 палиндромов.

Сколько было букв Ч, если букв Б было 7?

(В каждом палиндроме использовались все буквы Ч и все буквы Б.

) В качестве ответа укажите одно натуральное число.

Комментарий.

Палиндромом называется строка, которая одинаково читается как слева направо, так и справа налево.

Например, ЧЧББЧЧ — это палиндром.

Вы находитесь на странице вопроса Написать программу на языке Pascal Палиндромом называется строка, которая одинаково читается как слева направо, так и справа налево? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.