Вариант 8 Дано трёхзначное натуральное число?

Информатика | 5 - 9 классы

Вариант 8 Дано трёхзначное натуральное число.

Получить другое натуральное число, в котором порядок цифр изменён на противоположный.

Как будет выглядеть эта программа на языке паскаль?

Ответить на вопрос
Ответы (1)
Zed21 27 мая 2020 г., 13:06:50

Program swap

var a, b, c, n, m : integer ;

begin

readln(n) ;

a : = n mod 10 ;

m : = n - a ;

n : = m / 10 ;

b : = n mod 10 ;

m : = n - b ;

c : = m / 10 ;

m : = a * 100 + b * 10 + c ;

writeln('Ответ : ', n) ;

readln ;

end.

Menrostovnadonu 23 мая 2020 г., 19:55:05 | 5 - 9 классы

Народ очень срочно надо?

Народ очень срочно надо!

Напишите программу на языке Pascal.

Дано натуральное число n.

Получить число k из числа n, поменяв порядок цифр исходного числа на противоположный.

Antonkhvorov 20 июн. 2020 г., 12:56:51 | 10 - 11 классы

1) дано натуральное а?

1) дано натуральное а.

Верно ли, что данное число состоит из 3 цифр?

2) дано натуральное число.

Верно ли, что в данном числе четыре цифры?

3) Даны два натуральных числа.

Определить в каком числе первая цифра больше.

4) Дано натуральное n.

Найти количество 6, входящих в данное число.

Нужно решить в программе паскаль.

Если поможет, то мы учим цикл в паскале, div, mod.

CamKo 22 мар. 2020 г., 10:05:22 | 5 - 9 классы

Составить программу на паскале Дано натуральное число, найти сумму цифр этого числа?

Составить программу на паскале Дано натуральное число, найти сумму цифр этого числа!

Sofiykas 5 июн. 2020 г., 20:18:17 | 10 - 11 классы

Даны натуральные числа m и n?

Даны натуральные числа m и n.

Получить число состоящее из m последних чётных цифр числа n.

Написать программу на Паскале только на Паскале.

Kovanov2014 27 окт. 2020 г., 02:37:24 | 10 - 11 классы

Дано трёхзначное число?

Дано трёхзначное число.

Найти среди цифр этого числа, максимальное.

Программа в Паскале.

Улка1 29 мар. 2020 г., 10:07:58 | 5 - 9 классы

Паскаль составьте программу определения наибольшей цифры в записи данного натурального числа?

Паскаль составьте программу определения наибольшей цифры в записи данного натурального числа.

Ryazanceva0303 28 мая 2020 г., 19:24:24 | 5 - 9 классы

Дано натуральное число ?

Дано натуральное число .

Определить есть ли в нем цифра а Написать с постусловием язык Паскаля !

Viktorova2303 1 мая 2020 г., 07:41:21 | 5 - 9 классы

Запишите на языке Паскаль программу, которая для произвольного натурального двузначного числа определяет : 1) сумму и произведение его цифр ; 2) число, образованное перестановкой цифр исходного числа?

Запишите на языке Паскаль программу, которая для произвольного натурального двузначного числа определяет : 1) сумму и произведение его цифр ; 2) число, образованное перестановкой цифр исходного числа.

Катюшка170212 27 сент. 2020 г., 04:27:12 | 5 - 9 классы

Написать программу в паскале?

Написать программу в паскале.

Дано натуральное число Х.

Найти сумму квадратов чётных цифр в числе.

Millenium76 6 дек. 2020 г., 10:50:49 | 5 - 9 классы

Дано натуральное число n?

Дано натуральное число n.

Вычислите произведение нечетных натуральных чисел от 1 до n.

Как должна правильно выглядеть программа?

Перед вами страница с вопросом Вариант 8 Дано трёхзначное натуральное число?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.