Дан массив натуральных чисел найти количество элементов кратных данному k СРОЧНО?

Информатика | 10 - 11 классы

Дан массив натуральных чисел найти количество элементов кратных данному k СРОЧНО!

ПОЖАЛУЙСТА ПОМОГИТЕ!

Ответить на вопрос
Ответы (1)
Andreyjukby 3 янв. 2020 г., 01:37:44

Быол бы неплохо указывать среду прoграммирования.

Paskal.

Program massiv ;

uses crt ;

var A : array [1.

200] of integer ; n, i, k, s : integer ;

begin ;

clrscr ;

writeln ('введите количество элементов в массиве') ;

readln(n) ;

randomize ;

writeln ('задан массив') ;

for i : = 1 to n do begin a[i] : = - 10 + random(21) ; write (a[i], ' ') ; end ;

writeln ;

writeln ('введите число') ; {кратное которому необходимо найти}

readln (k) ;

for i : = 1 to n do

if (a[]i]< ; > ; 0) and (a[i] mod k = 0) then s : = s + 1 ;

write ('количество элементов кратных введенному числу - ', s) ;

readkey

end.

Jmjmjmjmj500 27 февр. 2020 г., 16:12:32 | 10 - 11 классы

Дан массив натуральных чисел ?

Дан массив натуральных чисел .

Найти сумму элементов , кратных заданному К.

Veronica1902 22 окт. 2020 г., 22:58:05 | 10 - 11 классы

Помогите пожалуйста написать программу на паскале : дан массив целых чисел?

Помогите пожалуйста написать программу на паскале : дан массив целых чисел.

Найти количество элементов, кратных 5, расположенных между максимальным и минимальным элементами массива (включая их).

Про100кири4 20 янв. 2020 г., 09:27:38 | 10 - 11 классы

Дан массив целых чисел из 12 элементов?

Дан массив целых чисел из 12 элементов.

Найти количество элементов массива являющихся кратными трем и пяти.

Седдааа 7 апр. 2020 г., 01:01:43 | 5 - 9 классы

Дан массив состоящий из 10 элементов заполнить массив целых чисел найти сумму, количество элементов положительных и кратных три?

Дан массив состоящий из 10 элементов заполнить массив целых чисел найти сумму, количество элементов положительных и кратных три.

Ariname 14 мая 2020 г., 07:02:43 | 5 - 9 классы

1. Дан массив целых чисел, найти среднее арифметическое всех элементов массива?

1. Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел, найти количество отрицательных элементов массива.

3. Дан массив целых чисел, найти количество чётных чисел в массиве.

Диана200356 19 янв. 2020 г., 19:36:48 | 5 - 9 классы

Одномерные массивы?

Одномерные массивы.

Дан массив натуральных чисел, состоящий из n элементов.

Найти сумму элементов массива, кратных данному числу К.

(паскаль).

MRcoffee 14 мар. 2020 г., 08:36:28 | 5 - 9 классы

Помогите решить задачи на паскаль?

Помогите решить задачи на паскаль.

1) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти произведение всех элементов массива.

2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти сумму четных элементов массива.

3) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива.

4) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива среди элементов, кратных 3.

Sashulya20 15 апр. 2020 г., 18:20:05 | 5 - 9 классы

Дан массив натуральных чисел, заполненный случайными числами?

Дан массив натуральных чисел, заполненный случайными числами.

Найти произведение элементов кратных 3.

SarymovaKaramelya 4 июл. 2020 г., 23:23:18 | 5 - 9 классы

Одномерные массивы?

Одномерные массивы.

Дан массив натуральных чисел, состоящий из n элементов.

Найти сумму элементов массива, кратных данному числу К.

Кпек42пк 12 июн. 2020 г., 02:41:47 | 5 - 9 классы

Дан массив из 20 натуральных чисел?

Дан массив из 20 натуральных чисел.

Составить программу суммы элементов, кратных данному числу d .

На этой странице сайта размещен вопрос Дан массив натуральных чисел найти количество элементов кратных данному k СРОЧНО? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 10 - 11 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.