10 Класс Напишите программу обработки последовательности целых чисел?

Информатика | 5 - 9 классы

10 Класс Напишите программу обработки последовательности целых чисел.

На вход программе сначала подается натуральное число N - кол - во элементов последовательности, N не превосходит 1000.

Затем следуют натуральные числа, каждое число в отдельной строке.

Каждый элемент последовательности не превосходит 10000.

Программа должна выводить все элементы последовательности, являющиеся трехзначными числами, кратными семи, в порядке, обратном порядке ввода.

Если таковых нет, программа выводит число - 1 Заранее спасибо!

Ответить на вопрос
Ответы (1)
Ударник2014 6 нояб. 2020 г., 01:37:00

Program primer ;

Var a : array[1.

1000] of integer ; i, m, k, n : integer ;

Begin

readln(n) ;

for i : = 1 to n do

read(a[i]) ;

for i : = n downto 1 do begin / / в обратном порядке

k : = 0 ;

m : = a[i] ;

while m> ; 0 do begin

m : = m div 10 ;

inc(k) ; / / ищем количество разрядов

end ;

if ((a[i] mod 7) = 0) and (k = 3) then write(a[i] : 2) ; / / кратно 7 и 3 разряда - выводим

end ;

end.

ABC Pascal.

BelaGaGi 28 апр. 2020 г., 22:11:37 | 5 - 9 классы

Напишите программу которая в последовательности натуральных чисел определяет сумму чисел, кратных 6?

Напишите программу которая в последовательности натуральных чисел определяет сумму чисел, кратных 6.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число кратное 6.

Кол - во чисел не превышает 100.

Введённые числа не привышают 300.

Программа должна ввести одно число - сумму чисел кратных 6.

Настя3254 1 мая 2020 г., 01:49:08 | 10 - 11 классы

С1. Составьте программу, которая вводит с клавиатуры три различных целых числа, каждое из которых по абсолютной величине не превосходит 100 (каждое число – с новой строки), и выводит на экран число, р?

С1. Составьте программу, которая вводит с клавиатуры три различных целых числа, каждое из которых по абсолютной величине не превосходит 100 (каждое число – с новой строки), и выводит на экран число, равное произведению максимального и минимального из них, если минимальное число отрицательно ; или сумме максимального и минимального из них, если минимальное число неотрицательно.

Ничего, кроме указанного числа, программа выводить не должна.

С2. Составьте программу, которая вводит с клавиатуры натуральное число N, не превосходящее 12, а затем N целых неотрицательных чисел ( каждое чисол - с новой строки), записывает эти N чисел в массив, выводит на экран сначала в обратном порядке все, без исключения, элементы массива, затем, в прямом порядке относительно следования в массиве, все элементы, остаток которых от деления на 8 равен 3.

Каждое число программа должна выводить в отдельной строке ; ничего, кроме чисел, программа выводить не должна.

С3. См.

Фото.

Делька2001год 19 нояб. 2020 г., 19:36:59 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3?

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, кратное 3.

Количество чисел не превышает 100.

Введённые числа не превышают 300.

Программа должна вывести одно число – сумму чисел, кратных 3.

Murmurm 3 авг. 2020 г., 21:35:02 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 6?

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 6.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, крат​ное 6.

Nic1000 22 мая 2020 г., 05:14:03 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 3?

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 3.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, кратное 3.

Количество чисел не превышает 100.

Введённые числа не превышают 300.

Программа должна вывести одно число - количество чисел, кратных 3.

Vut 12 февр. 2020 г., 23:03:03 | 10 - 11 классы

Напишите программу, которая в последовательности натуральных чисел определяет количество трёхзначных чисел, кратных 4?

Напишите программу, которая в последовательности натуральных чисел определяет количество трёхзначных чисел, кратных 4.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа не превышают 30 000.

Программа должна вывести одно число : количество трёхзначных чисел, кратных 4.

Напишите программу в паскале пожайлуста.

Sumir87 15 дек. 2020 г., 05:43:00 | 5 - 9 классы

Напишите программу, которая в последовательности натуральныхчисел определяет количество чисел, кратных 6?

Напишите программу, которая в последовательности натуральных

чисел определяет количество чисел, кратных 6.

Программа получает

на вход количество чисел в последовательности, а затем сами числа.

В

последовательности всегда имеется число, кратное 6.

Количество чисел не превышает 1000.

Введённые числа не превышают

30 000.

Программа должна вывести одно число – количество чисел, кратных 6.

Пример работы программы :

13343 18 февр. 2020 г., 06:04:01 | 5 - 9 классы

ПОМОГИТЕ, ПОЖАЛУЙСТА, НАПИСАТЬ ПРОГРАММУ Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3?

ПОМОГИТЕ, ПОЖАЛУЙСТА, НАПИСАТЬ ПРОГРАММУ Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, кратное 3.

Количество чисел не превышает 100.

Введённые числа не превышают 300.

Программа должна вывести одно число – сумму чисел, кратных 3.

Yulai 14 окт. 2020 г., 20:21:05 | 5 - 9 классы

ПОМОГИТЕ, ПОЖАЛУЙСТА, НАПИСАТЬ ПРОГРАММУ Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3?

ПОМОГИТЕ, ПОЖАЛУЙСТА, НАПИСАТЬ ПРОГРАММУ Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, кратное 3.

Количество чисел не превышает 100.

Введённые числа не превышают 300.

Программа должна вывести одно число – сумму чисел, кратных 3.

SuperKayne 22 апр. 2020 г., 01:45:06 | 5 - 9 классы

Напишите программу которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 0?

Напишите программу которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 0.

Программа получает на вход натуральные числа, количество введеных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).

Вы открыли страницу вопроса 10 Класс Напишите программу обработки последовательности целых чисел?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.