1)В переменные А и В записаны целые числа (оператором присваивания, например, А : = 20 ; В : = 13)?

Информатика | 10 - 11 классы

1)В переменные А и В записаны целые числа (оператором присваивания, например, А : = 20 ; В : = 13).

Поменяйте числа в этих переменных местами.

Воспользуйтесь третьей переменной – С.

2)Выполните задание 13 без использования третьей переменной С.

Помогите, пожалуйста.

Ответить на вопрос
Ответы (1)
Stranger3 14 сент. 2020 г., 07:10:57

Var a, b, c : integer ;

begin { Первый способ } a : = 20 ; b : = 13 ; c : = a ; a : = b ; b : = c ; Writeln('a = ', a, ', b = ', b) ; { Второй способ } a : = 20 ; b : = 13 ; a : = a + b ; b : = a - b ; a : = a - b ; Writeln('a = ', a, ', b = ', b) ;

end.

Тестовое решение :

a = 13, b = 20

a = 13, b = 20.

Qwert20 7 февр. 2020 г., 07:00:26 | 10 - 11 классы

Если Y – вещественная переменная, а N – целая, то правилен или нет следующий оператор присваивания : y : = sqr(sqrt(n))?

Если Y – вещественная переменная, а N – целая, то правилен или нет следующий оператор присваивания : y : = sqr(sqrt(n)).

(Ответ обосновать).

Gfgfhfyfy 28 дек. 2020 г., 02:07:57 | 5 - 9 классы

9. Запишите операторы присваивания, определяющие значения переменной Х по следующим правилам ?

9. Запишите операторы присваивания, определяющие значения переменной Х по следующим правилам :

Эльма6 1 авг. 2020 г., 14:39:21 | 5 - 9 классы

Запишите оператор присваивания переменной X случайной величины в диапазоне от 2 до 59?

Запишите оператор присваивания переменной X случайной величины в диапазоне от 2 до 59.

Danja97 3 апр. 2020 г., 06:26:22 | 5 - 9 классы

Составьте программу, которая считывает с клавиатуры значения переменных а и b, затем меняет между собой значения этих переменных и выводит их на экран, без использования третьей переменной?

Составьте программу, которая считывает с клавиатуры значения переменных а и b, затем меняет между собой значения этих переменных и выводит их на экран, без использования третьей переменной.

Tach5230 14 нояб. 2020 г., 03:39:38 | 5 - 9 классы

После выполнения команды присваивания b : = b + a, переменная а приняла значение 5, а переменная b - значение 7?

После выполнения команды присваивания b : = b + a, переменная а приняла значение 5, а переменная b - значение 7.

Чему было равно значение переменной b до выполнения команды присваивания?

Ника880 7 нояб. 2020 г., 08:48:12 | 5 - 9 классы

Написать программу в паскале Даны две переменных с некоторыми значениями?

Написать программу в паскале Даны две переменных с некоторыми значениями.

Поменять местами значения этих переменных.

DarkLord111 13 авг. 2020 г., 16:52:25 | 5 - 9 классы

После выполнения команды присваивания х : = х + у значение переменной х равна 3, а значение переменной у равно 5?

После выполнения команды присваивания х : = х + у значение переменной х равна 3, а значение переменной у равно 5.

Чему были равны значения переменной х и у до выполнения указанной команды присваивания?

Lnazhivina 27 июн. 2020 г., 12:54:17 | 5 - 9 классы

Как вы думаете, можно ли использовать в арифметическом выражении оператора присваивания неопределенную переменную?

Как вы думаете, можно ли использовать в арифметическом выражении оператора присваивания неопределенную переменную?

К каким последствиям это может привести?

Mskoboskina 26 окт. 2020 г., 16:30:18 | 5 - 9 классы

Что изменя ится при присваивании переменой?

Что изменя ится при присваивании переменой.

Helenua1901 25 окт. 2020 г., 01:36:42 | 5 - 9 классы

В переменной X записано некоторое число?

В переменной X записано некоторое число.

Записать в переменную Y значение 10, если X чётное и записать - 10, если X нечётное.

Оператор if использовать не разрешается.

Вы находитесь на странице вопроса 1)В переменные А и В записаны целые числа (оператором присваивания, например, А : = 20 ; В : = 13)? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.