Помогите пожалуйста уменьшение положительного числа до тех пор, пока оно неотрицательное?

Информатика | 10 - 11 классы

Помогите пожалуйста уменьшение положительного числа до тех пор, пока оно неотрицательное.

Как только число становится отрицательным, команда повторения заканчивает свою работу программу в Pascal ABC.

Ответить на вопрос
Ответы (1)
Dayana20000220 13 авг. 2020 г., 15:32:58

Странная задача, однако.

Но :

program z1 ;

var k : integer ;

begin

writeln('Введите число') ;

readln(k) ;

while(k> ; 0) do

k : = k - 1 ;

writeln(k) ;

end.

Sulamif70 15 сент. 2020 г., 09:19:21 | 10 - 11 классы

Вводить числа до тех пор пока не пудет введено положительное найти номер минимального?

Вводить числа до тех пор пока не пудет введено положительное найти номер минимального.

(Решать в паскале).

5клас 4 июн. 2020 г., 06:42:03 | 10 - 11 классы

Ребят, помоги в паскале?

Ребят, помоги в паскале.

Напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0.

В конце работы программы на экран выводится сумма и произведение введенных чисел.

Irunka1003 19 апр. 2020 г., 05:04:39 | 10 - 11 классы

Pascal Вводится число?

Pascal Вводится число.

Если оно положительное, то уменьшить его в 10 раз.

Romni441r 13 февр. 2020 г., 01:10:25 | 10 - 11 классы

Минимальное число в последовательности положительных чисел?

Минимальное число в последовательности положительных чисел.

Pascal ABC.

2635112476 19 дек. 2020 г., 18:05:33 | 5 - 9 классы

Pascal ABCЗадача 1составить программу которая запрашивает целое число не равное нулю сообщает положительное они или отрицательное и при этом положительное число уменьшает в 2 раза, отрицательные возво?

Pascal ABC

Задача 1

составить программу которая запрашивает целое число не равное нулю сообщает положительное они или отрицательное и при этом положительное число уменьшает в 2 раза, отрицательные возводит в квадрат .

Задача 2

составить программу , которая определяет является ли введенное число нечетным и выводит на экран сообщение да или нет .

Milavika1980 9 окт. 2020 г., 23:48:38 | 10 - 11 классы

Напишите программу, которая вводила бы целые числа и суммировала их до тех пор, пока пользователь не ввел число 0?

Напишите программу, которая вводила бы целые числа и суммировала их до тех пор, пока пользователь не ввел число 0.

Moretz1337 25 авг. 2020 г., 18:49:52 | 5 - 9 классы

Привет?

Привет.

Напишите, пожалуйста, программу, которая будет вводить целые числа до тех пор, пока не будет введён нуль.

Подсчитать количество положительных и отрицательных чисел.

KsyshaCet 12 нояб. 2020 г., 06:21:35 | 5 - 9 классы

Напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено число 0?

Напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено число 0.

В конце работы программы на экран выводится минимальное и максимальное из введенных чисел (не считая 0).

Кристина200401 3 апр. 2020 г., 03:24:05 | 5 - 9 классы

Запрашиваются числа до тех пор пока не будет введено число 0?

Запрашиваются числа до тех пор пока не будет введено число 0.

Вычислить среднее арифметическое положительных чисел из запрошеных.

(С помощью цикла "Пока" в паскале).

Jjj21 25 дек. 2020 г., 13:03:17 | 5 - 9 классы

Составте программу решающую следующую задачу дано число н если оно неотрицательно то возвести его в квадрат а если отрицательно то в третью степень?

Составте программу решающую следующую задачу дано число н если оно неотрицательно то возвести его в квадрат а если отрицательно то в третью степень.

Вы зашли на страницу вопроса Помогите пожалуйста уменьшение положительного числа до тех пор, пока оно неотрицательное?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.