Даны длины а, в, с сторон некоторого треугольника?

Информатика | 5 - 9 классы

Даны длины а, в, с сторон некоторого треугольника.

Найти медианы треугольника, сторонами которого являются медианы исходного треугольника.

PASCAL ABC Нужно написать программу, используя процедуру(ы) и функцию(ы).

Пожалуйста, помогите!

: ).

Ответить на вопрос
Ответы (1)
Freyern 20 авг. 2020 г., 07:24:37

Type num = double ; { в этом месте можно сменить тип на иной }

function Legal(a, b, c : num) : boolean ; { возвращает True, если из отрезков длиной a, b, c можно построить треугольник }

begin Legal : = (a + b> ; c) and (a + c> ; b) and (b + c> ; a)

end ;

function Med(a, b, c : num) : num ; { возвращает длину медианы, проведенную к стороне а }

begin Med : = sqrt(2 * (sqr(b) + sqr(c)) - sqr(a)) / 2

end ;

procedure Med3(a, b, c : num ; var m1, m2, m3 : num) ; { возвращает длины m1, m2, m3 всех медиан треугольника, построенного из отрезков длиной a, b, c.

При этом m1 - длина медианы, проведенной к стороне а, m2 - дилна медианы, проведенной к стороне b и т.

Д. Если треугольник построить нельзя, m1 = m2 = m3 = 0 }

begin if Legal(a, b, c) then begin m1 : = Med(a, b, c) ; m2 : = Med(b, a, c) ; m3 : = Med(c, a, b) end else begin m1 : = 0 ; m2 : = 0 ; m3 : = 0 end

end ;

{ основная программа }

var a, b, c, m1, m2, m3 : num ;

begin Write('Введите длины сторон треугольника : ') ; Readln(a, b, c) ; Med3(a, b, c, m1, m2, m3) ; if m1> ; 0 then begin Med3(m1, m2, m3, m1, m2, m3) ; if m1> ; 0 then Writeln('Длины медиан : ', m1, ', ', m2, ', ', m3) else Writeln('Из полученных медиан нельзя построить треугольник.

') end else Writeln('Невозможно построить треугольник с такими сторонами.

')

end.

Тестовое решение :

Введите длины сторон треугольника : 14.

3 18.

9 8. 6

Длины медиан : 10.

725, 14.

175, 6.

45.

Alinkaqwerty4 6 сент. 2020 г., 08:44:27 | 10 - 11 классы

Программа Pascal?

Программа Pascal.

Даны координаты 3 точек x1, x2, x3, y1, y2, y3, которые представляют собой вершины треугольника.

Вычислить а) Длины сторон треугольника б)Площадь треугольника.

Rakff 7 мар. 2020 г., 03:17:36 | 10 - 11 классы

Напишите программу Pascal в ЦИКЛИЧЕСКОМ алгоритме?

Напишите программу Pascal в ЦИКЛИЧЕСКОМ алгоритме.

Задача : Определить, являются ли подобными 2 треугольника, если известны длины всех 3 - х сторон каждого треугольника.

Artyom120304123 9 дек. 2020 г., 08:23:41 | 10 - 11 классы

Дан круг радиуса R?

Дан круг радиуса R.

Определить, поместиться ли правильный треугольник со сторонами а в этом круге.

Для программы Pascal.

Missisanat 14 дек. 2020 г., 22:04:05 | 10 - 11 классы

Помогите пж?

Помогите пж.

Составить линейную программу для решения задачи.

Дана сторона равностороннего треугольника.

Найти высоту этого треугольника.

Misssukhodoeva 29 нояб. 2020 г., 12:10:28 | 5 - 9 классы

ПОМОГИТЕ ПОЖАЛУЙСТА НАПИСАТЬ ПРОГРАММУ В QBASIC?

ПОМОГИТЕ ПОЖАЛУЙСТА НАПИСАТЬ ПРОГРАММУ В QBASIC!

Периметр треугольника равен Р, длина одной стороны равна А, другой - В.

Найти длину третьей стороны.

Ishbuildina 16 июл. 2020 г., 18:01:02 | 10 - 11 классы

Составить программу вычисления длин медиан треугольника, у которой длины сторон a, b, c?

Составить программу вычисления длин медиан треугольника, у которой длины сторон a, b, c.

Соня183 11 янв. 2020 г., 21:06:13 | 10 - 11 классы

Даны три натуральных числа, являющиеся длинами сторон треугольника?

Даны три натуральных числа, являющиеся длинами сторон треугольника.

Число ввести с клавиатуры.

Определить является ли треугольник прямоугольным, если эти отрезки позволяют его построить.

Написать программу на паскале только на паскале и не на другом языке!

893737658 14 мар. 2020 г., 10:03:21 | 5 - 9 классы

Вычислите длины медианы треугольника, заданного длинами сторон?

Вычислите длины медианы треугольника, заданного длинами сторон.

KamilagabdulliNa 7 дек. 2020 г., 07:21:43 | 10 - 11 классы

Разработайте программу в паскаль, которая проверяет возможность существования треугольника с заданными сторонами (треугольник может быть изображен на плоскости, если сумма длин любой пары сторон больш?

Разработайте программу в паскаль, которая проверяет возможность существования треугольника с заданными сторонами (треугольник может быть изображен на плоскости, если сумма длин любой пары сторон больше длины третьей стороны).

Программа запрашивает у пользователя длины сторон треугольника и на основании этих данных делает вывод о возможности существования треугольника с такими сторонами.

Evakvachinskaya 20 мая 2020 г., 03:49:52 | 5 - 9 классы

1. Даны 3 числа А, В и С?

1. Даны 3 числа А, В и С.

Выяснить существует ли треугольник со сторонами А, В, С (Pascal ABC).

Вы перешли к вопросу Даны длины а, в, с сторон некоторого треугольника?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.