Код на PASCAL ?

Информатика | 10 - 11 классы

Код на PASCAL !

Ответить на вопрос
Ответы (1)
Dasharodina89 8 янв. 2020 г., 11:29:02

Function Prod(a : real ; n : integer) : real ;

var i : integer ; p : real ;

begin p : = 1 ; for i : = 1 to abs(n) do p : = p * a ; if n< ; 0 then Prod : = 1 / p else Prod : = p

end ;

function Pow(a, b : real) : real ;

var p : integer ;

begin if b = Int(b) then Pow : = Prod(a, Trunc(b)) else Pow : = exp(b * ln(a))

end ;

var a, c, x, y, p1, p2, pp : real ;

begin a : = 1 ; c : = 2 ; x : = - 1 ; p1 : = 3 * abs(sqr(a) - 5 * Pow((tan(sqr(c))), 3)) ; p2 : = 4 * Pow(cos(5 * sqr(sin(x))), 3) * cos(x) ; p2 : = p2 / (5 * Pow(sin(3 * x), 3 * x)) ; y : = p1 + sqrt(p2 - 4 * sqrt(a) / (5 * Pow(tan(c), 5))) ; Writeln('a = ', a, ', c = ', c, ', x = ', x, ', y = ', y : 0 : 6)

end.

Тестовое решение :

a = 1, c = 2, x = - 1, y = 20.

412194

В этой формуле заложен "подводный камень".

При х = - 1 получается отрицательное значение sin(3x), которое надо возводить в степень 3х.

В компьютерных расчетах определяется операция возведения в степень путем последовательного умножения, когда показатель степени - натуральное число, а также операция возведения в любую степень может быть выполнена через логарифм и экспоненту, но только при неотрицательном основании степени.

Считая вручную, мы бы, конечно, сделали преобразование, избавившись от отрицательной степени :

$sin^{-3}(-3)= \frac{1}{sin^3(-3)}$, но компьютер сам этого сделать не может, поэтому пришлось написать две функции, построив на их основе возведение в степень Pow(a, b).

Nastena5252 20 июн. 2020 г., 13:16:29 | 5 - 9 классы

PASCAL ABC Символьный тип данных?

PASCAL ABC Символьный тип данных.

Вывести на экран все латинские буквы, коды которых чётные и кратны 5.

Laisrem13 8 дек. 2020 г., 23:51:41 | 10 - 11 классы

Pascal abc Написать программу, которая бы вводила с клавиатуры два символа и выводила на экран тот, код которого больше (использовать операцию сравнения символов)?

Pascal abc Написать программу, которая бы вводила с клавиатуры два символа и выводила на экран тот, код которого больше (использовать операцию сравнения символов).

Пустой 15 мар. 2020 г., 10:32:37 | 5 - 9 классы

Найти количество делителей натурального числа А, больших К?

Найти количество делителей натурального числа А, больших К.

(А и К вводятся с клавиатуры, K< ; = A).

Код должен быть написан на языке Паскаля (Pascal).

Seecats99 30 дек. 2020 г., 11:16:16 | 10 - 11 классы

Код на PASCAL ?

Код на PASCAL !

Ilina170712 8 янв. 2020 г., 01:04:19 | 5 - 9 классы

Дан радиус окружности?

Дан радиус окружности.

Найти её диаметр.

(код Pascal).

Eqorqeiko 11 мар. 2020 г., 07:55:46 | 10 - 11 классы

Код программы в PASCAL, СРОЧНО?

Код программы в PASCAL, СРОЧНО!

Условие : Вводятся 3 натуральных числа.

Найти сумму цифр каждого из них (создать функцию для нахождения суммы цифр произвольного натурального числа).

Эдуард1305 26 нояб. 2020 г., 18:31:22 | 10 - 11 классы

Здравствуйте?

Здравствуйте!

Помогите пожалуйста составить код для задачи ниже на Pascal ABC.

Желательно как можно скорее!

Настя3612 19 дек. 2020 г., 18:34:45 | 10 - 11 классы

Пожалуйста составте программу для Pascal по следующим заданиям : 1) Получить из слов "Язык", "программирования", "Pascal" фразу язык программирования Pascal" 2)Получить из слов "Интер" , "нет" слово "?

Пожалуйста составте программу для Pascal по следующим заданиям : 1) Получить из слов "Язык", "программирования", "Pascal" фразу язык программирования Pascal" 2)Получить из слов "Интер" , "нет" слово "Интернет 3) Дан Символ С вывести его код.

Lida53 10 дек. 2020 г., 21:24:32 | 10 - 11 классы

1. Написать оператор, который выведет через пробел коды букв, образующих слово PASCAL2?

1. Написать оператор, который выведет через пробел коды букв, образующих слово PASCAL

2.

Написать оператор, который выведет текст , образованный кодами символов 65, 71, 69.

Mamontovasveta 16 сент. 2020 г., 21:22:08 | 10 - 11 классы

Составить программу, определяющую для точки с координатами (X, Y), принадлежит ли она заштрихованной области?

Составить программу, определяющую для точки с координатами (X, Y), принадлежит ли она заштрихованной области.

Delphi / Pascal.

Что угодно.

Мне именно основную часть кода.

Использовать условный оператор.

Вы зашли на страницу вопроса Код на PASCAL ?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.