Задача в Паскале?

Информатика | 5 - 9 классы

Задача в Паскале!

Дано 4 - х значное двоичное число b, перевести в десятичное и вывести на экран.

Ответить на вопрос
Ответы (1)
EliMer 12 апр. 2020 г., 11:03:01

Program algorithm ;

uses crt ;

var s, sbox : string ;

i, step, dva, n, l, delo : integer ;

begin

Writeln('Введите двоичное число : ') ;

read(dva) ; s : = IntToStr(dva) ;

l : = length(s) ;

for i : = 1 to l do

begindva : = StrToInt(s[i]) ;

step : = l - i ;

if dva> ; 0

then

begin

for n : = 1 to step dodva : = dva * 2 ;

delo : = delo + dva ;

end ;

end ;

Writeln('Десятичное число : ', delo) ;

end.

KateykinaKatya 7 февр. 2020 г., 01:25:44 | 5 - 9 классы

Ввести 3 - х значное число , вывести сумму его цифр ( паскаль)?

Ввести 3 - х значное число , вывести сумму его цифр ( паскаль).

Vikusya16 18 мая 2020 г., 22:28:20 | 10 - 11 классы

3. Дано целое трехзначное число А?

3. Дано целое трехзначное число А.

Вывести цифры этого числа на экран в столбик.

Паскаль.

Ник2223 21 июн. 2020 г., 21:34:45 | 10 - 11 классы

Задача в паскале?

Задача в паскале.

Вывести на экран в порядке возрастания все цифры, не являющиеся цифрами данного десятичного натурального числа (переменной целого типа).

Например, число 125657 не содержит цифры : 0, 3, 4, 8, 9.

NemOsTOOr230 16 дек. 2020 г., 15:30:50 | 10 - 11 классы

Решите задачу в Паскале?

Решите задачу в Паскале.

Если можно с блок - схемой.

Дана последовательность чисел.

Вывести на экран все отрицательные числа.

Олеся44 6 июн. 2020 г., 08:43:41 | 5 - 9 классы

Перевести из двоичной в десятичную число 10010?

Перевести из двоичной в десятичную число 10010.

Juliaemets 29 мар. 2020 г., 15:14:49 | 5 - 9 классы

Дано 5 ти значное число вывести на экран монитора вторую и пятую цифры их разность?

Дано 5 ти значное число вывести на экран монитора вторую и пятую цифры их разность.

CR7doc 3 окт. 2020 г., 08:29:06 | 5 - 9 классы

Помоги написать задачу на Паскале?

Помоги написать задачу на Паскале.

Решить надо с помощью цикла FOR.

Вывести на экран все делители данного числа введенного с клавиатуры.

Kusena 17 апр. 2020 г., 05:15:06 | 10 - 11 классы

Паскаль?

Паскаль.

Вывести на экран квадрат средней цифры пятизначного числа.

Livadia 11 мая 2020 г., 14:22:56 | 10 - 11 классы

Перевести данные числа из двоичной системы счисления в десятичную и наоборот?

Перевести данные числа из двоичной системы счисления в десятичную и наоборот.

1001110011₂, 10110101₂.

DanyaLyamin 29 сент. 2020 г., 07:31:38 | 10 - 11 классы

Переведите натуральное число из двоичной системы в десятичную (в двоичном числе не более 10 цифр)?

Переведите натуральное число из двоичной системы в десятичную (в двоичном числе не более 10 цифр).

Нужна программа на паскале.

Входные данные : 1 Выходные данные : 1.

Вы открыли страницу вопроса Задача в Паскале?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.