РЕШИТЕ В ПАСКАЛЕ : Принадлежит ли точка с известными координатами окружности с известным радиусом?

Информатика | 10 - 11 классы

РЕШИТЕ В ПАСКАЛЕ : Принадлежит ли точка с известными координатами окружности с известным радиусом.

Попытайся воспользоваться формулой : квадрат радиуса равен сумме квадратов координат.

Ответить на вопрос
Ответы (1)
Насьтюшка 25 апр. 2020 г., 02:26:47

Const e = 1e - 5 ; / / точность

var x, y, r, d : real ;

begin readln(x) ; readln(y) ; readln(r) ; r : = r * r ; d : = sqrt(sqr(x) + sqr(y)) ; if abs(d - r) < ; e then writeln ('лежит на окружности') else if d < ; r then writeln ('попадает в круг') else writeln('вне круга') ;

end.

Ngonta 18 янв. 2020 г., 06:17:21 | 10 - 11 классы

Расставить на экране 30 окружностей со случайными координатами X и Y, случайного радиуса и цвета ("мыльные пузыри")?

Расставить на экране 30 окружностей со случайными координатами X и Y, случайного радиуса и цвета ("мыльные пузыри").

Паскаль, пожалйуста решите, кто знает.

Comp152 11 апр. 2020 г., 13:17:04 | 10 - 11 классы

Расписать в паскале : На плоскости расположена окружность R в центре с началом координат?

Расписать в паскале : На плоскости расположена окружность R в центре с началом координат.

Определить положение точки X с координатами (A, B) относительно окружности (лежит ли точка внутри окружности на окружности или вне ее) Если можно полностью.

VrZ4lateMbursika 10 мар. 2020 г., 18:47:42 | 5 - 9 классы

Даны координаты точки на плоскости?

Даны координаты точки на плоскости.

Известно, что окружность радиусом Р центром совпадает с началом координат.

Определить, лежит ли данная точка на окружности или же вне её.

Sonia182 30 окт. 2020 г., 09:49:03 | 10 - 11 классы

Какое логическое выражение соответствует высказыванию : "Точка (X, Y) принадлежит кругу радиуса R с центром в начале координат"?

Какое логическое выражение соответствует высказыванию : "Точка (X, Y) принадлежит кругу радиуса R с центром в начале координат"?

Yarixx 17 нояб. 2020 г., 09:26:13 | 5 - 9 классы

Решить в паскаль Ввести координаты m точек трехмерного пространства?

Решить в паскаль Ввести координаты m точек трехмерного пространства.

Определить сколько из них лежит внутри сферы радиуса R с центром в начале координат.

Настяглухова 29 окт. 2020 г., 15:06:04 | 5 - 9 классы

В Pascal ABC?

В Pascal ABC.

Найдите радиус окружности если известна площадь окружности.

Анна1040 29 нояб. 2020 г., 05:08:24 | 10 - 11 классы

Решить в паскале : Написать программу, определяющую, является ли фигура квадратом?

Решить в паскале : Написать программу, определяющую, является ли фигура квадратом.

Вершины квадрата задаются координатами точек.

222666555 7 сент. 2020 г., 17:42:33 | 5 - 9 классы

Задана точка M с координатами (x, y)?

Задана точка M с координатами (x, y).

Определить ее положение относительно окружности радиуса R с центром в начале осей координат.

Starsarms 23 окт. 2020 г., 19:05:02 | 5 - 9 классы

Введите с клавиатуры координаты точки на плоскости(целочисленные)?

Введите с клавиатуры координаты точки на плоскости(целочисленные).

Выведите на экран квадрат расстояния от начала координат до этой точки.

Nikitafilippov7 9 дек. 2020 г., 09:01:42 | 5 - 9 классы

Определить фигуру с наибольшей площадью : квадрат со стороной a, равносторонний треугольник со стороной b, окружность с радиусом R?

Определить фигуру с наибольшей площадью : квадрат со стороной a, равносторонний треугольник со стороной b, окружность с радиусом R.

Паскаль.

Если вам необходимо получить ответ на вопрос РЕШИТЕ В ПАСКАЛЕ : Принадлежит ли точка с известными координатами окружности с известным радиусом?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.