Сформировать одномерный массив состоящий из N элементов случайных чисел (random 10) и удалить элемент стоящий на M месте?

Информатика | студенческий

Сформировать одномерный массив состоящий из N элементов случайных чисел (random 10) и удалить элемент стоящий на M месте.

Ответить на вопрос
Ответы (1)
Арман1о 5 апр. 2024 г., 13:21:58

Программа :

Pascal :

var   ; arr : array of integer ;   ; M, N, i : integer ;

begin   ; write('N = ') ;   ; readln(N) ;   ; SetLength(arr, N) ;   ; for i : = 1 to N - 1 do arr[i] : = random(10) ;   ; writeln(arr) ;   ; write('M = ') ;   ; readln(M) ;   ;   ; for i : = M - 1 to N - 2 do   ;   ; arr[i] : = arr[i + 1] ;   ; SetLength(arr, N - 1) ;   ;   ; writeln(arr) ;

end.

Азамат11111 11 янв. 2024 г., 16:24:13 | студенческий

Сгенерируйте список из 10 случайных чисел от 10 до 20 и выведите его в строчку?

Сгенерируйте список из 10 случайных чисел от 10 до 20 и выведите его в строчку.

Напишите программу, которая переставит местами первый и последний элемент в списке (изменит текущий список!

) и выведет его в строчку.

​.

Светкаsveta 27 янв. 2024 г., 11:12:57 | 10 - 11 классы

Язык Си заполнить массив из 10 элементов случайными числами в интервале [ - 10 ; 10] и выполнить инверсию отдельно для 1 - й и 2 - й половин массива?

Язык Си заполнить массив из 10 элементов случайными числами в интервале [ - 10 ; 10] и выполнить инверсию отдельно для 1 - й и 2 - й половин массива.

Dashulyagolubets 3 янв. 2024 г., 02:31:50 | 5 - 9 классы

В одномерном массиве все отрицательные элементы переместить в начало массива, а остальные – в конец с сохранением порядка следования?

В одномерном массиве все отрицательные элементы переместить в начало массива, а остальные – в конец с сохранением порядка следования.

Дополнительный массив заводить не разрешается.

​.

Саша1322 25 мар. 2024 г., 22:31:52 | 10 - 11 классы

Составить программу на Паскале, которая в двумерном массиве определяет максимальный элемент в каждой строке и записывает его в одномерный массив?

Составить программу на Паскале, которая в двумерном массиве определяет максимальный элемент в каждой строке и записывает его в одномерный массив.

Для определения максимального элемента в строке использовать function , а для ввода и вывода массивов - procedure.

Dagirovauma 8 апр. 2024 г., 20:43:38 | 5 - 9 классы

Дан массив, состоящий из целых чисел?

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитывает количество положительных чисел среди элементов массива.

Входные данные

Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел

ЯЗЫК - PASCAL

35 баллов.

Анжелика268 18 февр. 2024 г., 07:10:49 | 5 - 9 классы

Дан одномерный массив B из 20 целых чисел(числа вводятся по формуле (i + 2 * (i - 1)), вывестина экран массив в строку через пробел, найти ивывести максимальный элемент массива?

Дан одномерный массив B из 20 целых чисел

(числа вводятся по формуле (i + 2 * (i - 1)), вывести

на экран массив в строку через пробел, найти и

вывести максимальный элемент массива.

Baulinakristina706 8 апр. 2024 г., 05:30:23 | 10 - 11 классы

Массив размерности N задается случайным образом ?

Массив размерности N задается случайным образом .

Вычислите элементы массива которые стоят на четнвх местах , например A[2] = .

A[4] = .

Annatitova12345 3 апр. 2024 г., 09:43:12 | 5 - 9 классы

Дан массив из N элементов?

Дан массив из N элементов.

Найти и вывести элементы этого массива, принадлежащие диапазону от А до В (А и В ввести с клавиатуры).

Язык программирования pascal.

F39821 16 янв. 2024 г., 00:26:34 | 5 - 9 классы

ДАН ЦЕЛОЧИСЛЕННЫЙ МАССИВ ИЗ 30 ЭЛЕМЕНТОВ ?

ДАН ЦЕЛОЧИСЛЕННЫЙ МАССИВ ИЗ 30 ЭЛЕМЕНТОВ .

ЭЛЕМЕНТЫ МАССИВА МОГУТ ПРИНИМАТЬ ЗНАЧЕНИЯ ОТ - 1000 ДО 1000.

ОПИШИТЕ НА РУССКОМ ИЛИ НА 1 ИЗ ЯЗЫКОВ ПРОГРАММИРОВАНИЯ АЛГОРИТМ , КОТ ПОЗВОЛЯЕТ ПОДСЧИТАТЬ И ВЫВЕСТИ СРЕДНЕЕ АРИФМЕТИЧЕСКОЕ ТЕХ ЭЛЕМЕНТОВ МАССИВА , КОТ ПО СВОЕМУ ЗНАЧЕНИЮ МЕНЬШЕ ПОСЛЕДН ЭЛЕМЕНТА ЭТОГО МАССИВА .

ГАРАНТИРУЕТСЯ , ЧТО В ИСХОДНОМ МАССИВЕ ЕСТЬ ХОТЯ БЫ 1 ТАКОЙ ЭЛЕМЕНТ .

Markowacaterin 25 янв. 2024 г., 07:35:05 | 5 - 9 классы

Задача 2?

Задача 2.

2. 1.

Data = (1, 2, 3, 4, 5, 6, 7, 8, 9] задан одномерный массив.

Напишите код программы, извлекающий элемент, стоящий на 3 - м месте в массиве.

Ответ : ​.

Если вам необходимо получить ответ на вопрос Сформировать одномерный массив состоящий из N элементов случайных чисел (random 10) и удалить элемент стоящий на M месте?, относящийся к уровню подготовки учащихся студенческий, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.