Дана последовательность натуральных чисел 1, 2, 3, ?

Информатика | 5 - 9 классы

Дана последовательность натуральных чисел 1, 2, 3, .

, N(1< ; = N< ; = 1000).

Необходимо сначала расположить в обратном порядке часть этой последовательности от элемента с номером А до элемента с номером В, а затем о С до D (А< ; В ; С< ; D ; 1< ; = A, B, C, D< ; = N).

Входные данные

вводятся натуральные числа N, A, B, C, D.

Выходные данные

требуется вывести полученную последовательность

Примеры

9 2 5 6 9

выходные данные

1 5 4 3 2 9 8 7 6

Помогите пожалуйста, очень срочно!

​.

Ответить на вопрос
Ответы (1)
Sorih 7 нояб. 2023 г., 21:11:07

Ответ :

var i, n, a, b, c, d : integer ;

begin

read (n, a, b, c, d) ;

for i : = 1 to a - 1 do write (i, ' ') ;

for i : = b downto a do write (i, ' ') ;

for i : = b + 1 to c - 1 do write (i, ' ') ;

for i : = d downto c do write (i, ' ') ;

if d < ; > ; n then for i : = d + 1 to n do write (i, ' ') ;

end.

Объяснение :

var i, n, a, b, c, d : integer ;

begin

write ('n = ') ;

readln (n) ;

write ('a = ') ;

readln (a) ;

write ('b = ') ;

readln (b) ;

write ('c = ') ;

readln (c) ;

write ('d = ') ;

readln (d) ;

for i : = 1 to a - 1 do write (i, ' ') ;

for i : = b downto a do write (i, ' ') ;

for i : = b + 1 to c - 1 do write (i, ' ') ;

for i : = d downto c do write (i, ' ') ;

if d < ; > ; n then for i : = d + 1 to n do write (i, ' ') ;

end.

KateSilaeva12 25 дек. 2023 г., 00:09:17 | 10 - 11 классы

Поле шахматной доски определяется парой натуральных чисел, каждое из которых не превосходит 8 : первое число - номер вертикали (при счете слева направо), второе - номер горизонтали (при счете снизу вв?

Поле шахматной доски определяется парой натуральных чисел, каждое из которых не превосходит 8 : первое число - номер вертикали (при счете слева направо), второе - номер горизонтали (при счете снизу вверх).

На поле (a, b) расположен король.

Верно ли, что он может одним ходом попасть на поле (c, d)?

Чтобы попасть на собственное поле, королю нужно два хода.

Значения c и d могут находится вне границ шахматной доски.

В этом случае Король в принципе не может попасть на заданное поле.

Формат входных данных

Даны натуральные числа a, b каждое из которых не превосходит 8.

А также числа c, d каждое из которых лежит в интервале [0, 10]

Формат выходных данных

На выходе программы должно быть написано булево значение, определяющее выполняется ли заданное условие задача на паскаль.

Bogdanlazareff 6 окт. 2023 г., 10:08:32 | 5 - 9 классы

Определите тип выходных данных, если необходимо посчитать количество вхождений буквы "с" и позицию первого вхождения буквы "у" в строке " Я учусь в 7 - ом классе"?

Определите тип выходных данных, если необходимо посчитать количество вхождений буквы "с" и позицию первого вхождения буквы "у" в строке " Я учусь в 7 - ом классе".

Melenchuk2016 3 нояб. 2023 г., 06:41:42 | 10 - 11 классы

Дан вещественный массив, состоящий из 7 элементов?

Дан вещественный массив, состоящий из 7 элементов.

Найти произведение этих элементов (одномерные массивы, 10 класс).

Swan426y 20 нояб. 2023 г., 17:05:40 | 10 - 11 классы

Напишите программу?

Напишите программу.

Дано натуральное число.

Найти сумму его цифр, кратных 7.

DianeS 10 окт. 2023 г., 13:46:25 | студенческий

Задание по C + +Алгоритм Евклида?

Задание по C + +

Алгоритм Евклида.

Даны целые числа A и B.

Найти наибольший общий делитель этих чисел.

Исходные данные : A, B - целый тип

Результат : NOD наиб.

Общий делитель

Тестовый пример : при А = 36, В = 48, НОД = 12.

Akimzhan12131 12 дек. 2023 г., 07:20:32 | 5 - 9 классы

Написать программу, которая выводит на экран таблицу умножения на n (n - натуральное число от 2 до 9?

Написать программу, которая выводит на экран таблицу умножения на n (n - натуральное число от 2 до 9.

Пример входных данных Пример выходных данных

Введите n = 3 3 * 2 = 6 3 * 3 = 9 3 * 4 = 12 3 * 5 = 15 3 * 6 = 18 3 * 7 = 21 3 * 8 = 24 3 * 9 = 27

Помогите!

Умка2013 21 нояб. 2023 г., 06:49:24 | 5 - 9 классы

Решить задачу в C + +Помогите пожалуйста?

Решить задачу в C + +

Помогите пожалуйста!

Дан одномерный массив x1, x2, .

, xn.

Вычислить среднее арифметическое положительных элементов массива.

VoldemaR4ik 6 дек. 2023 г., 15:00:35 | студенческий

Найти сумму номеров отрицательных элементов массива h = (h1, h2?

Найти сумму номеров отрицательных элементов массива h = (h1, h2.

Hn) .

Ввод с клавиатуры, язык Java.

Камол008 16 дек. 2023 г., 21:33:36 | 5 - 9 классы

Ребята, помогите с задачей?

Ребята, помогите с задачей!

Надо ввести ее в pascal

Дан ряд чисел.

Количество задается пользователем.

Найти кол - во четных чисел оканчивающих на 0 или 2

9 класс.

Pereliginalena 31 дек. 2023 г., 01:41:18 | 10 - 11 классы

Даны числа : 2 ; 15 ; 353 ; 3570 ; 10351?

Даны числа : 2 ; 15 ; 353 ; 3570 ; 10351.

Используя MS Excel, вычисли среднее арифметическое данных чисел.

Вопрос Дана последовательность натуральных чисел 1, 2, 3, ?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.