ПАСКАЛЬДаны три числа?

Информатика | 5 - 9 классы

ПАСКАЛЬ

Даны три числа.

Найти среди них максимальное, среднее, минимальное.

Ответить на вопрос
Ответы (1)
89273846990 27 дек. 2021 г., 23:07:15

Const n = 3 ; {можно любое число}

var a : array [1.

N] of Integer ; x, q, i : Integer ; b, c, z : Real ;

begin

for i : = 1 to n do

begin

Write('a[', i, '] = ') ;

ReadLn(a[i]) ;

end ;

x : = a[1] ;

for i : = 2 to n do

if xa[i]

then q : = a[i] ;

z : = q ;

Writeln(z : 3 : 2, ' - Naimenshoe') ;

b : = (x + q) / 2 ;

WriteLn(b : 3 : 2, ' - seredne arifmitichne') ;

readln ;

end.

VladNikiforov560 4 мая 2021 г., 18:38:53 | 10 - 11 классы

Сколько элементов массива превышают среднее арифметическое значение максимального и минимального элементов?

Сколько элементов массива превышают среднее арифметическое значение максимального и минимального элементов?

) на паскале.

Troyanov2015 24 мая 2021 г., 23:55:49 | 5 - 9 классы

Найти максимальное и минимальное из двух чисел (проверить, равны ли числа)?

Найти максимальное и минимальное из двух чисел (проверить, равны ли числа).

Rastorguev2001 16 янв. 2021 г., 17:24:52 | 5 - 9 классы

Напишите программу которая вычисляет минимальное и максимальное число среди чисел вводимых с клавиатуры?

Напишите программу которая вычисляет минимальное и максимальное число среди чисел вводимых с клавиатуры.

Инусся 6 мар. 2021 г., 23:59:02 | 10 - 11 классы

Найти номер максимального и минимального из введённых с клавиатуры 10 элементов Паскаль (массивы)?

Найти номер максимального и минимального из введённых с клавиатуры 10 элементов Паскаль (массивы).

Theberezina1 16 июл. 2021 г., 12:52:15 | 10 - 11 классы

На Языке Паскаль?

На Языке Паскаль!

Даны 2 числа минимальных вывести минимальное из них.

Marismarina23 26 июн. 2021 г., 17:38:11 | 10 - 11 классы

Паскаль?

Паскаль.

Дан массив из 18 чисел.

Найти минимальный элемент массива.

Ekhusainova567 14 дек. 2021 г., 19:22:24 | 5 - 9 классы

Найти минимальный элемент среди отрицательных чисел и максимальный элемент среди неотрицательных?

Найти минимальный элемент среди отрицательных чисел и максимальный элемент среди неотрицательных.

Valoo 22 февр. 2021 г., 03:58:47 | 5 - 9 классы

Дан массив из 5 целых чисел, найти номер максимального элемента?

Дан массив из 5 целых чисел, найти номер максимального элемента.

(Паскаль).

Spasenkova1981 27 окт. 2021 г., 05:04:14 | 5 - 9 классы

СРОЧНО?

СРОЧНО!

На паскале надо сделать задачу : даны два ненулевых числа.

Найти их среднее арифметическое.

Формат вывода результата «Среднее арифметическое числа ___ и числа ___ равно ___».

Vlask3 7 июл. 2021 г., 15:57:37 | 5 - 9 классы

ПАСКАЛЬДаны три числа?

ПАСКАЛЬ

Даны три числа.

Найти среди них максимальное, среднее, минимальное.

Вы перешли к вопросу ПАСКАЛЬДаны три числа?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.