Пишется в паскале : встречено "END", а ожидался оператор?

Информатика | 5 - 9 классы

Пишется в паскале : встречено "END", а ожидался оператор.

Всё ли я правильно сделала, нет ошибок?

Program abc ;

Uses Robot ;

Begin ;

Field(10, 10) ;

Down ; Paint ; Down ; Paint ; Down ; Paint ; Down ; Paint ; Up ; Up ; Up ; Right ; Paint ;

Up ; Right ; Paint ; Up ; Right ; Paint ; Down ; Down ; Down ; Down ; Paint ; Up ; Left ;

Paint ; Up ; Left ; Paint.

END.

Ответить на вопрос
Ответы (1)
Katrin3986 30 апр. 2022 г., 13:32:36

У тебя после BEGIN стоит ' ; ' и перед END стоит ".

",

Program abc ;

Uses Robot ;

Begin

Field(10, 10) ;

Down ; Paint ; Down ; Paint ; Down ; Paint ; Down ; Paint ; Up ; Up ; Up ; Right ; Paint ; Up ; Right ; Paint ; Up ; Right ; Paint ; Down ; Down ; Down ; Down ; Paint ; Up ; Left ; Paint ; Up ; Left ; Paint ;

END.

Ника1576 24 янв. 2022 г., 12:26:04 | 10 - 11 классы

Два фрагмента программы записанный на языке ПаскальBeginK : = 5 ; N : = 0 ;For i : = 1 to K do ;BeginN : = i + K + N ;N : = n - 5 ;End ;K : = N ;End?

Два фрагмента программы записанный на языке Паскаль

Begin

K : = 5 ; N : = 0 ;

For i : = 1 to K do ;

Begin

N : = i + K + N ;

N : = n - 5 ;

End ;

K : = N ;

End.

Чему равно значение переменной K после выполнения?

Татьяна110 5 февр. 2022 г., 03:48:09 | 5 - 9 классы

Помогите найти ошибку (Информатика, Паскаль)?

Помогите найти ошибку (Информатика, Паскаль).

Var s, k, a : integer ;

Begin

s : = 0 ;

k : = 0 ;

Read(a) ;

while a0 do

Begin

if a mod 8 = 0 then

Begin

s : = s + a ;

k : = k + 1 ;

end ;

Readln(a) ;

end ;

var y : real ;

begin

y : = s / k ;

Read(s) ;

if s>0 then

Writeln(y)

else

Writeln('NO')

end ;

end.

Сурок228 2 февр. 2022 г., 14:17:32 | студенческий

Определите число : которое будет напечатано в результате выполнения программы (с помощью языка программирования Паскаль)var n, s : integerbeginn : = 0 ;s : = 402 ;while s>0 dobegins : = s - 10 ;n : = ?

Определите число : которое будет напечатано в результате выполнения программы (с помощью языка программирования Паскаль)

var n, s : integer

begin

n : = 0 ;

s : = 402 ;

while s>0 do

begin

s : = s - 10 ;

n : = n + 3

end ;

write(n)

end.

Hxhe25 16 янв. 2022 г., 16:09:11 | 1 - 4 классы

Название клавиш Esc, Enter, Shift, Caps Loock, Control, Alt, Backspace, Delete, Insert, Home, End, Page Up, Page Down, Num Look?

Название клавиш Esc, Enter, Shift, Caps Loock, Control, Alt, Backspace, Delete, Insert, Home, End, Page Up, Page Down, Num Look.

Laa09 5 февр. 2022 г., 18:16:53 | 5 - 9 классы

Паскаль?

Паскаль.

Ошибка "Встречено '1', а ожидался идентификатор".

Что исправить?

Мулкина 10 янв. 2022 г., 15:58:17 | 1 - 4 классы

Какие операторы не правильные?

Какие операторы не правильные?

(В паскале) Преобразуйте в правильную программу.

Program qq ; var a, b : integer ; x, y : real ; begin a : = 5 ; 10 : = x ; y : = 7, 8 ; b : = 2.

5 ; x : = 2 * (a + y) ; a : = b + x ; end.

Doooooos2016 24 мар. 2022 г., 08:38:40 | 10 - 11 классы

СрочноProgram sredarifment ;Var a : array[1?

Срочно

Program sredarifment ;

Var a : array[1.

10] of real ;

i, k : integer ;

C, S, sred : real ;

Begin

For i : = 1 to 10 do begin write ('a[', i, '] = ') ; readln (a[i]) ; end ;

write('введите C : ') ; readln (C) ;

For i : = 1 to 10 do begin If a[i]>C then begin S = S + a[i] ; K = K + 1 ; end ; end ;

sred = S / k ;

Writeln('среднее арифметическое чисел, превосходящих ', C, ' равно ', sred) ;

End.

Помогите чтобы программа запускалась.

Выходит что не верно.

Рниangel2004851 19 янв. 2022 г., 06:46:37 | 5 - 9 классы

Для чего предназначен графический редактор Paint?

Для чего предназначен графический редактор Paint?

Verakarpova85 8 июн. 2022 г., 15:42:19 | 5 - 9 классы

К прикладным программам относятся :A) MS Word, MS Paint, Windows 7, ALPLogo 1?

К прикладным программам относятся :

A) MS Word, MS Paint, Windows 7, ALPLogo 1.

5

B) Windows XP, Calcuator, MS Paint, NotePad

C) MS Paint, Calculator, MS Word, İnternet Explorer

D) My Computer, MS Paint, NotePad, WordPad.

Просто5Аня 16 мая 2022 г., 02:05:42 | 5 - 9 классы

Что обозначает файл в paint?

Что обозначает файл в paint?

Дам за ответ 20 баллов!

На этой странице сайта размещен вопрос Пишется в паскале : встречено "END", а ожидался оператор? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.