Дан массив вещественных чисел x(x1?

Информатика | 10 - 11 классы

Дан массив вещественных чисел x(x1?

X2, .

, xn).

Найти произведение положительных элементов массива и подсчитать их число.

Ответить на вопрос
Ответы (1)
Umaevppp 5 дек. 2020 г., 19:08:34

Const n = 5 ;

var x : array[1.

N]of real ; i, k : integer ; p : real ;

begin

p : = 1 ;

for i : = 1 to n do begin readln(x[i]) ; if x[i]> ; 0 then begin p : = p * x[i] ; k : = k + 1 ; end ; end ;

writeln('p = ', p) ;

writeln('k = ', k) ;

end.

АлиасхабоваПатимат 19 дек. 2020 г., 07:33:38 | 5 - 9 классы

Дан массив состоящий их 7 вещественных чисел?

Дан массив состоящий их 7 вещественных чисел.

Из всех положительных элементов массива вычесть элемент с номером k, из всех отрицательных n ( числа k и n вводятся с клавиатуры).

Нулевые элементы оставить без изменения.

Rogovajulia201 3 янв. 2020 г., 04:15:07 | 10 - 11 классы

Ввести массив F(n) вещественных чисел?

Ввести массив F(n) вещественных чисел.

Если последний элемент массива положительный, то найти max среди элементов массива и заменить его значений последний элемент массива.

Массив распечатать.

Иначе – дать сообщение «Массив остался без изменений».

Ganster009 17 сент. 2020 г., 23:29:05 | 10 - 11 классы

1. Найти произведение положительных элементов массива X(9)?

1. Найти произведение положительных элементов массива X(9).

2. Заменить элементы, значения которых равны числу 4, числом - 4.

Данные задать самостоятельно в массиве С(5).

Настя2005 3 янв. 2020 г., 06:37:14 | 5 - 9 классы

Дан одномерный массив, состоящий из вещественных элементов?

Дан одномерный массив, состоящий из вещественных элементов.

Найти сумму элементов массива, расположенных до последнего положительного элемента.

Аааааа53 6 дек. 2020 г., 11:35:41 | 10 - 11 классы

1. Заполнить одномерный массив B вещественными числами из промежутка от - 20 до 5?

1. Заполнить одномерный массив B вещественными числами из промежутка от - 20 до 5.

Найти сумму и среднее положительных и четных элементов массива.

Найти произведение отрицательных элементов массива.

Найти минимальный элемент массива.

Отсортировать массив по убыванию.

2. Заполнить одномерный массив А целыми числами из промежутка от - 12 до 7.

Вывести элементы массива, значения которых больше заданного числа Н и кратны числу К.

Найти максимальный элемент массива.

Отсортировать массив по возрастанию.

На паскале.

Izgaraeva 22 нояб. 2020 г., 06:16:43 | 10 - 11 классы

Дан массив, состоящий из целых чисел?

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитывает количество положительных чисел среди элементов массива.

Входные данные Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные Необходимо единственное число - количество положительных элементов в массиве.

Java.

Lolla11 25 нояб. 2020 г., 05:52:52 | 5 - 9 классы

Дан массив вещественных чисел из 11 элементов?

Дан массив вещественных чисел из 11 элементов.

Найти произведение элементов, которые меньше 9.

Romchik13 3 сент. 2020 г., 17:31:37 | 10 - 11 классы

Дан одномерный массив вещественных чисел найти средняя арифметическая положительных элементов?

Дан одномерный массив вещественных чисел найти средняя арифметическая положительных элементов.

Dzhidabaev 27 сент. 2020 г., 14:02:27 | 5 - 9 классы

Дан массив, состоящий из 7 вещественных чисел?

Дан массив, состоящий из 7 вещественных чисел.

Из всех положительных элементов массива вычесть элемент с номером k, из всех отрицательных - число n ( числа k и n вводятся с клавиатуры ).

Нулевые элементы оставить без изменения.

Нася20001 31 дек. 2020 г., 18:18:27 | 5 - 9 классы

Ввести массив из 7 элементов?

Ввести массив из 7 элементов.

Подсчитать произведение положительных элементов массива.

На этой странице сайта вы найдете ответы на вопрос Дан массив вещественных чисел x(x1?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.