Var n, a, b, c, d, f : integer ;beginwrite('Введите трёхзначное число n = ', n) ;a : = n del 100 ;b : = n mod 10 ;c : = n del 10 ;a + b + c = s ;if(s> = 10)(s?

Информатика | 10 - 11 классы

Var n, a, b, c, d, f : integer ;

begin

write('Введите трёхзначное число n = ', n) ;

a : = n del 100 ;

b : = n mod 10 ;

c : = n del 10 ;

a + b + c = s ;

if(s> = 10)(s.

Ответить на вопрос
Ответы (1)
Shiryaeva22 12 мая 2022 г., 12:16:17

Много у тебя косяков, иду по порядку :

1)del ?

Что это?

Может ты должен использовать div?

= )

2)a + b + c = s ; сразу несколько косяков, во 1 - х так не пишут, а пишут s : = a + b + c ; , во 2 - х у тебя переменная s не определена в Var

3)if(s> = 10)(s = 10) and (s.

Екатерина29051999 2 янв. 2022 г., 14:32:50 | 10 - 11 классы

Определите, какое число будет напечатано на экране в результате выполнения следующей программы :var a, b : integer ;begin a : = 0 ; b : = 2 ; while b < 32 do begin a : = a + 1 ; b : = b * 2 ; end ; wr?

Определите, какое число будет напечатано на экране в результате выполнения следующей программы :

var a, b : integer ;

begin a : = 0 ; b : = 2 ; while b < 32 do begin a : = a + 1 ; b : = b * 2 ; end ; writeln(a) ;

end.

Bdot 4 февр. 2022 г., 06:35:56 | 10 - 11 классы

65) (Д?

65) (Д.

Ф. Муфаззалов, Уфа) Какое число будет напечатано в результате выполнения программы :

var i, k : integer ;

function f(x : integer) : integer ;

var m : integer ;

begin

if x < 10 then f : = x

else begin

m : = f(x div 10) ;

if m < x mod 10 then

f : = x mod 10

else f : = m ;

end ;

end ;

begin

k : = 0 ;

for i : = 1000 to 9999 do

if f(i mod 100) = 1 then

if f(i div 100) = f(i mod 100) then

k : = k + 1 ;

writeln(k) ;

end.

Объясните, пожалуйста.

Элькаспросит 31 янв. 2022 г., 03:16:43 | 5 - 9 классы

Определите что будет напечатано в результате выполнения алкоритма, записанного на паскалеVar a, b : integer ;begina : = 1333 ;b : = (a div 100) * 13 + 5 :a : = (10 * b - a) mod 100 ;writeln (`a = `, a?

Определите что будет напечатано в результате выполнения алкоритма, записанного на паскале

Var a, b : integer ;

begin

a : = 1333 ;

b : = (a div 100) * 13 + 5 :

a : = (10 * b - a) mod 100 ;

writeln (`a = `, a) ;

writeln (`b = `, b) ;

end.

Serge12 12 янв. 2022 г., 22:07:37 | 5 - 9 классы

СРОЧНООО , ПОМОГИИИТЕ((((Ниже записана программа?

СРОЧНООО , ПОМОГИИИТЕ((((

Ниже записана программа.

Получив на вход число , эта программа печатает два числа, L и M .

Укажите наибольшее из таких чисел , при вводе которых алгоритм печатает сначала 3, а потом 0.

Var x, L, M : integer ; begin readln(x) ; L : = 0 ; M : = 0 ; while x > 0 do begin L : = L + 1 ; if x mod 2 = 0 then M : = M + x mod 10 ; x : = x div 10 ; end ; writeln(L) ; write(M) ; end.

Татьяна110 5 февр. 2022 г., 03:48:09 | 5 - 9 классы

Помогите найти ошибку (Информатика, Паскаль)?

Помогите найти ошибку (Информатика, Паскаль).

Var s, k, a : integer ;

Begin

s : = 0 ;

k : = 0 ;

Read(a) ;

while a0 do

Begin

if a mod 8 = 0 then

Begin

s : = s + a ;

k : = k + 1 ;

end ;

Readln(a) ;

end ;

var y : real ;

begin

y : = s / k ;

Read(s) ;

if s>0 then

Writeln(y)

else

Writeln('NO')

end ;

end.

Agent2013 10 мар. 2022 г., 07:17:40 | студенческий

Дайте ответ пожалуйста?

Дайте ответ пожалуйста!

Ниже записана программа.

Получив на вход число , эта программа печатает два числа, и .

Укажите наименьшее из таких чисел , при вводе которых алгоритм печатает сначала 3, а потом10.

Var x, a, b : integer ;

begin readln(x) ; a : = 0 ; b : = 1 ; while x > 0 do begin a : = a + 1 ; b : = b * (x mod 8) ; x : = x div 8 ; end ; writeln(a) ; write(b) ;

end.

Lenamar 13 февр. 2022 г., 01:32:23 | 10 - 11 классы

Какими клавишами можно скопировать текст в буфер обмена?

Какими клавишами можно скопировать текст в буфер обмена?

А) Ctrl + Ins

Б) Shift + Del

В) Alt + Ctrl

Г) Shift + Ins.

Froggy2005 25 февр. 2022 г., 23:54:15 | 5 - 9 классы

Какое число необходимо подать на вход программе, чтобы было выведено число 6387?

Какое число необходимо подать на вход программе, чтобы было выведено число 6387?

Var n : integer ;

begin

readln(n) ;

writeln(n div 100 mod 10 * 1000 + n div 10 mod 10 * 100 + n mod 10 * 10 + n div 1000) ;

end.

Idibek1 17 мар. 2022 г., 17:00:02 | 5 - 9 классы

Program Dvch ;var N : integer ;beginwriteln('Введите число N') ;readln(N) ;If (N>9) and (N?

Program Dvch ;

var N : integer ;

begin

writeln('Введите число N') ;

readln(N) ;

If (N>9) and (N.

Gork345 3 мая 2022 г., 18:04:33 | 5 - 9 классы

Помогите с Паскалемconst N = 40 ;vara : array[1?

Помогите с Паскалем

const N = 40 ;

var

a : array[1.

N] of integer ;

i, j, s : integer ;

st : real ;

begin

for i : = 1 to N do readln(a[i]) ;

Вы перешли к вопросу Var n, a, b, c, d, f : integer ;beginwrite('Введите трёхзначное число n = ', n) ;a : = n del 100 ;b : = n mod 10 ;c : = n del 10 ;a + b + c = s ;if(s> = 10)(s?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.