Найти количество положительных чисел среди введенных с клавиатуры четырёх чисел в паскале?

Информатика | 5 - 9 классы

Найти количество положительных чисел среди введенных с клавиатуры четырёх чисел в паскале!

Ответить на вопрос
Ответы (1)
Lykhinpavel59 29 мар. 2020 г., 20:24:05

Var a, b, c, d : integer ;

begin writeln('Введите 4 числа через пробел') ; readln(a, b, c, d) ; if (a> ; 0)and(b> ; 0)and(c> ; 0)and(d> ; 0) then writeln('Все числа положительные')

elseif((a< ; 0)and(b> ; 0)and(c> ; 0)and(d> ; 0))or((a> ; 0)and(b< ; 0)and(c> ; 0)and(d> ; 0))or((a> ; 0)and(b> ; 0)(c< ; 0))or((a> ; 0)and(b> ; 0)and(c> ; 0)and(d< ; 0)) then writeln('3 числа положительные') else if ((a< ; 0)and(b< ; 0)and(c> ; 0)and(d> ; 0))or((a< ; 0)and(b> ; 0)and(c< ; 0)and(d> ; 0))or((a< ; 0)and(b> ; 0)and(c> ; 0)and(d> ; 0))or((a< ; 0)and(b> ; 0)and(c> ; 0)and(d< ; 0))or((a> ; 0)and(b< ; 0)and(c< ; 0)and(d> ; 0))or((a> ; 0)and(b< ; 0)and(c> ; 0)and(d< ; 0))or((a> ; 0)and(b> ; 0)and(c< ; 0)and(d< ; 0)) then writeln('2 числа положительных') ; else if ((a> ; 0)and(b< ; 0)and(c< ; 0)and(d< ; 0))or((a< ; 0)and(b> ; 0)and(c< ; 0)and(d< ; 0))or((a< ; 0)and(b< ; 0)and(c> ; 0)and(d< ; 0))or((a< ; 0)and(b< ; 0)and(c< ; 0)and(d> ; 0)) then writeln('1 положительное число') else if(a< ; 0)and(b< ; 0)and(c< ; 0)and(d< ; 0) then writeln('Нет положительных чисел') ; readln

end.

Aleksandr20103 4 мар. 2020 г., 15:22:42 | 5 - 9 классы

С клавиатуры последовательно вводится 10 чисел?

С клавиатуры последовательно вводится 10 чисел.

Найти количество положительных чисел.

Срочноо!

Решите пожалуйста на Паскале.

Schkol 20 авг. 2020 г., 11:06:41 | 10 - 11 классы

Найти сумму положительных чисел из 10, введённых с клавиатуры?

Найти сумму положительных чисел из 10, введённых с клавиатуры.

Программа Паскаль.

Pee006 15 июн. 2020 г., 00:10:56 | 5 - 9 классы

Среди n введенных с клавиатуры чисел, найти сумму положительных и произведение отрицательных чисел?

Среди n введенных с клавиатуры чисел, найти сумму положительных и произведение отрицательных чисел.

Танген 22 июл. 2020 г., 08:38:44 | 10 - 11 классы

С клавиатуры вводятся числа (положительные и отрицательные) и последовательно суммируются их модули?

С клавиатуры вводятся числа (положительные и отрицательные) и последовательно суммируются их модули.

Найти количество введенных чисел, когда их сумма превысила 100.

На языке Паскаль пожалуйста пожалуйста, срочно!

Валерия123123 20 июл. 2020 г., 11:14:21 | 10 - 11 классы

С клавиатуры вводятся 3 числа?

С клавиатуры вводятся 3 числа.

Найти количество и сумму четных чисел среди них.

Если среди введенных четных нет, то вывести соответствующее сообщение.

Mahamusatova 29 дек. 2020 г., 20:31:57 | 10 - 11 классы

Пожалуйста, помогите?

Пожалуйста, помогите!

Срочно!

В ПАСКАЛЕ : 1) найти количество положительных целых чисел от 45 до 215 ; 2) Найти сумму положительных целых чисел от - 50 до 200, кратных 5 и 8 ; 3) Найти сумму и количество отрицательных четных целых чисел, введенных с клавиатуры.

Печать результата по вводу числа 0.

Валерон07 20 окт. 2020 г., 11:41:35 | 5 - 9 классы

Найти сумму n однозначных чисел введенных с клавиатуры паскаль?

Найти сумму n однозначных чисел введенных с клавиатуры паскаль.

Irinakovtun 9 мар. 2020 г., 09:01:16 | 5 - 9 классы

Найти количество отрицательных чисел среди 10 введенных из клавиатуры?

Найти количество отрицательных чисел среди 10 введенных из клавиатуры.

Информатика, написать программу в паскале.

Секрет86 13 сент. 2020 г., 18:49:23 | 5 - 9 классы

Ввести с клавиатуры n - любых чисел , найти количество отрицательных чисел( Паскаль )?

Ввести с клавиатуры n - любых чисел , найти количество отрицательных чисел( Паскаль ).

Anna200478 15 дек. 2020 г., 14:02:53 | 5 - 9 классы

Паскаль?

Паскаль.

Подсчитайте количество отрицательных и положительных чисел среди чисел a, b, c.

Вопрос Найти количество положительных чисел среди введенных с клавиатуры четырёх чисел в паскале?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.