1. Составить программу, которая увеличивает каждый элемент настоящей таблице х [1 ?

Информатика | 10 - 11 классы

1. Составить программу, которая увеличивает каждый элемент настоящей таблице х [1 .

10] на 1.

2. составить программу, замены положительных элементов настоящей таблице х [1 .

10] на 0.

3. составить программу, замены отрицательного элементов настоящей таблице х [1 .

10] на их квадрат.

4. составить прогрумму, которая увеличивает на 2 все элементы настоящей таблице х [1 .

10], которые больше 10.

Ответить на вопрос
Ответы (1)
Dasha2on 29 июн. 2020 г., 20:50:31

/ / первая программа

var x : array[1.

10] of integer ; i : integer ;

begin for i : = 1 to 10 do begin write('x[', i, '] = ') ; readln(x[i]) ; inc(x[i]) ; end ; writeln ; writeln('Result') ; for i : = 1 to 10 do write(x[i], ' ') ; readln ;

end.

/ / вторая программа

var x : array[1.

10] of integer ; i : integer ;

begin for i : = 1 to 10 do begin write('x[', i, '] = ') ; readln(x[i]) ; if x[i] > ; 0 then x[i] : = 0 ; end ; writeln ; writeln('Result') ; for i : = 1 to 10 do write(x[i], ' ') ; readln ;

end.

/ / третья программа

var x : array[1.

10] of integer ; i : integer ;

begin for i : = 1 to 10 do begin write('x[', i, '] = ') ; readln(x[i]) ; if x[i] < ; 0 then x[i] : = x[i] * x[i] ; end ; writeln ; writeln('Result') ; for i : = 1 to 10 do write(x[i], ' ') ; readln ;

end.

/ / четвертая программа

var x : array[1.

10] of integer ; i : integer ;

begin for i : = 1 to 10 do begin write('x[', i, '] = ') ; readln(x[i]) ; if x[i] > ; 10 then x[i] : = x[i] + 2 ; end ; writeln ; writeln('Result') ; for i : = 1 to 10 do write(x[i], ' ') ; readln ;

end.

Asema198448 6 авг. 2020 г., 09:32:32 | 5 - 9 классы

Составить программу которая заполняет массив из 10 элементов случайными целыми числами из положительные, отрицательные и нулевые числа и выводит на экран?

Составить программу которая заполняет массив из 10 элементов случайными целыми числами из положительные, отрицательные и нулевые числа и выводит на экран.

0664956447 4 авг. 2020 г., 01:37:18 | 5 - 9 классы

Написать программу которая даст таблицу Q5 * 5?

Написать программу которая даст таблицу Q5 * 5.

Каждый эелемент таблицы случайное число из отрезка [ - 30, + 30].

Вычислить сумму все отрицательных и сумму положительных элементов.

Кристинаагилеровна 24 авг. 2020 г., 07:24:06 | 5 - 9 классы

Составить программу, которая составит из двух таблиц 3 - ю, упорядоченную по возрастаннию?

Составить программу, которая составит из двух таблиц 3 - ю, упорядоченную по возрастаннию.

В паскале.

ИринаЛюбительская 5 сент. 2020 г., 10:35:36 | 5 - 9 классы

Составить программу которая выводит на экран таблицу умножения на 8?

Составить программу которая выводит на экран таблицу умножения на 8.

Buzkop 1 июл. 2020 г., 17:07:45 | 10 - 11 классы

Написать программу, которая запрашивает массив из N элементов и увеличивает все элементы массива на максимальный элемент?

Написать программу, которая запрашивает массив из N элементов и увеличивает все элементы массива на максимальный элемент.

Протестировать программу на массивах размерностью 8 и 10 элементов.

You3103 24 июн. 2020 г., 06:06:24 | 10 - 11 классы

Составить программу которая заполняет массив значением квадратов индексов элементов?

Составить программу которая заполняет массив значением квадратов индексов элементов.

Мучение0 14 сент. 2020 г., 05:20:12 | 5 - 9 классы

Составить программу , заменяющую отрицательные элементы элементы массива A[10] нулями?

Составить программу , заменяющую отрицательные элементы элементы массива A[10] нулями.

Grishabutkevic 9 янв. 2020 г., 18:05:51 | 5 - 9 классы

Дан массив A [1 ?

Дан массив A [1 .

20] целого типа .

Составить программу замены отрицательных элементов на 0, положительных на 1.

Гоха06 20 янв. 2020 г., 17:12:01 | 5 - 9 классы

Составить программу, которая печатает таблицу умножения на 5(паскаль)?

Составить программу, которая печатает таблицу умножения на 5(паскаль).

Thanking 19 нояб. 2020 г., 17:34:55 | 5 - 9 классы

Составить программу поиска элементов массива, значение которых совпадает с индексом?

Составить программу поиска элементов массива, значение которых совпадает с индексом.

На этой странице сайта, в категории Информатика размещен ответ на вопрос 1. Составить программу, которая увеличивает каждый элемент настоящей таблице х [1 ?. По уровню сложности вопрос рассчитан на учащихся 10 - 11 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.