2. Даны две переменные целого типа : Q и Z?

Информатика | 10 - 11 классы

2. Даны две переменные целого типа : Q и Z.

Если их значения равны, присвоить Q значение среднего арифметического этих двух действительных положительных чисел, а если не равны, то присвоить Z значение среднего геометрического этих двух действительных положительных чисел.

3. Написать программу, которая выводит на экран значения функции у = 5х2 - х + 2 для х, изменяющегося в диапазоне от - 3 до 3 с шагом 0, 5.

Ответить на вопрос
Ответы (1)
Sauleshka89 1 апр. 2022 г., 05:32:47

Program z14 ; Var q, z : integer ; sr, sg, x, y : real ; Begin write('Введите число Q = ') ; readln(q) ; write('Введите число Z = ') ; readln(z) ; writeln('Задание 2 : ') ; if (q = z) then begin sr : = (q + z) / 2 ; writeln('Среднее арифметическое = ', sr) ; end else begin sg : = sqrt(q * z) ; writeln('Среднее геометрическое = ', sg) ; end ; writeln('Задание 3 : ') ; x : = - 3 ; while (x.

Natalie24 9 янв. 2022 г., 05:21:47 | 5 - 9 классы

Напишите программу, которая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит эти числа на экран и вычисляет их среднее арифметическое?

Напишите программу, которая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит эти числа на экран и вычисляет их среднее арифметическое.

(КуМир).

Яна223 28 февр. 2022 г., 16:02:20 | студенческий

Даны две переменные целого типа А и В?

Даны две переменные целого типа А и В.

Если их значение не равны, то присвоить каждой переменной сумму этих значений, а если равны, то присвоить переменным нулевые значения.

Nastena199830 3 янв. 2022 г., 05:14:32 | 5 - 9 классы

Написать программу, которая выводит таблицу квадратов первых десяти целых положительных чисел C + +?

Написать программу, которая выводит таблицу квадратов первых десяти целых положительных чисел C + +.

TeriLis 13 апр. 2022 г., 04:02:47 | 5 - 9 классы

Составьте программу, которая сравнивает два целых числа введенных с клавиатуры - положительное и отрицательное и выводит положительное число на экран?

Составьте программу, которая сравнивает два целых числа введенных с клавиатуры - положительное и отрицательное и выводит положительное число на экран.

863269975421589 22 янв. 2022 г., 02:49:43 | 5 - 9 классы

Вычислить значение заданной функции?

Вычислить значение заданной функции.

Осуществить вывод значений аргумента и результатов вычислений значений функции в заданном диапазоне с заданным шагом.

MultyPulty 8 февр. 2022 г., 14:27:57 | 5 - 9 классы

Ввести с клавиатуры 9 производных чисел (положительных и отрицательных)?

Ввести с клавиатуры 9 производных чисел (положительных и отрицательных).

Вычислить среднее арифметическое нечетных и отрицательных из них.

Нужна программа для паскаля.

Yuralagouda 4 мая 2022 г., 22:04:14 | 10 - 11 классы

Написать программу, которая вычисляет сумму первых n целых положительных целых чисел?

Написать программу, которая вычисляет сумму первых n целых положительных целых чисел.

Количество суммируемых чисел должно вводиться во время работы программы.

Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены жирным шрифтом).

Вычисление суммы положительных чисел.

Введите количество суммируемых чисел —> 20

Сумма первых 20 положительных чисел равна 210.

Vovaplatow9597 1 февр. 2022 г., 09:09:21 | 5 - 9 классы

Даны две переменные целого типа : A и B?

Даны две переменные целого типа : A и B.

Если их значения не

равны, то присвоить каждой переменной большее из этих значений, а если

равны, то присвоить переменным нулевые значения.

Вывести новые

значения переменных A и B.

49Б.

Двоечниг 16 апр. 2022 г., 12:44:18 | 10 - 11 классы

Дана матрица действительных чисел A размером 6х7?

Дана матрица действительных чисел A размером 6х7.

Сформировать массив R1, …, R7, каждый элемент которого равен

среднему арифметическому значению элементов

соответствующего столбца матрицы A : написать программу С + , помогите пожалуйста.

Vladuk9666 4 июн. 2022 г., 18:31:49 | 5 - 9 классы

Как вывести функцию сравнения двух чисел в паскале с помощью mod и div не используя IF?

Как вывести функцию сравнения двух чисел в паскале с помощью mod и div не используя IF?

Напишите программу, которая считывает два целых положительных числа aa и bb и выводит наибольшее значение из них.

Вы зашли на страницу вопроса 2. Даны две переменные целого типа : Q и Z?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.