Определить количество целых чисел, которые можно закодировать 2 байтами (Integer)?

Информатика | 10 - 11 классы

Определить количество целых чисел, которые можно закодировать 2 байтами (Integer).

Напишите, пожалуйста полное решение.

Ответить на вопрос
Ответы (1)
Polyariya 22 февр. 2022 г., 11:38:12

1 байт = 8 бит.

Максимальное число которое можно закодировать двумя байтами это :

1111111111111111 (16 едениц)

Переведем в десятичную систему исчисления :

1 + 2 + 4 + 8 + 16 + 32 + 64 + 128 + 256 + 512 + 1024 + 2048 + 4096 + 8192 + 16384 + 32768 = 65535

Не забываем 0, и того получается 65536.

Малой2000 12 мар. 2022 г., 05:10:32 | студенческий

А как быть с этим?

А как быть с этим?

Определите пожалуйста, количество чисел K, для которых следующая программа выведет такой же результат, что и для K = 120 :

var i, k : integer ;

function F(x : integer) : integer ;

begin if x < 1 then F : = 1 else F : = F(x - 1) + 3 * F(x - 2) ;

end ;

begin i : = 0 ; readln(K) ; while F(i) < K do i : = i + 1 ; writeln(i) ;

end.

Chubenco2005gfh 3 апр. 2022 г., 09:37:25 | 10 - 11 классы

Сколько байт нужно, чтобы закодировать один символы русского и латинского алфавита(только большие и маленькие буквы)?

Сколько байт нужно, чтобы закодировать один символы русского и латинского алфавита(только большие и маленькие буквы)?

Моньяк1 18 янв. 2022 г., 08:45:23 | 5 - 9 классы

Рисунок закодирован с палитрой 128 цветов?

Рисунок закодирован с палитрой 128 цветов.

Сколько байт занимает информация о палитре?

Вероника161rus 7 февр. 2022 г., 13:27:21 | 5 - 9 классы

Племени мульти состоит из 290 символов каждый из закодированы двоичным последовательно минимальной длины Какое количество информации будет содержать предложение из 40 символов ответственности в байтах?

Племени мульти состоит из 290 символов каждый из закодированы двоичным последовательно минимальной длины Какое количество информации будет содержать предложение из 40 символов ответственности в байтах.

Diko86 5 мар. 2022 г., 00:08:42 | 10 - 11 классы

Книга состоит из 320 листов?

Книга состоит из 320 листов.

На странице 2000 знаков .

Определите количество информации в книге (в байтах).

Dmitriy2005rus 2 мар. 2022 г., 23:03:03 | 5 - 9 классы

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , сумму чётных чисел и сумму нечётных от 1 до n2)напишите программу, которая спрашивает целые числа а и b и выводит н?

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , сумму чётных чисел и сумму нечётных от 1 до n

2)напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b

(Паскаль).

Волк151 28 мар. 2022 г., 04:22:36 | 5 - 9 классы

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , Муму чётных чисел и сумму нечётных от 1 до n2)напишите программу, которая спрашивает целые числа а и b и выводит на?

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , Муму чётных чисел и сумму нечётных от 1 до n

2)напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b

3) напишите программу, которая спрашивает целые числа а и b и выводит на экран количество чётных и нечётных чисел в диапазоне от а до b

4) напишите программу, которая спрашивает целое число n , целые числа а и b, и выводит на экран n случайных чисел от а до b.

Chuev 4 июн. 2022 г., 06:07:33 | студенческий

Даны две последовательности целых чисел : a1, a2, ?

Даны две последовательности целых чисел : a1, a2, .

, a8 и b1, b2, .

, b8.

Найти количество четных чисел в первой из них и количество нечетных во

второй.

(Определить функцию, позволяющую распознавать четные числа.

)(решите на с + + ).

Girlonline03 6 янв. 2022 г., 08:16:10 | 5 - 9 классы

Среди заданных трех положительных чисел определить количество трехзначных чисел?

Среди заданных трех положительных чисел определить количество трехзначных чисел.

Даша2900 28 февр. 2022 г., 13:36:14 | 1 - 4 классы

9 класс ?

9 класс !

Напишите программу, которая в последовательности целых чисел определяет их количество и сумму чётных чисел.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — при знак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа по модулю не превышают 30 000.

Программа должна вывести два числа : длину последовательности и сумму чётных чисел.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Определить количество целых чисел, которые можно закодировать 2 байтами (Integer)?. По уровню сложности вопрос рассчитан на учащихся 10 - 11 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.