Вычислить сумму цифр четырехзначного числа, которые кратны 3 паскаль?

Информатика | 1 - 4 классы

Вычислить сумму цифр четырехзначного числа, которые кратны 3 паскаль.

Ответить на вопрос
Ответы (2)
Vnadja 18 июл. 2021 г., 08:03:42

Может быть 8.

Karinasamoylova 18 июл. 2021 г., 08:03:46

Const l = 4 ;

var n, s : integer ; i : byte ;

begin write ('Введите 4 - значное число : ') ; readln (n) ; for i : = 1 to l do begin if (n mod 10) mod 3 = 0 then s : = s + (n mod 10) ; n : = n div 10 ; end ; writeln ; writeln ('Сумма цифр, кратных 3 = ', S)

end.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Пример :

Введите число : 3456

Сумма цифр, кратных 3 = 9.

10246328 10 февр. 2021 г., 11:56:07 | 5 - 9 классы

Составьте программу, выводящую на экран все четырехзначные числа, сумма цифр которых меньше 4 паскаль?

Составьте программу, выводящую на экран все четырехзначные числа, сумма цифр которых меньше 4 паскаль.

Brusovpp 29 мая 2021 г., 04:13:25 | 5 - 9 классы

Найти сумму четырехзначного числа на языке паскаль?

Найти сумму четырехзначного числа на языке паскаль.

Luna121286g 15 янв. 2021 г., 13:53:45 | 5 - 9 классы

Дано четырехзначное число?

Дано четырехзначное число.

Определить кратна ли 3 сумма его цифр.

Arslan12342 4 окт. 2021 г., 23:14:59 | 5 - 9 классы

1 Дано трехзначное число?

1 Дано трехзначное число.

Определить какая из его цифр больше первая или вторая.

2 Дано четырехзначное число.

Определить кратна ли 3 сумма его цифр.

Это по Информатике.

В паскале.

Пж срочно.

Асыланбек 24 июл. 2021 г., 13:31:26 | 5 - 9 классы

Задание 2?

Задание 2.

Составьте программу, определяющую, является ли сумма цифр данного четырехзначного числа n четным числом.

В паскале, спасибо большое.

MAKSIMSUVORIN2 19 апр. 2021 г., 22:41:06 | 5 - 9 классы

Дано четырехзначное число, если оно кратно 4, то посчитать сумму его цифр, иначе посчитать произведение цифр?

Дано четырехзначное число, если оно кратно 4, то посчитать сумму его цифр, иначе посчитать произведение цифр.

Составить программу на Паскаль.

Русалина3 3 июн. 2021 г., 08:50:26 | 10 - 11 классы

Напишите на паскале (АВС)?

Напишите на паскале (АВС).

Задание : Среди всех четырехзначных натуральных чисел вывести на экран "особо счастливые", у которых сумма цифр в четных разрядах равна сумме цифр в нечетных.

Nesterova198143 31 окт. 2021 г., 02:24:01 | 5 - 9 классы

Даны 2 четырехзначные числа, как в паскале найти сколько цифр в них совпадают?

Даны 2 четырехзначные числа, как в паскале найти сколько цифр в них совпадают.

Sobirovamariya 3 июл. 2021 г., 03:51:19 | 5 - 9 классы

С клавиатуры вводится четырехзначное число найдите сумму цифр в этом числе кратных трем?

С клавиатуры вводится четырехзначное число найдите сумму цифр в этом числе кратных трем.

Ygtujftrugk 23 сент. 2021 г., 08:51:30 | 10 - 11 классы

Вывести через программу Паскаль в 4 столбика все четырехзначные числа, которые делятся на сумму своих чисел?

Вывести через программу Паскаль в 4 столбика все четырехзначные числа, которые делятся на сумму своих чисел.

На этой странице находится ответ на вопрос Вычислить сумму цифр четырехзначного числа, которые кратны 3 паскаль?, из категории Информатика, соответствующий программе для 1 - 4 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.