1)дано трехзначное число?

Информатика | 5 - 9 классы

1)дано трехзначное число.

Составьте программу которая определяет а)является ли сумма его цифр нечетным числом

2)Составьте программу в которой осуществляется вот целых чисел до тех пор пока не будет введен 0 и подсчет а)количество чисел оканчивающихся на 6 и кратных 4 б)Сумма чисел оканчивающихся на 6 и кратных 4

на языке Паскаль.

Ответить на вопрос
Ответы (1)
Випшкола 15 дек. 2021 г., 15:17:34

1)

Program hhh54 ;

var x : longint ;

begin read (x) ; if ((x div 100) + ((x div 10) mod 10) + (x mod 10)) mod 2 0 then write ('ЯВЛЯЕТСЯ') else write ('НЕ ЯВЛЯЕТСЯ') ;

end.

2)

а)

Progran hhh54 ;

var i, k, x : longint ;

begin k : = 0 ; read (x) ; while x 0 do begin if (x mod 10 = 6) and (x mod 4 = 0) ; then k : = k + 1 ; read (x) ; end ; write (k) ;

end.

Б)

Progran hhh54 ;

var i, s, x : longint ;

begin s : = 0 ; read (x) ; while x 0 do begin if (x mod 10 = 6) and (x mod 4 = 0) ; then s : = s + x ; read (x) ; end ; write (s) ;

end.

Stotik 9 авг. 2021 г., 06:15:48 | 5 - 9 классы

Нужна помощь ?

Нужна помощь .

Введите с клавиатуры 5 положительных целых чисел.

Вычислить сумму тех из них, которые делятся на 4 и при этом заканчивается на 6.

Программа должна вывести одно число сумму чисел, кратных 4 и оканчивающихся на 6.

Baronina79 2 сент. 2021 г., 07:23:46 | 5 - 9 классы

Напишите программу которая в последовательности натуральных чисел определяет количество всех чисел, кратных 6 и оканчивающихся на 0?

Напишите программу которая в последовательности натуральных чисел определяет количество всех чисел, кратных 6 и оканчивающихся на 0.

Программа получает на вход натуральные числа, кол - во введенных чисел неизвестно, последовательность чисел оканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).

Кол - во чисел не превышает 1000.

Введенные числа не превышают 30000.

Программа должна вывести одно число : кол - во всех чисел последовательности, кратных 6 и оканчивающихся на 0.

PROST100MAG 23 июн. 2021 г., 08:37:19 | 10 - 11 классы

1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел , кратных 6?

1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел , кратных 6.

Программа получает на вод натуральные числа, кол - во введенных чисел неизвестно, последовательность чисел заканчивается числом 0(0 - признак окончания ввода, не входит в последовательность).

Программа должна вывести одно число : сумма четырехзначных чисел , кратных 6.

2) Напишите программу , которая в последовательности натуральных чисел определяет максимальное число, кратно 3 и оканчивающиеся на 3.

Программа получает на вход кол - во чисел в последовательности, а заем сами числа.

В последовательности всегда имеется число, кратное 3 и оканчивающиеся на 3.

Кол - во чисел не превышает 1000.

Введенные числа не превышают 30 000.

Программа должна вывести одно число - максимальное число, кратное 3 и оканчивающиеся на 3.

Gulo03 15 нояб. 2021 г., 22:50:41 | 5 - 9 классы

1. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 9?

1. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 9.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, кратное 9.

2. Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 8.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, оканчивающееся на 8.

Lezxa 9 янв. 2021 г., 05:23:17 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 7 и оканчивающихся на 2?

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 7 и оканчивающихся на 2.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа не превышают 30 000.

Программа должна вывести одно число : сумму всех чисел, кратных 7 и оканчивающихся на 2.

Соф11 10 дек. 2021 г., 00:09:57 | 5 - 9 классы

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и и подсчет суммы?

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и и подсчет суммы.

Введённых положительных чисел.

Используйте оператор repeat.

Решить в паскале.

Botanoc 15 апр. 2021 г., 05:15:28 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3 и оканчивающихся на 4?

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3 и оканчивающихся на 4.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, кратное 3 и оканчивающееся на 4.

Количество чисел не превышает 100.

Введённые числа по модулю не превышают 300.

Программа должна вывести одно число : сумму чисел, кратных 3 и оканчивающихся на 4.

Димкин 8 июн. 2021 г., 07:52:32 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3 и оканчивающихся на 4?

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3 и оканчивающихся на 4.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, кратное 3 и оканчивающееся на 4.

Количество чисел не превышает 100.

Введённые числа по модулю не превышают 300.

Программа должна вывести одно число : сумму чисел, кратных 3 и оканчивающихся на 4.

Svd011 8 июл. 2021 г., 14:09:43 | 10 - 11 классы

Напишите программу которая в последовательности натуральных чисел определяет количество таких чисел которые кратны 4 и оканчиваются на 2 ?

Напишите программу которая в последовательности натуральных чисел определяет количество таких чисел которые кратны 4 и оканчиваются на 2 .

Программа получает на вход натуральные числа количество введённых чисел неизвестно последовательность чисел заканчивается числом 0.

Количества чисел не превышает 1000 введенные числа не привышают 30000 программа должна вывести одно число : количество чисел , кратных 4 и оканчивающихся на 2.

MrDrosh111 29 авг. 2021 г., 19:10:11 | 5 - 9 классы

Напишите программу которая в последовательности натуральных чисел определяет сумму всех чисел кратных 7 и оканчивающихся на 1?

Напишите программу которая в последовательности натуральных чисел определяет сумму всех чисел кратных 7 и оканчивающихся на 1.

Программа получает вход натуральные числа количество введённых чисел неизвестно последовательность чисел заканчивается числом 0(0 - признак окончания ввода не входит в последовательность).

Программа должна вывести одно число : сумму всех чисел кратных 7 и оканчивающихся на 1.

На этой странице сайта вы найдете ответы на вопрос 1)дано трехзначное число?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.