Среди всех трёхзначных чисел (отрицательных и положительных) найти и выписать на экран те, у которых произведение крайних цифр совпадает с кубом средней цифры?

Информатика | 5 - 9 классы

Среди всех трёхзначных чисел (отрицательных и положительных) найти и выписать на экран те, у которых произведение крайних цифр совпадает с кубом средней цифры.

Ответить на вопрос
Ответы (1)
55544 12 нояб. 2021 г., 16:49:42

Var i, c : integer ;

begin

for i : = 100 to 999 do

begin

c : = i div 10 mod 10 ;

if (i div 100) * (i mod 10) = c * c * c then writeln( - i, ' ', i) ;

end ;

end.

Результат : - 100 100 - 111 111 - 128 128 - 200 200 - 224 224 - 300 300 - 339 339 - 400 400 - 422 422 - 500 500 - 600 600 - 700 700 - 800 800 - 821 821 - 848 848 - 900 900 - 933 933.

Anuta18022000 14 янв. 2021 г., 13:49:31 | 5 - 9 классы

Массив состоит из 20 целых положительных и отрицательных чисел, каждое из которых находится в пределах от 2 до 12?

Массив состоит из 20 целых положительных и отрицательных чисел, каждое из которых находится в пределах от 2 до 12.

Вывести на экран сначала отрицательные, а затем положительные числа.

Определите, модуль суммы каких чисел больше - положительных или отрицательных.

Sonikpanasonik33 26 мая 2021 г., 11:04:28 | 10 - 11 классы

Дано n натуральное?

Дано n натуральное.

Найти и вывести все числа в интервале от 10 до n - 1, у которых произведение всех цифр совпадает с суммой цифр данного числа.

Если таких чисел нет вывести "Нет".

Паскаль.

Nasiban10 6 мар. 2021 г., 13:48:45 | 5 - 9 классы

Дано трёхзначное число?

Дано трёхзначное число.

Найти произведение и частное второй и третей цифр.

Baymax73 21 мая 2021 г., 00:20:13 | 5 - 9 классы

Напишите программу, в которой осуществляется ввод целых чисел (пока не будет введён 0) и выведет на экран сумму положительных чисел, и произведение отрицательных введённых чисел?

Напишите программу, в которой осуществляется ввод целых чисел (пока не будет введён 0) и выведет на экран сумму положительных чисел, и произведение отрицательных введённых чисел.

Использовать цикл repeat.

Ddvpenza 10 мая 2021 г., 11:28:20 | 5 - 9 классы

Среди всех двузначных чисел указать те, сумма цифр которых равна числу К?

Среди всех двузначных чисел указать те, сумма цифр которых равна числу К.

Vanya1999dokukin 28 июл. 2021 г., 03:04:42 | 5 - 9 классы

Сравнить сумму чисел из диапазона от - 5 до + 5 и произведение цифр целого трёхзначного числа?

Сравнить сумму чисел из диапазона от - 5 до + 5 и произведение цифр целого трёхзначного числа.

Роллсп 7 окт. 2021 г., 02:26:48 | 5 - 9 классы

Найти количество четырехзначных натуральных чисел до N у которых сумма двух средних цифр равна хотя бы одной из крайних цифр?

Найти количество четырехзначных натуральных чисел до N у которых сумма двух средних цифр равна хотя бы одной из крайних цифр.

AppleJackin 16 дек. 2021 г., 19:08:38 | 10 - 11 классы

Среди всех трехзначных натуральных чисел вывести на экран в строчку те числа которые делятся на заданное m, так же найти их количество?

Среди всех трехзначных натуральных чисел вывести на экран в строчку те числа которые делятся на заданное m, так же найти их количество.

Sivach142 22 июл. 2021 г., 10:16:43 | 5 - 9 классы

Среди двузначных чисел найти те, сумма цифр которых равна 10 (pascal)?

Среди двузначных чисел найти те, сумма цифр которых равна 10 (pascal).

Русалина3 3 июн. 2021 г., 08:50:26 | 10 - 11 классы

Напишите на паскале (АВС)?

Напишите на паскале (АВС).

Задание : Среди всех четырехзначных натуральных чисел вывести на экран "особо счастливые", у которых сумма цифр в четных разрядах равна сумме цифр в нечетных.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Среди всех трёхзначных чисел (отрицательных и положительных) найти и выписать на экран те, у которых произведение крайних цифр совпадает с кубом средней цифры?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.