Помогите пожалуйста?

Информатика | 5 - 9 классы

Помогите пожалуйста!

Написать программу , которая вычислит отдельные суммы четных и нечетных чисел натурального ряда и их произведения.

Ответить на вопрос
Ответы (1)
Vnogaew1 5 окт. 2020 г., 21:47:10

Const

N = 7 ;

Var

A : array[1.

N]of integer ;

i : integer ;

S, Sn, P, Pn : real ;

Begin

S : = 0 ;

Sn : = 0 ;

P : = 1 ;

Pn : = 1 ;

For i : = 1 to N do

Begin

A[i] : = random(7) + 1 ;

Write(A[i], ' ') ;

if A[i] mod 2 = 0 then

Begin

S : = S + A[i] ;

P : = P * A[i] ;

End

else

Begin

Sn : = Sn + A[i] ;

Pn : = Pn * A[i] ;

End

End ;

WriteLn ;

WriteLn('Сумма чётных элементов = ', S) ;

WriteLn('Произведение чётных элементов = ', P) ;

WriteLn('Сумма НЕчётных элементов = ', Sn) ;

WriteLn('Произведение НЕчётных элементов = ', Pn) ;

End.

Илья1421 4 дек. 2020 г., 23:46:04 | 5 - 9 классы

Составьте программу, которая находит произведение четных чисел и сумму нечетных чисел в диапазоне от 1 до 10?

Составьте программу, которая находит произведение четных чисел и сумму нечетных чисел в диапазоне от 1 до 10.

В PascalABC.

Dahila0306031 22 июл. 2020 г., 17:56:08 | 5 - 9 классы

Составьте программу, которая находит сумму четных чисел и произведение нечетных чисел в диапазоне от 10 до 26?

Составьте программу, которая находит сумму четных чисел и произведение нечетных чисел в диапазоне от 10 до 26.

Vorondan7772 4 дек. 2020 г., 17:37:54 | 10 - 11 классы

Программа на Паскале?

Программа на Паскале.

Нахождение произведения четных чисел и суммы нечетных чисел меньше 15.

Maлunka 16 янв. 2020 г., 06:35:33 | 5 - 9 классы

Составить программу, которая вычисляет произведение нечетных натуральных чисел от 1 до N Помогите , пожалуйста : ))?

Составить программу, которая вычисляет произведение нечетных натуральных чисел от 1 до N Помогите , пожалуйста : )).

ОляТр 11 мая 2020 г., 07:48:57 | 5 - 9 классы

Составе программу которая находит сумму четных чисел и произведение нечетных чисел в диапазоне от 1 до 10?

Составе программу которая находит сумму четных чисел и произведение нечетных чисел в диапазоне от 1 до 10.

Rasimm 8 июл. 2020 г., 03:45:55 | 5 - 9 классы

8 класс?

8 класс.

Составьте программу, которая находит сумму четных чисел и произведение нечетных чисел в диапазоне от 1 до 10.

Galina8908057 24 мар. 2020 г., 05:56:28 | 5 - 9 классы

Помогите пожалуйста?

Помогите пожалуйста!

Нужно написать программу, которая подсчитывает сумму и произведение нечетных чисел, в одномерном массиве, размерностью 10.

Мистэр 24 сент. 2020 г., 04:01:14 | 5 - 9 классы

ПОМОГИТЕ РЕШИТЬ ИНФОРМАТИКУ ПОЖАЛУЙСТА?

ПОМОГИТЕ РЕШИТЬ ИНФОРМАТИКУ ПОЖАЛУЙСТА!

Написать программу, которая вычислит сумму и произведения ряда натуральных чисел от 1 до n.

Vladimirovna111 12 сент. 2020 г., 23:00:12 | 5 - 9 классы

Составьте программу которая находит сумму четных чисел в и произведение нечетных чисел в диапазоне от 1 до 10?

Составьте программу которая находит сумму четных чисел в и произведение нечетных чисел в диапазоне от 1 до 10.

Kourov 6 окт. 2020 г., 22:33:10 | 10 - 11 классы

Cоставить программу в паскале?

Cоставить программу в паскале.

В одномерном массиве произвольных чисел вычислить произведение четных и нечетных элементов.

На этой странице вы найдете ответ на вопрос Помогите пожалуйста?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.