Дана последовательность из N вещественных чисел?

Информатика | 5 - 9 классы

Дана последовательность из N вещественных чисел.

Первое число в последовательности нечетное.

Найти сумму всех идущих подряд в начале последовательности нечетных чисел.

Условный оператор не использовать.

Ответить на вопрос
Ответы (1)
Lesya115 22 дек. 2020 г., 16:35:10

/ / PascalABC.

NET / / Переменная m - множитель, когда встретится / / четное число, m станет равным нулю

begin var n : = ReadInteger('n = ') ; var m : = 1 ; var sum : = 0 ; for var i : = 1 to n do begin var number : = ReadInteger ; m * = number mod 2 ; count + = m * number end ; write(sum)

end.

Наталия1611 8 янв. 2020 г., 10:35:08 | 10 - 11 классы

Даны натуральное число n и последовательность целых чисел а1, а2, …, аn?

Даны натуральное число n и последовательность целых чисел а1, а2, …, аn.

Определить количество тех членов последовательности, которые нечетны .

Найти сумму членов последовательности, кратных 11.

Составить блок - схему алгоритма, написать программу.

Про100упс 27 июл. 2020 г., 21:05:24 | 5 - 9 классы

Дана последовательность натуральных чисел, завершающаяся числом 0?

Дана последовательность натуральных чисел, завершающаяся числом 0.

Определите, какое наибольшее число подряд идущих элементов этой последовательности равны друг другу.

Гоаркристине 5 окт. 2020 г., 00:50:37 | 5 - 9 классы

Надо сделать в паскале 1)Дан одномерный массив вещественных чисел?

Надо сделать в паскале 1)Дан одномерный массив вещественных чисел.

Найти минимальный элемент массива.

2) Дана последовательность 7 чисел.

Вычислите сумму элементов данной последовательности меньших нуля.

Спасибо.

Rewmos 1 апр. 2020 г., 02:12:20 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех четных чисел чисел и количество нечетных?

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех четных чисел чисел и количество нечетных.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Romanychka 13 янв. 2020 г., 14:59:40 | 10 - 11 классы

Дана последовательность чисел?

Дана последовательность чисел.

Найти в ней наименьшее число.

Анна89082293677 3 окт. 2020 г., 16:53:42 | 10 - 11 классы

Надо составить программу?

Надо составить программу.

Дана последовательность натуральных чисел а1, а2, .

Аn. Создать массив из нечетных чисел этой последовательности если таких нет, выведите сообщение об этом факте.

СРОЧНО НАДО СЕГОДНЯ((((.

Kriss959 20 окт. 2020 г., 01:52:04 | 10 - 11 классы

С клавиатуры вводится последовательность чисел до тех пор, пока не будет введено число 0?

С клавиатуры вводится последовательность чисел до тех пор, пока не будет введено число 0.

Требуется найти произведение нечетных чисел из введенной последовательности.

Решение с помощью while, подробно.

AaaKro1344 27 апр. 2020 г., 07:41:09 | 10 - 11 классы

Введите с клавиатуры два целых нечетных числа (первое больше второго)?

Введите с клавиатуры два целых нечетных числа (первое больше второго).

Выведите на экран последовательность нечетных чисел, расположенных между этими числами (паскаль).

ZlataFox 23 дек. 2020 г., 17:19:43 | 5 - 9 классы

Дана последовательность из n целых чисел?

Дана последовательность из n целых чисел.

Определить, есть ли в ней число, равное первому из этой последовательности.

AndreyKOdonezk 26 сент. 2020 г., 05:17:08 | 10 - 11 классы

Дана числовая последовательность случайных натуральных чисел не превышающих число 255?

Дана числовая последовательность случайных натуральных чисел не превышающих число 255.

Конец последовательности число ноль.

Проанализировать последовательность и вывести на экран количество, в этой последовательности, нечетных чисел, которые лежат в диапазоне от 1 до 9 включительно.

Это программирование паскаль 8 класс.

На этой странице находится вопрос Дана последовательность из N вещественных чисел?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.