Известны сведения о температуре за 10 дней (от - 20 до 20)?

Информатика | 5 - 9 классы

Известны сведения о температуре за 10 дней (от - 20 до 20).

Найти :

Найти среднюю температуру ;

Количество дней, когда были заморозки ;

Самую высокую температуру.

Задачу решить на Паскале.

Срочно!

Ответить на вопрос
Ответы (2)
Tem4iKo 11 нояб. 2020 г., 03:53:00

- 20 - 20= - 40 градусов - 40 - 10= - 50 гралусов.

Sereys 11 нояб. 2020 г., 03:53:02

Const n = 10 ;

var

temp : array [0.

N - 1] of shortint ;

max, min, i : byte ;

sum : integer ;

begin

randomize ;

writeln ('Температуры ', n, ' дней : ') ;

for i : = 0 to n - 1 do

begin

temp[i] : = random (41) - 20 ;

write (temp[i], ' ; ') ;

if temp[i]>temp[max] then max : = i ;

if temp[i].

Vladek123 13 июн. 2020 г., 08:44:50 | 5 - 9 классы

Найти среднею температуру воздуха за неделю ( Паскаль) программу напишите?

Найти среднею температуру воздуха за неделю ( Паскаль) программу напишите.

Единорог49370 20 апр. 2020 г., 04:04:46 | 5 - 9 классы

ВТОРОЙ РАЗ ПРОШУ, ПОМОГИТЕ?

ВТОРОЙ РАЗ ПРОШУ, ПОМОГИТЕ!

ПОЖАЛУЙСТА!

: (((ОЧЕНЬ НАДО!

: (ПОМОГИТЕЕЕЕЕЕ

в массиве хранится температура воздуха за январь месяц, определить среднюю температуру января и количество дней в январе, когда температура была ниже среднего.

БЕТМЕН666 7 июн. 2020 г., 00:05:12 | 5 - 9 классы

Информатика (Pascal) : Написать программу для след задачи : Найти среднюю температуру, если кол - во n дней, когда t > ; = 5?

Информатика (Pascal) : Написать программу для след задачи : Найти среднюю температуру, если кол - во n дней, когда t > ; = 5.

Вывести ДА или НЕТ.

Alexb97 7 мар. 2020 г., 00:03:58 | 10 - 11 классы

Известны данные о среднемесячной температуре за год?

Известны данные о среднемесячной температуре за год.

Определить, какая была самая высокая температура летом и самая низкая зимой.

Нужен код программы в паскаль.

Plutonjuke 10 февр. 2020 г., 18:41:20 | 5 - 9 классы

А) найдите среднюю температуру за неделю (температура была : - 5, - 3, - 7, - 6, - 2, - 4, - 3) Сколько дней было выше средней?

А) найдите среднюю температуру за неделю (температура была : - 5, - 3, - 7, - 6, - 2, - 4, - 3) Сколько дней было выше средней?

Ниже средней?

Составить массив.

Нюра4 10 нояб. 2020 г., 12:58:39 | 5 - 9 классы

Информация о средней суточной температуре воздуха за месяц задана в виде массива?

Информация о средней суточной температуре воздуха за месяц задана в виде массива.

Определите, температура скольких дней была выше среднемесячной.

Напишите программу в Кумире.

Добродон 8 мар. 2020 г., 15:30:08 | 5 - 9 классы

В массивах Td B Tn хранятся результаты измерения дневной и ночной температуры за 7 дней ?

В массивах Td B Tn хранятся результаты измерения дневной и ночной температуры за 7 дней .

Определить среднесуточную температуру за неделю.

Dtulepbayeva26 22 апр. 2020 г., 19:56:17 | 5 - 9 классы

В массиве хранится информация о среднедневной температуре за каждый день июля?

В массиве хранится информация о среднедневной температуре за каждый день июля.

Определить количество двух самых тёплых дней в этом месяце.

Milaplotnikova1 5 янв. 2020 г., 21:36:18 | 10 - 11 классы

Напишите программу для решения следующей задачи?

Напишите программу для решения следующей задачи.

Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру.

Найдите среднюю температуру за время наблюдения.

Если количество дней, когда температура поднималась выше нуля градусов, не менее 5, выведите YES, иначе выведите NO.

Программа получает на вход количество дней, в течение которых проводилось наблюдение N (1 ≤ N ≤ 31), затем для каждого дня вводится температура.

Марина7771 23 февр. 2020 г., 16:28:51 | 5 - 9 классы

В массиве хранится информация о среднесуточной температуре за текущую неделю?

В массиве хранится информация о среднесуточной температуре за текущую неделю.

Составить программу, определяющую среднюю температуру за неделю и количество дней, в течение которых температура была выше средней.

Вопрос Известны сведения о температуре за 10 дней (от - 20 до 20)?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.