Известны данные о среднемесячной температуре за год?

Информатика | 10 - 11 классы

Известны данные о среднемесячной температуре за год.

Определить, какая была самая высокая температура летом и самая низкая зимой.

Нужен код программы в паскаль.

Ответить на вопрос
Ответы (1)
Nastya20530 7 мар. 2020 г., 00:04:04

Program Task ;

Const m = 12 ;

Var a : Array [1.

M] of Integer ;

i : Integer ;

Function Max(a, b : Integer) : Integer ;

Begin

If a > ; b Then

Result : = a

Else

Result : = b ;

End ;

Function Min(a, b : Integer) : Integer ;

Begin

If a < ; b Then

Result : = a

Else

Result : = b ;

End ;

Begin

WriteLn('Введите среднемесячные температуры за год (через пробел)') ;

For i : = 1 To m Do

Read(a[i]) ;

WriteLn('Самая высокая температура летом равна ', Max(Max(a[6], a[7]), a[8])) ;

WriteLn('Самая низкая температура зимой равна ', Min(Min(a[11], a[12]), a[1])) ;

ReadLn ;

End.

Nikita5647 14 янв. 2020 г., 05:31:56 | 10 - 11 классы

Что такое подкачка данных в иерархической модели памяти?

Что такое подкачка данных в иерархической модели памяти?

(укажите несколько правильных ответов)

1) перемещение данных на самый высокии уровень

2) перемещение данных на самый низкии уровень

3) перемещение данных с более высоко уровня на более низкий

4) перемещение данных с более низкого уровня на более высокии

5) удаление данных с физического носителя.

Artemrochypkin 30 сент. 2020 г., 02:16:33 | 10 - 11 классы

Дана таблица значений среднемесячных температур в течение года составит программу на pascal в которой вычесляютсь четыре велечины : среднее температуры зимних месяцев весенних месяцев летних и осенних?

Дана таблица значений среднемесячных температур в течение года составит программу на pascal в которой вычесляютсь четыре велечины : среднее температуры зимних месяцев весенних месяцев летних и осенних.

Vladek123 13 июн. 2020 г., 08:44:50 | 5 - 9 классы

Найти среднею температуру воздуха за неделю ( Паскаль) программу напишите?

Найти среднею температуру воздуха за неделю ( Паскаль) программу напишите.

Elenamanina44 11 мая 2020 г., 14:30:38 | 5 - 9 классы

Составить программу в Паскале :В группе определить самого высокого мальчика и самую маленькую девочку?

Составить программу в Паскале :

В группе определить самого высокого мальчика и самую маленькую девочку.

Дима9779 20 авг. 2020 г., 07:43:02 | 5 - 9 классы

Помогите решить задачки на паскале я совсем не разбираюсь в этом?

Помогите решить задачки на паскале я совсем не разбираюсь в этом!

1)Дана таблица со значениями среднемесячных температур в течение года.

Составить программу на Паскале, в которой вычисляются четыре величины : средние температуры зимних месяцев, весенних месяцев, летних и осенних.

2)Вы посетили магазин и купили 10 видов товара.

В таблицу T [1.

10] записали количество купленного товара каждого вида.

В таблицу C [1.

10] записали цену единицы каждого вида товара соответственно.

Составить программу на Паскале вычисления общей стоимости всех покупок.

Нюра4 10 нояб. 2020 г., 12:58:39 | 5 - 9 классы

Информация о средней суточной температуре воздуха за месяц задана в виде массива?

Информация о средней суточной температуре воздуха за месяц задана в виде массива.

Определите, температура скольких дней была выше среднемесячной.

Напишите программу в Кумире.

Usmanovalihan2 13 февр. 2020 г., 12:15:15 | 10 - 11 классы

С помощью Паскаля написать программу на задачу : Дана температура?

С помощью Паскаля написать программу на задачу : Дана температура.

Определить агрегатное состояние воды.

Klermj 17 апр. 2020 г., 18:56:43 | 10 - 11 классы

Задачи на массив в Turbo Pascal1) Определите , на сколько отличается рост самого высокого и самого низкого учащегося в классе?

Задачи на массив в Turbo Pascal

1) Определите , на сколько отличается рост самого высокого и самого низкого учащегося в классе?

2) результаты переписи населения, которые хранятся в памяти компьютера.

Элемент массива - год рождения жителя.

Подсчитайте общее число жителей, родившихся раньше 1958 года.

3) С 8 до 20 часов температура воздуха измерялась ежечасно, и результаты измерения заносились в компьютер.

Известно, что в течение этого времени температура понижалась.

Напишите программу, определяющую, в котором часу была впервые отмечена отрицательная температура.

Alice02v 23 авг. 2020 г., 09:01:23 | 10 - 11 классы

ПОМОГИТЕ ПОЖАЛУЙСТА, СРОЧНО?

ПОМОГИТЕ ПОЖАЛУЙСТА, СРОЧНО!

Напишите программу на языке Паскаль, которая в конце выведет среднемесячную температуру.

Аля37 11 нояб. 2020 г., 03:52:55 | 5 - 9 классы

Известны сведения о температуре за 10 дней (от - 20 до 20)?

Известны сведения о температуре за 10 дней (от - 20 до 20).

Найти :

Найти среднюю температуру ;

Количество дней, когда были заморозки ;

Самую высокую температуру.

Задачу решить на Паскале.

Срочно!

На этой странице находится ответ на вопрос Известны данные о среднемесячной температуре за год?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.