Программирование на pascal abc1?

Информатика | 5 - 9 классы

Программирование на pascal abc

1.

Путем копирования и склеивания получить из слова клоун слово кулон

2.

Дано предложение.

Определить, каких букв в нем больше : "м" или "н".

Ответить на вопрос
Ответы (2)
НткитаКозлов 14 окт. 2020 г., 08:58:09

1)

Program n1 ; var cl, q : string ; begin cl : = 'клоун' ; writeln(cl) ; cl : = cl[1] + cl[4] + cl[2] + cl[3] + cl[5] ; writeln(cl) ; end.

2)

Program n1 ; var i, k, k1 : integer ; st : string ; x : char ; begin readln(st) ; x : = 'м' ; k : = 0 ; k1 : = 0 ; for i : = 1 to length(st) do if st[i] = x then k : = k + 1 ; x : = 'н' ; for i : = 1 to length(st) do if st[i] = x then k1 : = k1 + 1 ; if(k>k1) then writeln('м больше чем н') ; if(k.

Nogal 14 окт. 2020 г., 08:58:16

1. var s1, s2 : string ;

begin

s1 : = 'клоун' ;

s2 : = s1[1] + s1[4] + s1[2] + s1[3] + s1[5] ;

writeln('1 : ', s2) ;

s2 : = copy(s1, 1, 1) + copy(s1, 4, 1) + copy(s1, 2, 2) + copy(s1, 5, 1) ;

writeln('2 : ', s2) ;

end.

Результат :

1 : кулон

2 : кулон

2.

Var s : string ;

i, k1, k2 : integer ;

begin

writeln('Введите предложение : ') ;

readln(s) ;

k1 : = 0 ; k2 : = 0 ;

for i : = 1 to length(s) do

case s[i] of

'м' : k1 : = k1 + 1 ;

'н' : k2 : = k2 + 1 ;

end ;

writeln('k1 = ', k1, ' k2 = ', k2) ;

if k1>k2

then writeln('Букв "м" больше')

else if k1.

Diashka200133 22 июл. 2020 г., 22:50:43 | 1 - 4 классы

Два русских слова, при склеивания которых получится тоже русское слово?

Два русских слова, при склеивания которых получится тоже русское слово.

Lenusik190893 17 дек. 2020 г., 08:11:07 | 5 - 9 классы

Помогите сделать в pascal abc?

Помогите сделать в pascal abc.

Дана строка.

Укажите те слова, которые содержат хотя бы одну букву к.

Matiii 18 июл. 2020 г., 16:02:04 | 5 - 9 классы

Программа которая регенерирует любые цифры от 1 - 9, и если получится, то и буквы?

Программа которая регенерирует любые цифры от 1 - 9, и если получится, то и буквы.

Желательный язык программирования Pascal.

Bairamali36 16 июн. 2020 г., 08:59:59 | 5 - 9 классы

Написать программу в которой из букв длинного слова, составляются 2 - 3 слова, путем копирования и склейки частей, и изменение самого слова с помощью удаления и вставки?

Написать программу в которой из букв длинного слова, составляются 2 - 3 слова, путем копирования и склейки частей, и изменение самого слова с помощью удаления и вставки.

Помогите с этим пожалуйста.

Даю 30 баллов.

Используем PASCAL ABC.

Nastasia007TWIX 11 дек. 2020 г., 17:07:16 | 10 - 11 классы

Решить задачу на языке программирования Pascal : Дано предложение в котором между словами 2 или несколько пробелов : "Мама моет Машу"?

Решить задачу на языке программирования Pascal : Дано предложение в котором между словами 2 или несколько пробелов : "Мама моет Машу".

Сколько сочетаний букв "Ma" в предложении.

Massimka 26 авг. 2020 г., 14:18:08 | 10 - 11 классы

Определить сколько слов в заданной строке начинаются на букву "а"?

Определить сколько слов в заданной строке начинаются на букву "а".

Pascal.

Densrochno 11 мая 2020 г., 07:55:30 | 10 - 11 классы

Составьте программу, которая позволяет получить из слова "программирование" слово "программа" и "мир" путем удаления символов?

Составьте программу, которая позволяет получить из слова "программирование" слово "программа" и "мир" путем удаления символов.

87786095109 2 дек. 2020 г., 00:42:45 | 10 - 11 классы

Помогите написать программу в pascal?

Помогите написать программу в pascal.

Дан набор слов, разделенных точкой с запятой ( ; ).

Набор заканчивается двоеточием ( : ).

Определить, сколько в нем слов, заканчивающихся буквой а.

Настя3612 19 дек. 2020 г., 18:34:45 | 10 - 11 классы

Пожалуйста составте программу для Pascal по следующим заданиям : 1) Получить из слов "Язык", "программирования", "Pascal" фразу язык программирования Pascal" 2)Получить из слов "Интер" , "нет" слово "?

Пожалуйста составте программу для Pascal по следующим заданиям : 1) Получить из слов "Язык", "программирования", "Pascal" фразу язык программирования Pascal" 2)Получить из слов "Интер" , "нет" слово "Интернет 3) Дан Символ С вывести его код.

Cafia25 26 нояб. 2020 г., 04:52:15 | 5 - 9 классы

1. Дано предложение?

1. Дано предложение.

Подсчитать число пробелов стоящих на нечетных местах, и заменить такие пробелы на символ « * ».

2. Дано слово, состоящее из количества букв кратного четырем.

Поменять в нем буквы следующим образом : первую с четвертой, вторую с третьей, пятую с восьмой, шестую с седьмой и т.

Д. Например, из слова «карандаш» должны получить «аракшадн».

Язык Pascal ABC.

На этой странице находится вопрос Программирование на pascal abc1?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.