Pascal, цикл while или repeatВвести число?

Информатика | 5 - 9 классы

Pascal, цикл while или repeat

Ввести число.

Найти наибольшую цифру в записи числа.

Ответить на вопрос
Ответы (1)
Dedushka5 26 мая 2021 г., 11:31:53

Var

n : integer ;

max : byte ;

begin

write ('Введите число : ') ;

readln (n) ;

n : = abs (n) ;

while n>0 do

begin

if (n mod 10)>max then max : = n mod 10 ;

n : = n div 10 ;

end ;

write ('Макс.

Цифра - ', max) ;

end.

Kolchenko85 23 мар. 2021 г., 21:19:43 | 10 - 11 классы

Ввести два массива по 10 чисел?

Ввести два массива по 10 чисел.

Найти в каком массиве наибольшее число

(Delphi / Pascal).

Artemkokorev 8 янв. 2021 г., 08:36:58 | 5 - 9 классы

Циклы (for and while) в Pascal ABC?

Циклы (for and while) в Pascal ABC.

Помогите решить задачу, пожалуйста.

Составьте программу, которая выводит на экран все двузначные числа, сумма цифр которых четная.

Yramir 20 апр. 2021 г., 08:20:27 | 5 - 9 классы

Pascal Ввести четыре числа?

Pascal Ввести четыре числа.

Вывести максимальное.

Olgaulsu1978 6 мар. 2021 г., 07:40:19 | 5 - 9 классы

Pascal, цикл "для", составить программуВвести целое число N?

Pascal, цикл "для", составить программу

Ввести целое число N.

Вывести таблицу умножения для N от 1 до 10.

Dovalka 9 янв. 2021 г., 15:12:53 | 5 - 9 классы

Написать программу для Pascal - Ввести натуральное число и определить, какие цифры встречаются несколько раз?

Написать программу для Pascal - Ввести натуральное число и определить, какие цифры встречаются несколько раз.

Riza06 17 апр. 2021 г., 21:05:44 | 5 - 9 классы

Pascal, цикл While или RepeatВвести число?

Pascal, цикл While или Repeat

Ввести число.

Получить другое число, путем удаления единиц, сохранив порядок следования оставшихся цифр.

Dary1998 4 июн. 2021 г., 15:18:56 | 5 - 9 классы

Ввести число N?

Ввести число N.

Вывести число, получаемое выписыванием в обратном порядке цифр числа N.

(Например, 1234, результат 4321).

Pascal цикл while или repeat.

Scoopwithyourfriends 22 авг. 2021 г., 02:46:42 | 5 - 9 классы

Ввести число?

Ввести число.

Вычислить сумму первой и последней цифры.

Pascal цикл while или repeat.

Karina01081999 2 июн. 2021 г., 00:04:30 | 5 - 9 классы

Ввести целое число и определить, верно ли, что в нём ровно 3 цифры?

Ввести целое число и определить, верно ли, что в нём ровно 3 цифры.

Нужно с помощью цикла "while"

Пример :

Введите число :

123

Да

Пример :

Введите число :

1234

Нет.

Gufi2044 28 окт. 2021 г., 00:39:10 | 5 - 9 классы

Ввести натуральное число и определить, какие цифры встречаются несколько раз?

Ввести натуральное число и определить, какие цифры встречаются несколько раз.

ОБЯЗАТЕЛЬНО использовать until, repeat.

Если вам необходимо получить ответ на вопрос Pascal, цикл while или repeatВвести число?, относящийся к уровню подготовки учащихся 5 - 9 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.