(Pascal) Помогите решить пожалуйста , надо их решить с множествами1)поиск симметричных слов перевертышей?

Информатика | 10 - 11 классы

(Pascal) Помогите решить пожалуйста , надо их решить с множествами

1)поиск симметричных слов перевертышей.

2)поиск слов не имеющих повторяющихся букв.

Ответить на вопрос
Ответы (1)
Vinogradov03 7 мар. 2021 г., 00:57:24

Var

s, s1, s2, st1, st2 : string ; i : integer ;

mn : set of char ; b : boolean ;

begin

writeln('Введите текст : ') ;

readln(s) ;

s : = s + ' ' ;

st1 : = '' ; st2 : = '' ;

s1 : = '' ; s2 : = '' ; mn : = [] ; b : = false ;

while pos(' ', s)>0 do delete(s, pos(' ', s), 1) ;

for i : = 1 to length(s) do

if s[i]' ' then begin s1 : = s[i] + s1 ; s2 : = s2 + s[i] ; if s[i] in mn then b : = true ; mn : = mn + [s[i]] ; end else begin if s1 = s2 then st1 : = st1 + s1 + ' ' ; if not b then st2 : = st2 + s2 + ' ' ; s1 : = '' ; s2 : = '' ; mn : = [] ; b : = false ; end ;

if st1''

then writeln('Слова - перевёртыши : ', st1)

else writeln('Слов - перевёртышей нет') ;

if st2''

then writeln('Слова без повторяющихся букв : ', st2)

else writeln('Слов без повторяющихся букв нет') ;

end.

Пример :

Введите текст :

заказ слово комок пробел след пример огонь текст

Слова - перевёртыши : заказ комок

Слова без повторяющихся букв : пробел след.

Dimaneiz 30 июл. 2021 г., 05:29:23 | 5 - 9 классы

Паскаль абс?

Паскаль абс.

Поиск заданного символа в слове - какая функция?

If .

Гайка1 13 июн. 2021 г., 13:33:45 | 5 - 9 классы

Дорогие друзья помогите мне как написать алгоритм поиска слово в словаре?

Дорогие друзья помогите мне как написать алгоритм поиска слово в словаре?

Margaret2004Sweet 23 февр. 2021 г., 10:40:32 | 10 - 11 классы

Команда для поиска и замены слова в тексте?

Команда для поиска и замены слова в тексте.

Вентура 7 мая 2021 г., 14:57:02 | 10 - 11 классы

Что относится к атрибутам поиска?

Что относится к атрибутам поиска?

Leehatesphneedshelp 13 мая 2021 г., 18:00:05 | 5 - 9 классы

Сколько различных слов (в слове две буквы) можно составить из букв R, T, Y, U, I?

Сколько различных слов (в слове две буквы) можно составить из букв R, T, Y, U, I?

Буквы в слове не повторяются.

Пожалуйста помогите!

Xavaeyvazova 30 апр. 2021 г., 16:19:15 | 10 - 11 классы

C + + ?

C + + .

На вход подается строка, содержащая знаки препинания и разделения, и строка, содержащая паттерн поиска.

Необходимо, используя паттерн поиска, вывести все слова из первой введенной строки, которые соответствуют второй.

Мозг9123 18 мая 2021 г., 04:04:03 | 5 - 9 классы

Чем поиск отличается от запроса в аксесс?

Чем поиск отличается от запроса в аксесс?

ВВВВДДДД 11 дек. 2021 г., 03:13:22 | 5 - 9 классы

Помогите, пожалуйста, написать программу на языке паскаль " Напишите программу поиска максимального из четырех чисел с использованием подпрограммы поиска большего из двух?

Помогите, пожалуйста, написать программу на языке паскаль " Напишите программу поиска максимального из четырех чисел с использованием подпрограммы поиска большего из двух.

".

Maksimaaaaasiga 9 окт. 2021 г., 16:06:08 | 5 - 9 классы

Решить в Pascal ABC?

Решить в Pascal ABC.

Пожалуйста, помогите).

Kenizorova 25 июн. 2021 г., 06:57:17 | студенческий

Для одномерного целочисленного массива из 20 элементов решить задачу поиска номера первого нечетного элемента?

Для одномерного целочисленного массива из 20 элементов решить задачу поиска номера первого нечетного элемента.

PASCAL

Плесс.

На этой странице сайта вы найдете ответы на вопрос (Pascal) Помогите решить пожалуйста , надо их решить с множествами1)поиск симметричных слов перевертышей?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.