Помогите написать программу по информатике (на паскале)на перевод из десятичной системы счисления в двоичную?

Информатика | 5 - 9 классы

Помогите написать программу по информатике (на паскале)на перевод из десятичной системы счисления в двоичную.

Ответить на вопрос
Ответы (1)
Topgir2013 29 янв. 2021 г., 20:18:52

Program todec ;

uses crt ;

function detob(x : integer) : string ;

var s : string ;

begin

s : = '' ;

while x>0 do

begin

s : = chr(ord('0') + x mod 2) + s ;

x : = x div 2 ;

end ;

detob : = s ;

end ;

var a : integer ;

begin

clrscr ;

writeln('Введите число : ') ;

readln(a) ;

writeln('Полученное число : ', detob(a)) ;

readln ;

end.

Ang1nka 20 янв. 2021 г., 09:53:46 | 5 - 9 классы

Переведите число из десятичной системы счисления в двоичную (840)?

Переведите число из десятичной системы счисления в двоичную (840).

Илья77777773 2 янв. 2021 г., 06:12:35 | 5 - 9 классы

Сколько число 154 в десятичной системе счисления будет в двоичной?

Сколько число 154 в десятичной системе счисления будет в двоичной?

Tatysya77 17 апр. 2021 г., 16:12:41 | 10 - 11 классы

Помогите?

Помогите!

Как переводить числа в двоичные и десятичные системы?

Вычислите сумму двоичного и десятичного чисел 10(2) + 10(10).

Результат представить в десятичной системе счисления.

Кот160402 2 авг. 2021 г., 06:14:44 | 5 - 9 классы

Двоичное число 100110 в десятичной системе счисления записывается как?

Двоичное число 100110 в десятичной системе счисления записывается как.

Gerka8989 19 янв. 2021 г., 18:18:24 | 5 - 9 классы

Выполнить перевод чисел (64 ; 0, 89) из десятичной системы счисления в двоичную, восьмеричную, шестнадцатеричную?

Выполнить перевод чисел (64 ; 0, 89) из десятичной системы счисления в двоичную, восьмеричную, шестнадцатеричную.

AnnyMealk 5 февр. 2021 г., 04:45:06 | 1 - 4 классы

Переведи число 1110011 из двоичной системы счисления в десятичную систему счисления?

Переведи число 1110011 из двоичной системы счисления в десятичную систему счисления.

Bielovaalbina 14 авг. 2021 г., 17:04:26 | 5 - 9 классы

Переведите число 254 из десятичной системы счисления в двоичную систему счисления?

Переведите число 254 из десятичной системы счисления в двоичную систему счисления.

Veko10 27 дек. 2021 г., 00:12:29 | 5 - 9 классы

Перевести число 21 из десятичной системы счисления в двоичную, восьмеричную и шестнадцатеричную?

Перевести число 21 из десятичной системы счисления в двоичную, восьмеричную и шестнадцатеричную.

Перевести число 11010 из двоичной системы счисления в десятичную.

Александра2003г 16 мая 2021 г., 11:08:00 | 5 - 9 классы

Как из десятичной системы счисления перевести число в двоичную?

Как из десятичной системы счисления перевести число в двоичную?

AndrewCool234466644 6 авг. 2021 г., 07:09:26 | 5 - 9 классы

Перевести из десятичной системы счисления в двоичную 152?

Перевести из десятичной системы счисления в двоичную 152.

Вы находитесь на странице вопроса Помогите написать программу по информатике (на паскале)на перевод из десятичной системы счисления в двоичную? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 5 - 9 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.