Что надо переделать (или добавить) чтобы все работало?

Информатика | 5 - 9 классы

Что надо переделать (или добавить) чтобы все работало?

Program dfgvsdrfg ;

Var A : array [1.

16] of integer ;

k, i : integer ;

begin

writeln('исходные значения') ;

for i : = 1 to 16 do

begin

A[i] : = random (41) - 20 ;

write (A[i], '') ;

end ;

writeln ;

write('нулевые значения имеют элементы с индексами : ')

for i : = 1 to 16 do

if A[i] = 0 then write (i, '') ;

end.

Ответить на вопрос
Ответы (1)
Kristina86656667 24 сент. 2020 г., 21:16:59

Точку с запятой в строке write('нулевые значения имеют элементы с индексами : ') ;

Ну иwrite (A[i], '') ; иwrite (i, '') ; правильнее сделать как(A[i], ' ') ; иwrite (i, ' ') ; (поставить пробел между кавычками).

Komarik21 24 июл. 2020 г., 19:43:53 | 10 - 11 классы

Где ошибка?

Где ошибка?

Const n = 10 ; type TMas = array[1.

N] of integer ; var mas1 : TMas ; procedure ImputMas1(var masTMas : integer) ; var i : integer ; begin for i : = 1 to 10 do begin mas1[i] : = random(n) ; Write(mas1[i] : 3) ; end ; end.

Прыгайзайка 17 янв. 2020 г., 13:47:28 | 5 - 9 классы

Заполните пропуски в программе ввода и вывода 10 целочисленных элементов массива, заданных случайным образом на промежутке [20 ; 40] : Program gh ; var A : array[ 1?

Заполните пропуски в программе ввода и вывода 10 целочисленных элементов массива, заданных случайным образом на промежутке [20 ; 40] : Program gh ; var A : array[ 1.

___] of integer ; i : integer ; begin for i : = 1 to __ do begin A[i] : = random(___) + ____ ; write(____) ; end ; end.

Sds58 12 дек. 2020 г., 05:55:57 | 10 - 11 классы

Написать программу для решения следующей задачи : в заданной числовой последовательности найти и вывести на печать номер первого отрицательного элемента?

Написать программу для решения следующей задачи : в заданной числовой последовательности найти и вывести на печать номер первого отрицательного элемента.

Если все элементы последовательности неотрицательны, то вывести ноль.

Program lab5_5 ; const n = 10 ; type x = array[1.

N] of integer ; var a : x ; i : integer ; k : integer ; begin for i : = 1 to n do begin a[i] : = - 10 + random (91) ; write (A[i] : 4) end ; writeln ; k : = 0 ; for i : = n downto 1 do if a[i]< ; 0 then begin k : = I end ; if k> ; 0 then writeln (‘Индекс отрицательного элемента = ’, k : 1) else writeln (‘В массиве нет отрицательных элементов’) ; readln ; end.

Как сделать эту программу без random чтоб работало в Pascal ABC?

Marta134 18 сент. 2020 г., 05:01:56 | 10 - 11 классы

Program pr ; var mas : array[1?

Program pr ; var mas : array[1.

10] of integer ; i, min, ind : integer ; Begin randomize ; For i : = 1 to 10 do Begin mas[i] : = Random(100) ; write(mas[i], ' ') ; End ; writeln() ; min : = mas[1] ; For i : = 1 to 10 do Begin If (min> ; mas[i]) then End ; write('Минимальный элемент массива : ', min) ; End.

Что не верно?

Вот задача : Дан одномерный массив А длиной N.

Определить, на какой позиции нахо - дится минимальный элемент массива.

Sashapodkaifom 12 мая 2020 г., 09:27:16 | 5 - 9 классы

Что тут неправильно ?

Что тут неправильно ?

Var a : array[1.

10, 1.

10] of integer ;

i, m, n, j, k : integer ;

s : real ;

begin

Write ('m = ') ; readln(m) ;

write('n = ') ; readln(n) ;

for i : = 1 to m do

for j : = 1 to n do

a[i, j] : = random(50) ;

for i : = 1 to n do

begin for j : = 1 to m do write(a[i, j] : 4) ; writeln ; end ;

for i : = 0 to m do

begin for j : = 0 to n do

begin if a[i][j] = 0 then

begin a[i][j] : = i + j ; end ; end ; end ;

a[i, j] : = k ; writeln('k = ', k) ; end.

Дан массив.

Изменить массив по следующему правилу Все нулевые элементы заменить суммой индексов элемента ;

NELLYASX 9 июл. 2020 г., 15:08:30 | 10 - 11 классы

Помогите в Паскале изменить текст программы так, чтобы выводила не только индекс элемента, но и его значение var a : array[1?

Помогите в Паскале изменить текст программы так, чтобы выводила не только индекс элемента, но и его значение var a : array[1.

10]of integer ; i, k, n : integer ; begin n : = 0 ; k : = 0 ; Writeln('Исходный массив : ') ; Randomize ; for i : = 1 to 10 do begin a[i] : = Random(51) - 25 ; Write(a[i], ' ') ; end ; Writeln ; for i : = 10 downto 1 do if a[i]> ; 0 then begin k : = k + 1 ; if k = 2 then n : = i ; end ; if k = 0 then Writeln('В массиве нет положительных элементов!

') else Writeln('Номер предпоследнего положительного элемента : ', n) ; Readln ; end.

Make96th 18 янв. 2020 г., 03:04:39 | 10 - 11 классы

USES Crt ; const N = 10 ; VAR A : array[1?

USES Crt ; const N = 10 ; VAR A : array[1.

N] of integer ; k : integer ; Function FUN : integer ; Var i, M : integer ; Begin writeln('Введите число M = ') ; readln(M) ; k : = 0 ; for i : = 1 to N do if A[i] FUN : = k ; End ; Procedure SOSTMAS ; Var i : integer ; Begin for i : = 1 to N do begin A[i] : = Random(199) - 100 ; write(A[i] : 5) ; end ; Writeln ; end ; BEGIN SOSTMAS ; Writeln(FUN) ; что то неправильно говорят массив.

Oksankataktash 9 нояб. 2020 г., 16:25:18 | 10 - 11 классы

Здравствуйте, что в этом коде на free pascal считает k?

Здравствуйте, что в этом коде на free pascal считает k?

Program SiberiaBoss ; var a : array[1.

100] of integer ; i, k, n : integer ; begin readln(n) ; randomize ; for i : = 1 to n + 1 do begin a[i] : = random(10) ; if a[i] < ; i then k : = k + 1 ; writeln(a[i] : 3) ; end ; writeln('Itogo ', k) ; end.

Lorasa 11 мая 2020 г., 18:48:44 | 10 - 11 классы

Помогите пожалуйста написать в С + + ?

Помогите пожалуйста написать в С + + .

Program Matrix7 ; var a : array [1.

10, 1.

10] of integer ; M, N, K, i, j : Integer ; begin Write('N : ') ; Readln(N) ; Write('M : ') ; Readln(M) ; Write('K : ') ; Readln(K) ; for i : = 1 to M do begin writeln(i, ' : ') ; for j : = 1 to N do begin Write(j, ' : ') ; Read(a[i, j]) ; end ; end ; for j : = 1 to N do begin Write(' : ', a[K, j]) ; end ; writeln(' : ') ; end.

Дана матрица размера М и N и целое число К ( 1≤ К ≤ М).

Вывести элементы К - й строки данной матрицы.

Bk25 19 окт. 2020 г., 06:46:31 | 5 - 9 классы

Определить s : 1) Var s, k : integer ; Begin s : = 0 ; for k : = 14 to 18 do s : = s + 7 ; writeln(s) ; End?

Определить s : 1) Var s, k : integer ; Begin s : = 0 ; for k : = 14 to 18 do s : = s + 7 ; writeln(s) ; End.

2) Var s, k : integer ; Begin s : = 0 ; for k : = 1 to 11 do s : = s + 12 ; write(s) ; End.

3) var s, k : integer ; begin s : = 100 ; for k : = 0 to 10 do s : = s - 5 ; writeln (s) ; end.

Вы находитесь на странице вопроса Что надо переделать (или добавить) чтобы все работало? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 5 - 9 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.