Заполните пропуски в программе ввода и вывода 10 целочисленных элементов массива, заданных случайным образом на промежутке [20 ; 40] : Program gh ; var A : array[ 1?

Информатика | 5 - 9 классы

Заполните пропуски в программе ввода и вывода 10 целочисленных элементов массива, заданных случайным образом на промежутке [20 ; 40] : Program gh ; var A : array[ 1.

___] of integer ; i : integer ; begin for i : = 1 to __ do begin A[i] : = random(___) + ____ ; write(____) ; end ; end.

Ответить на вопрос
Ответы (1)
Siledanas 17 янв. 2020 г., 13:47:35

Program gh ; var A : array[ 1.

10] of integer ; i : integer ;

begin for i : = 1 to 10 do begin A[i] : = random(20) + 20 ; write(A[i]) ; end ;

end.

Komarik21 24 июл. 2020 г., 19:43:53 | 10 - 11 классы

Где ошибка?

Где ошибка?

Const n = 10 ; type TMas = array[1.

N] of integer ; var mas1 : TMas ; procedure ImputMas1(var masTMas : integer) ; var i : integer ; begin for i : = 1 to 10 do begin mas1[i] : = random(n) ; Write(mas1[i] : 3) ; end ; end.

Марина24 24 сент. 2020 г., 06:31:21 | 10 - 11 классы

Помогите найти ошибку в программе?

Помогите найти ошибку в программе.

Умножение двумерного массива.

Pas(29) : Нельзя преобразовать тип integer к array [1.

100] of array [1.

100] of integer.

Вот сама программа : умножение матриц в обратном порядке, т.

Е первый элемент на последний, второй на предпоследний и.

Т. д.

Var x : integer ; a1 : array[1.

100, 1.

100] of integer ; a2 : array[1.

100, 1.

100] of integer ; a3 : array[1.

100, 1.

100] of integer ; i, j, m, n : integer ; begin writeln('Введите размер матрицы') ; readln(m, n) ; for i : = 1 to m do begin for j : = 1 to n do end ; begin writeln('Введите элементы первой матрицы') ; for i : = 1 to m do begin for j : = 1 to n do readln(a1[i, j]) ; end ; end ; begin writeln('Введите элементы второй матрицы') ; for i : = 1 to m do begin for j : = 1 to n do readln(a2[i, j]) ; end ; end ; begin a3 : = a1[i, j] * a2[x + 1 - i, x + 1 - j] ; for i : = 1 to m do begin for j : = 1 to n do readln(a3[i, j]) ; end ; writeln ; end ; readln ; end.

ЗАРАНЕЕ СПАСИБО!

Йчуметнлщдшщгапм5689 22 авг. 2020 г., 00:02:41 | 5 - 9 классы

Найдите значение переменной А после выполнения программы VAR A : INTEGER BEGIN A : = SQRT(16) : END?

Найдите значение переменной А после выполнения программы VAR A : INTEGER BEGIN A : = SQRT(16) : END.

Sds58 12 дек. 2020 г., 05:55:57 | 10 - 11 классы

Написать программу для решения следующей задачи : в заданной числовой последовательности найти и вывести на печать номер первого отрицательного элемента?

Написать программу для решения следующей задачи : в заданной числовой последовательности найти и вывести на печать номер первого отрицательного элемента.

Если все элементы последовательности неотрицательны, то вывести ноль.

Program lab5_5 ; const n = 10 ; type x = array[1.

N] of integer ; var a : x ; i : integer ; k : integer ; begin for i : = 1 to n do begin a[i] : = - 10 + random (91) ; write (A[i] : 4) end ; writeln ; k : = 0 ; for i : = n downto 1 do if a[i]< ; 0 then begin k : = I end ; if k> ; 0 then writeln (‘Индекс отрицательного элемента = ’, k : 1) else writeln (‘В массиве нет отрицательных элементов’) ; readln ; end.

Как сделать эту программу без random чтоб работало в Pascal ABC?

TasyaSnow 22 дек. 2020 г., 12:59:22 | 5 - 9 классы

Укажите результат выполнения программы var a, b : integer procedure proc(var a : integer ; b : integer) begin b : = 4 ; a : = 6 ; b : = a + b ; end ; begin a : = 2 ; b : = 3 ; proc(a, b) ; writeln(a, ?

Укажите результат выполнения программы var a, b : integer procedure proc(var a : integer ; b : integer) begin b : = 4 ; a : = 6 ; b : = a + b ; end ; begin a : = 2 ; b : = 3 ; proc(a, b) ; writeln(a, ' ', b) ; end.

Kerrigan54 3 авг. 2020 г., 16:55:50 | 10 - 11 классы

Задача по двумерному массиву?

Задача по двумерному массиву.

Создать новый одномерный массив из элементов, стоящих под главной диагональю.

Вот шапочка массива : uses crt ; type mas = array [1.

8, 1.

8] of integer ; var M : mas ; i, j : integer ; begin randomize ; for i : = 1 to 8 do begin for j : = 1 to 8 do begin M[i, j] : = random(190) - 95 ; write(M[i, j] : 4) ; end ; writeln ; end ;

Marta134 18 сент. 2020 г., 05:01:56 | 10 - 11 классы

Program pr ; var mas : array[1?

Program pr ; var mas : array[1.

10] of integer ; i, min, ind : integer ; Begin randomize ; For i : = 1 to 10 do Begin mas[i] : = Random(100) ; write(mas[i], ' ') ; End ; writeln() ; min : = mas[1] ; For i : = 1 to 10 do Begin If (min> ; mas[i]) then End ; write('Минимальный элемент массива : ', min) ; End.

Что не верно?

Вот задача : Дан одномерный массив А длиной N.

Определить, на какой позиции нахо - дится минимальный элемент массива.

Make96th 18 янв. 2020 г., 03:04:39 | 10 - 11 классы

USES Crt ; const N = 10 ; VAR A : array[1?

USES Crt ; const N = 10 ; VAR A : array[1.

N] of integer ; k : integer ; Function FUN : integer ; Var i, M : integer ; Begin writeln('Введите число M = ') ; readln(M) ; k : = 0 ; for i : = 1 to N do if A[i] FUN : = k ; End ; Procedure SOSTMAS ; Var i : integer ; Begin for i : = 1 to N do begin A[i] : = Random(199) - 100 ; write(A[i] : 5) ; end ; Writeln ; end ; BEGIN SOSTMAS ; Writeln(FUN) ; что то неправильно говорят массив.

Spasibo123 5 февр. 2020 г., 18:45:06 | 10 - 11 классы

Что напечатает данная программа : Var x : = Integer Begin x : = 2 WriteLn('x + 1 = ', x) End?

Что напечатает данная программа : Var x : = Integer Begin x : = 2 WriteLn('x + 1 = ', x) End.

Помаг 24 сент. 2020 г., 21:16:58 | 5 - 9 классы

Что надо переделать (или добавить) чтобы все работало?

Что надо переделать (или добавить) чтобы все работало?

Program dfgvsdrfg ;

Var A : array [1.

16] of integer ;

k, i : integer ;

begin

writeln('исходные значения') ;

for i : = 1 to 16 do

begin

A[i] : = random (41) - 20 ;

write (A[i], '') ;

end ;

writeln ;

write('нулевые значения имеют элементы с индексами : ')

for i : = 1 to 16 do

if A[i] = 0 then write (i, '') ;

end.

Перед вами страница с вопросом Заполните пропуски в программе ввода и вывода 10 целочисленных элементов массива, заданных случайным образом на промежутке [20 ; 40] : Program gh ; var A : array[ 1?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.