В массиве из 15 чисел подсчитать сумму и количество положительных элементов?

Информатика | 10 - 11 классы

В массиве из 15 чисел подсчитать сумму и количество положительных элементов.

Помогите, программа на языке паскаля.

Ответить на вопрос
Ответы (2)
Umar15000 18 июн. 2021 г., 15:04:58

Var a : array[1.

15] of integer ; i, sum, count : integer ;

begin for i : = 1 to 15 do readln(a[i]) ; sum : = 0 ; count : = 0 ; for i : = 1 to 15 do if a[i] > 0 then begin sum : = sum + a[i] ; inc(count) ; end ; writeln(sum, ' ', count) ;

end.

Slavasemerenko 18 июн. 2021 г., 15:05:02

Program n1 ;

var a : array [1.

15] of integer ;

S, k, i : integer ;

begin

for i : = 1 to 15 do readln(a[i]) ;

S : = 0 ;

k : = 1 ;

for i : = 1 to 15 do

begin

if(a[i]>0) then

begin

S : = S + a[i] ;

k : = k + 1 ;

end ;

end ;

writeln(k) ;

writeln(S) ;

end.

Paluan200115 7 янв. 2021 г., 17:44:57 | 5 - 9 классы

Паскаль, ребятки?

Паскаль, ребятки?

Кто тут гений информатики?

Помогите, пожалуйста!

Написать программу и блок - схему Дан массив из 10 целых чисел, заполненный генератором случайных чисел.

Найти минимальный элемент в массиве и подсчитать количество таких элементов в массиве.

Cherepok2002 29 янв. 2021 г., 17:35:21 | 10 - 11 классы

Найти сумму положительных и количество нечетных элементов массива А(10)?

Найти сумму положительных и количество нечетных элементов массива А(10).

Через паскаль , срочно пожалуйста !

Sp1997 21 мая 2021 г., 06:45:10 | 10 - 11 классы

Заменить все положительные элементы массива на максимальный элемент массива ?

Заменить все положительные элементы массива на максимальный элемент массива .

Напишите программу в ПАСКАЛЬ.

Subaru04 14 мая 2021 г., 10:31:45 | 10 - 11 классы

Найти средние арифметические положительных и отрицательных элементов массива Паскаль написать программу?

Найти средние арифметические положительных и отрицательных элементов массива Паскаль написать программу.

Мариша1990 19 авг. 2021 г., 21:27:19 | 5 - 9 классы

Составте программу позволяющую подсчитать в массиве число положительных и нулевых элементов?

Составте программу позволяющую подсчитать в массиве число положительных и нулевых элементов.

Sasha1326 10 апр. 2021 г., 18:46:02 | 10 - 11 классы

Найти средние арифметические положительных и отрицательных элементов массива, написать программу в паскале?

Найти средние арифметические положительных и отрицательных элементов массива, написать программу в паскале.

Ketp83 1 янв. 2021 г., 01:00:15 | 10 - 11 классы

В массиве найти сумму и кол - во элементов между первым и последним положительными элементами?

В массиве найти сумму и кол - во элементов между первым и последним положительными элементами.

(паскаль).

0992448003 12 мая 2021 г., 04:54:40 | 5 - 9 классы

Составить программу?

Составить программу!

На языке Паскаль

Подсчитать количество отрицательных чисел из 10 введенных с клавиатуры.

Найти количество чисел, не больше 100.

XOTTABX 8 апр. 2021 г., 00:38:57 | 5 - 9 классы

Найти сумму элементов одномерного массива с 7 целых чисел язык Паскаль?

Найти сумму элементов одномерного массива с 7 целых чисел язык Паскаль.

Anastasiyafrenov 18 нояб. 2021 г., 06:43:58 | студенческий

Помогите пожалуйста, срочно?

Помогите пожалуйста, срочно!

Подсчитать количество чётных элементов массива, заданного датчиком случайных чисел.

Паскаль.

На странице вопроса В массиве из 15 чисел подсчитать сумму и количество положительных элементов? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.